Happy New Year! Today we are happy to release an updated version of Seas0nPass that supports an untethered jailbreak of the latest 4.4.4 (iOS 5.0.1) AppleTV software. Big thanks goes to the world famous @pod2g for doing the lion's share of the work to make this new version possible.

What's new in AppleTV 4.4.4?

  • AirPlay Mirroring: Now with video mirroring – wirelessly stream what’s on your iPad 2 screen to your HDTV.
  • Photo Stream: View photos recently taken on your iOS device and pushed to your Photo Stream in iCloud.
  • Trailers: A whole new way to browse and view hundreds of the latest theatrical trailers.
  • National Hockey League: Watch live games. View highlights, scores, and more.
  • Wall Street Journal Live: Watch up-to-date news, business commentary, and financial analysis from leading experts.
  • Audio output: Addresses an issue in which audio may not play through the optical port when the TV is turned off.
  • Netflix: Added support for Netflix in Mexico and Latin America.
  • Stability and performance: version 4.4.4 includes general performance and stability improvements, including a fix for an issue that displayed an error when playing some video content.

Note: If you're already running a tethered version of 4.4.4 you will need to re-jailbreak using Seas0nPass to take advantage of the new untethered version. 

Which plugins are supported on 4.4.4?

  • Couch Surfer (works)
  • Last.fm (works)
  • Media Player (works)
  • NitoTV (works)
  • Overflow (works)
  • Plex (works)
  • Remote HD (works)
  • Rowmote (works)
  • RSS Feeds (works)
  • Weather (works)
  • XBMC (works)

How do I get it?

As always, Seas0nPass is available as a free download from Seas0nPass.com.

Troubleshooting tips can be found here.

Enjoy Smile

Comments

Submitted by Smashby on December 30, 2011 - 7:49pm

Which is more stable...installing XBMC from the Maintenance Tab, or from NitoTV? I notice a different look, and was wondering if one had an advantage over the other?

Submitted by Curious Consumer on December 30, 2011 - 9:37pm

I installed from the maintenance tab, but I have not noticed any difference from the tethered jailbreak so far. Other than the fact that many navi-x movies will not play. However, that may be because of my internet connection. Not sure.

Submitted by Curious Consumer on December 30, 2011 - 9:39pm

That is strange. A lot of people have mentioned similar problems. Maybe your cache is full? Google cache full atv and you can find out how to ssh into the apple tv and delete your cache files. Maybe that will help? I have not experienced the problem so I can't be much help Frown

Submitted by Curious Consumer on December 30, 2011 - 9:40pm

Keep trying. I had to do it a couple times before it worked. iTunes is strange.

Submitted by Curious Consumer on December 30, 2011 - 9:43pm

Use PS3 media server! It works way better than SMB without buffering, and works great with XBMC. Just google and download! It uses UPNP, which is superior Tongue

Submitted by johnk.9570 on December 30, 2011 - 10:25pm

Did you reinstall aTV after you installed the new Seas0nPass?  If no, log into your account and grab the recent version from the downloads page.

Submitted by jsfer on December 30, 2011 - 11:09pm

Thanks! work great

Submitted by aceedburn on December 30, 2011 - 11:10pm

Worked great on first try. Well done and great great job guys. God bless you and happy new year. Great start to the new year. Apple tv running 4.4.4 seasonpass untether works like a charm.

Submitted by Anonymous on December 30, 2011 - 11:28pm

I take this isn't working for 4.4.2? I tried it and get the tethered screen at boot up.

Submitted by mscreations on December 30, 2011 - 11:50pm

After a LOT of fighting I finally got this to work. I don't believe it was the fault of Seas0nPass. I think it was because Apple's servers stopped responding for about 3 hrs.

Anyways, I had to restore it to factory first before re-jailbreaking it. I'm not sure why, but I kept getting seemingly random errors when trying to straight upgrade it. 

One note that I will make to help anyone else that runs into it: If you are running Windows 7 and after it creates the IPSW, it seems to work better if you manually launch iTunes to restore it. And make sure you don't put it into DFU mode after the "Create IPSW" tool has finished. Go straight to iTunes and restore it. I saw that something gets uploaded to the ATV during the tools execution, but I don't know if it gets killed by resetting the unit or putting it back in DFU mode.

Great work though! So glad to finally be untethered. I was never able to downgrade to 4.3 for whatever reason (I have my SHSH blobs...) so I've been forced to tether everytime I lose power, which has been quite often recently. 

Submitted by Christian HB on December 31, 2011 - 12:04am

I have a 6 months old AppleTV Black which I never used. Now I want to. Should I update this using iTunes before jailbreaking using seasonPass - or just leave it as it is and go ahead?

Submitted by vsvella on December 31, 2011 - 12:20am

I tried the update, it looks like its jail broken, however I have no Maintenance menu (ie I just have the FC icon on the bottome LHS of my screen). I have tried to re-install several times and end up with the same result. (i can access the box via putty) Has anyone else had a similar experience? did you fix it, mind sharing how if you did:)

Submitted by chrisg.1682 on December 31, 2011 - 12:30am

Changed from teathered seas0npass 4.4.4 to today's unteathered release.  Install went great but now I can't access my NAS storage device.  I keep getting the "AFP connection failed" error message.  I seem to recall the connection being NAS not AFP but there is no way to change it in the settings menu.  Any ideas?  I restored from backup so I didn't change any settings.  My NAS device is a 2 TB Goflex Home

Submitted by harrisony.0466 on December 31, 2011 - 12:49am

What does this mean? I tried y and enter, no luck. 

 

The following NEW packages will be installed:

  org.xbmc.xbmc-atv2

0 upgraded, 1 newly installed, 0 to remove and 10 not upgraded.

Need to get 41.1MB of archives.

After this operation, 0B of additional disk space will be used.

WARNING: The following packages cannot be authenticated!

  org.xbmc.xbmc-atv2

Install these packages without verification [y/N]? reboot

E: Some packages could not be authenticated

Submitted by grahamgorton on December 31, 2011 - 12:53am

sounds like you need to install aTV Flash again.

Submitted by Ray on December 31, 2011 - 1:40am

@fircore

You rock ! Always fast in response and atv flash black rules !! All you guys who don't have atv flash black BUY IT than your atv2 will be atv2 2.0.

Question

I'm running on untethered 4.3, setup atv flash black,xbmc, wd my book NAS, own background, icefilms.

When I update it to 4.4.4 can I configure this back to above setting and does it works, because some notes it says it can't play files from my NAS and that's very important for me.

Thanx for the answer and keep up the good work !

Submitted by MACiek.PL on December 31, 2011 - 2:00am

I have a problem pops up information:

"iTunes restore script failed!, selecting IPSW in Finder ..."

- Mac OS X 10.7.2, iTunes 10.5.2. (11)

... what to do?

Submitted by MACiek.PL on December 31, 2011 - 2:00am

I have a problem pops up information:

"iTunes restore script failed!, selecting IPSW in Finder ..."

- Mac OS X 10.7.2, iTunes 10.5.2. (11)

... what to do?

Submitted by adrianw.6946 on December 31, 2011 - 2:06am

Thanks for the update.

Mine went very much like the first time I did an untethered 4.3 jailbreak.  First try got a 1601 error, but just ran it again and updated without any problems the second time (same usb cable/port)

Will keep an eye out on the Plex update as i tend to prefer this to the Firecore Media Player, although that's fine until Plex is fixed.  Not a fan of the XBMC interface.

Worth upgrading for the Airplay mirroring from my iPad

Submitted by fredv.108362 on December 31, 2011 - 2:07am

Instructions how to get PLEX (0.90 beta 4) on a Jailbreaked Apple TV 2 (4.4.4):

Be sure your Apple TV2 is on

1) Start Terminal on your iMac
2) Type: ssh root@apple-tv.local
3) Type: alpine (the password)
4) Type: echo "deb http://www.ambertation.de ./downloads/PLEX/" > /etc/apt/sources.list.d/plex.list
5) Type: apt-get remove com.plex.client-plugin
6) Type: apt-get update
7) Type: apt-get install com.plex.client-plugin=0.0.9.0.0-312c11b0

Now your Apple TV2 should reset and when its starters there is PLEX.

(hint: you can also copy => paste the lines in terminal)

suc6

iFred

www.ifred.nl

[[wysiwyg_imageupload:133:]]

 

 

Submitted by adrianw.6946 on December 31, 2011 - 2:14am

Brilliant!

Thanks for those instructions.  Plex installed and everything as it was running 4.3 but now 4.4.4

Submitted by neo_strut on December 31, 2011 - 2:27am

i have problem restoring the generated AppleTV2,1_4.4.4_9A406a_SP_Restore.ipsw with iTunes 10.5.2.11 (latest). It says an unknown error occured (3194). I've tried many times, but still the same error.

Anyone have idea to resolve this? I was able to restore my aTV2 to factory setting and at the same time updated using iTunes. Then, I tried running Seas0nPass again to generate the new custom IPSW. Error 3194 still deter me from Custom Restore (shift+Restore).

Help appreciated.

Thanks.

Submitted by josephk.87500 on December 31, 2011 - 2:29am

Likewise, I can only now connect via AFP, We seem to have lost SMB. SMB worked in the Teathered SeasonPass I was using Yesterday.  I will post a ticket.  Mainmenu Weather seems to have broken as well. (looks like wrong font size or frame size as as bit of text is cut short with ...)

Submitted by fredv.108362 on December 31, 2011 - 2:31am

Update:

 

in stead of 2) Type: ssh root@apple-tv.local you can use 2) Type: ssh root@your IP of the Apple TV2 (eg. 192.168.1.75)

and

maybe you have to do the instructions 2-times , just do it

 

iFred

Submitted by vsvella on December 31, 2011 - 2:53am

I'm such  dush!!

 

I did a clean install. All i needed to do was run the "aTV Flash.exe" file. All is good now!!

 

This is awsome. Thanks V

Submitted by Anonymous on December 31, 2011 - 3:19am

itunes couldn't restore the new firmware and was stuck at "Preparing Apple TV" then threw 1604 error. The Apple TV would no longer boot properly either. Downladed iReb to get it into DFU mode then I could restore through iTunes and it worked! thanks!

Submitted by Anonymous on December 31, 2011 - 3:38am

Ok, after like an hour of jb'ing. I finally got the atv2 to work using a macbook pro (was on PC). Everything seems to work except that when I install xbmc.

Also issue a reboot or whenever I restart the atv2 does not startup.

It needs to be unplug for like half a minute and reset another reset for it to startup.

idk if this is a bug or not?

Submitted by Anonymous on December 31, 2011 - 3:40am

Anyone find bugs?

I told about an hour to get it running using PC. But gave up and used a macbook pro and it worked. Then I install xbmc and rebooted.

The atv2 does not reboot or load. I have to unplug the power/hdmi and wait then replug and another reset for it to startup.

Anyone with similar problem?

Submitted by Anonymous on December 31, 2011 - 4:04am

+1

Submitted by NotSoSmart on December 31, 2011 - 4:06am

Updated AppleTV to 4.4.4 as jailbreak released using Seas0nPass, followed all steps as described.
During restore of AppleTV2,1_4.4.4_9A406a_Restore I get a error 1602 during restore using itunes version 10.5.2.11

All the processes were carried out on PC running Windows 7 Pro 32bit.

Anyone else having the same problem or could provide help would be great!

Happy New Year to you all!

Submitted by ady199 on December 31, 2011 - 4:16am

Had problems with 1600 message in iTunes - all I had to do to fix it was to put the ATV 2 into DFU Mode using iReb r4 and all worked perfectly :)

 

Am I supposed to see a menu option for Seas0nPass? as I don't see anything, only the Firecore logo on the bottom right of the screen.

Thanks again Firecore

 

Submitted by marksthomas on December 31, 2011 - 6:21am

All working great on my 3 ATV2's - sterling work chaps.

 

Grin

Submitted by marksthomas on December 31, 2011 - 6:22am

No - once you JB'd with Seas0nPass then install ATV Flash - the firecore logo is just to show the JB has worked... 

Submitted by Canissa on December 31, 2011 - 6:49am

Same thing on Mac as well...
I cannot jb my ATV2 with seasonpass, I got error 1600 and 1602 all the time...

Submitted by firewall75 on December 31, 2011 - 6:58am

Have problems with the upgrade. Always get the 1602 error when iTunes is upgrading Firmware!

Please help!

Submitted by canissa on December 31, 2011 - 7:10am

Error 1602 all the time...
No hope.

Submitted by Anonymous on December 31, 2011 - 7:33am

For all suffering with iTunes errors, I was having the same issues.

As soon as I switched from an OS X Lion machine to a Windows machine it worked first time.

I can only suggest you try the same. Good luck.

Submitted by DerMarkus on December 31, 2011 - 7:33am

Hi all, perhaps this is not the right place, so please forgive me if I'm wrong. Have an issue with installing a plugin (xStream) to my XBMC Eden Beta on ATV2. Always get the error that the zip file that I want to install via "Install zip file" has not the right structure. The plugin was working on Dharma....so did the required structure for add ons change in Eden? Why isn't it possible for me to install the zip...have read a lot of posts in other forums and they were able to install the same file I am using. Thanks a lot for your support and a Happy New Year!! Cheers Markus

Submitted by Anonymous on December 31, 2011 - 8:08am

My problem that Terminal asks for a password but doesn't let me type any letters thus I cannot go further. What's wrong?

Submitted by boriZ on December 31, 2011 - 8:12am

Turn of firewall, than it sould work great!

Submitted by jlouis on December 31, 2011 - 8:14am

I have this message (i'm french boy...)
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
9a:f8:47:d2:9f:f3:13:6b:1c:2a:65:42:fc:0a:0d:c0.
Please contact your system administrator.
Add correct host key in /Users/jlouishouplain/.ssh/known_hosts to get rid of this message.
Offending key in /Users/jlouishouplain/.ssh/known_hosts:3
RSA host key for 192.168.1.92 has changed and you have requested strict checking.
Host key verification failed.

have you a idea?

Submitted by empirejose on December 31, 2011 - 8:15am

what about the plex , how do i add plea 0.9 any one can help ?

 

Submitted by canissa on December 31, 2011 - 8:16am

I have already done it.

Submitted by ianw.103103 on December 31, 2011 - 8:29am

Hi,

I have just run the process through. I have created the restore file no problems. The process then kicked off the restore again no problem. I then got a 1602 error. I have put the atv in dfu again and tried many times. Eventually I am told it was successful. All I get now is apple boot screen then nothing. I am using xp pro, lastest itunes and 4.4.4 atv2.

Submitted by ianw.103103 on December 31, 2011 - 8:29am

Hi,

I have just run the process through. I have created the restore file no problems. The process then kicked off the restore again no problem. I then got a 1602 error. I have put the atv in dfu again and tried many times. Eventually I am told it was successful. All I get now is apple boot screen then nothing. I am using xp pro, lastest itunes and 4.4.4 atv2.

Submitted by dumitru.robert on December 31, 2011 - 8:30am

nice....it works...thnks

Submitted by Anonymous on December 31, 2011 - 8:36am

you've jailbroken your device several times, right? delete your known_host file.
http://forums.macrumors.com/showthread.php?t=354258

Submitted by saverrio on December 31, 2011 - 9:05am

Its NOT XBMC that is the problem. SMB is not working for ATVFlash. Media Player will not recognize SMB. So i tried XBMC and it is the same thing. Everything was working fine before i upgraded to ATV 4.4.4, Season Pass, and ATVFlash.

Submitted by happygq on December 31, 2011 - 9:08am

I got it!!!

 

How do I JB 4.4.4:

1. perform official restore in Itunes

2. once successful finished, launch SeasOnPass (the latest version of course), follow the normal instruction BUT, always keep power cord connected!!!

3. first time you will get an error in iTunes at the end, no worry, just redo again (don't touch your ATV)

4. the second time when you get through the DFU mode and looking at iTunes loading the firmware, at the end you will still see an error, but this time the code is "1602", which means you passed!!!

 

have a try.

hahaha

/Eric

Submitted by empirejose on December 31, 2011 - 9:18am

i got too 1602 its mean ok , i did this for 15 times today . but main problem is my plex  ,i don't have plex and don't know how to config xmbc since its do not see my library except iTunes. any one facing same problem? on this page it says only plex 0.9 beta 

does anyone know how to put this 0.9 plex into atv2