21 posts / 0 new / Last post
#1  August 6, 2019 - 1:46pm
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 37
Kudos: 4

Hi,

I use Infuse connected to a Plex library. I usually watch series in continuous play. If I cancel the playback of an episode immediately after it has started, it is marked as watched next time Plex is synchronized. This does not happen when I play the series on Plex.

Thanks

  August 8, 2019 - 12:28pm
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 13,791
Kudos: 1,151

If this happens again, can you drop us a quick note from your device?

https://support.firecore.com/hc/en-us/articles...

Infuse 6 for iOS and Apple TV is now available!

  August 8, 2019 - 1:55pm
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 37
Kudos: 4

Here is a sample. After episode 9, episode 10 is played. When canceling the playback of episode 10, it marks episode 10 as played. This happens on every TV Show. I will try to reproduce on iOS and send logs.

http://www.vdata.net/sample.mov

  August 8, 2019 - 2:04pm
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 13,791
Kudos: 1,151

Thanks! We'll take a look into what's going on here.

Infuse 6 for iOS and Apple TV is now available!

  August 8, 2019 - 2:06pm
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 37
Kudos: 4

In iOS it has the same behavior.

I've sent request #119459 from iOS.

BTW If If let the episode play until it's resumable, it's not marked as watched.

  August 8, 2019 - 2:08pm
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 13,791
Kudos: 1,151

Thanks. That is helpful to know.

We'll figure out what's going on here.

Infuse 6 for iOS and Apple TV is now available!

  August 9, 2019 - 1:36am
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 37
Kudos: 4

Another thing I've seen. It's not related to continuous play, if you play a single episode and you cancel playback before reaching resume time, it's also marked as watched. This doesn't happend on movies, only on TV shows.

  August 9, 2019 - 2:44am
philosen's picture
Beta Tester
Offline
Joined: Sep 2016
Posts: 21
Kudos: 5

Just happened to me as well. I'm running the latest Infuse and tvOS beta though.

  August 20, 2019 - 11:47am
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 37
Kudos: 4

The issue still persists in version 6.1.5. Any progress on this? Have you been able to reproduce the bug?

  August 27, 2019 - 11:35am
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 37
Kudos: 4

I've done a test, I've uninstalled Trakt on Plex Server and I've enabled Trakt on Infuse. Apparently this problem has disappeared magically. I will do more playing tests and report the results.

  August 27, 2019 - 1:15pm
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 37
Kudos: 4
  philosen wrote:

Just happened to me as well. I'm running the latest Infuse and tvOS beta though.

Do you use Trakt plugin on your Plex Server?

  August 27, 2019 - 3:46pm
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 37
Kudos: 4
  vdatanet wrote:

I've done a test, I've uninstalled Trakt on Plex Server and I've enabled Trakt on Infuse. Apparently this problem has disappeared magically. I will do more playing tests and report the results.

No, issue persists. It takes longer, but If you cancel playback when episode is not resumable, it's marked as watched. Please fix it asap because I miss episodes without realizing. I have to be carefull and remember the last watched episode.

  September 11, 2019 - 11:32am
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 37
Kudos: 4

Is there any chance that this is fixed in the next release version?

  September 24, 2019 - 12:39am
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 37
Kudos: 4

Bug still present in version 6.1.7

  September 26, 2019 - 12:11pm
OMGzilla's picture
Offline
Joined: Jun 2018
Posts: 17
Kudos: 21

Hey guys, same issue here. I hadn't made the connection of this triggering when cancelling playback on startup but that makes sense now. When I get to the end of an episode, I typically hit the "Chapter Up" command on my Harmony to skip past the credits and force the next episode to queue up from the start. If I'm not planning on watching the next episode right away, I then exit out.

  September 26, 2019 - 12:27pm
OMGzilla's picture
Offline
Joined: Jun 2018
Posts: 17
Kudos: 21

Hey, I just did some more experimenting and have some additional observations. The short answer is that this may be a problem with the Plex server, not Infuse.

I flagged the last 2 episodes of a show's season as unwatched, then started the first of those 2. After a few seconds into playback, I chapter-forwarded to the end to force the next episode to start playing. After a few seconds, I exited out the the list of the episodes for the series. At this moment, the last episode was still flagged as unwatched. When I backed out a level, the season showed in my "Recently Added" list up top with the orange bar still indicating that there were unwatched episodes. Going back in and out had no effect on the "unwatched" status of the episode. When I forced a refresh from the icon up top, the episode at that point got flagged as watched (and thus, the whole season).

From that, it seems Infuse is getting the "watched" status from Plex, although if it's sending something to Plex to make it think it was watched, I cannot say.

EDIT: ok, I don't think it is the Plex server. I can't replicate the problem on Plex' own app on the ATV. But here's what I did find. After forwarding through the first of those 2 same episodes to get to the second in Plex, and after aborting playback of the 2nd after it started, that last episode remained flagged as unwatched in Plex, and showed the same in Infuse. When I repeated the process in Infuse as before and got the "watched" flag applied incorrectly on that last episode, I went back to Plex and Plex still correctly shows that same episode as unwatched. If I check directly via Plex Server's web browser interface, it also still correctly shows that episode as unwatched.

  September 30, 2019 - 2:23am
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 37
Kudos: 4

Before this happened on both iOS and tvOS. Now it seems that it only happens on tvOS.

  September 30, 2019 - 1:20pm
Oliver-05's picture
Offline
Joined: Sep 2019
Posts: 3
Kudos: 0

I confirm, I have the same issue on tvOS.

  October 2, 2019 - 5:11am
OMGzilla's picture
Offline
Joined: Jun 2018
Posts: 17
Kudos: 21

Problem persists on version 6.1.8. This is highly aggravating. I had to turn off Continuous Playback so I wouldn't get burned by this.

  October 3, 2019 - 10:43am
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 37
Kudos: 4
  OMGzilla wrote:

Problem persists on version 6.1.8. This is highly aggravating. I had to turn off Continuous Playback so I wouldn't get burned by this.

I've also disabled continuous playback.

  October 11, 2019 - 1:59am
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 37
Kudos: 4

I have finally decided to switch to smb as source of media and I am quite happy with the change. When this is fixed, I will possibly return to Plex as media source, because it is more convenient for me to manage metadata.