10 posts / 0 new / Last post
#1  December 14, 2015 - 6:34am
honey's picture
Offline
Joined: Dec 2015
Posts: 10
Kudos: 0

I posted this in the wrong forum so reposting here. I also posted in one of the sticky threads (no InFuse response) and logged a help call but only received a "we'll look at it" reply - I now can't access the call as per the email I received (#73794) and wonder if/why it's been closed. Hopefully posting it here might help. I've paid for Pro and since purchase have managed to actually see a movie maybe 1 time in 50.

Firstly I'm not using surround sound and am playing sound via AirPlay to an AirPort Express attached via phono to my old hifi amplifier. I can hardly get any movies to play at all - they just beachball the moment I hit play and I can't access the top menu. All these movies play fine with AirPlay turned off, work fine in every other Apple TV movie app I have (with sounds via AirPlay to my AirPort Express) and work fine when played from InFuse on an iPhone/iPad and sending them to the Apple TV. I need to use AirPlay to non-surround sound systems.

The very few times I can get a movie to play I get a horribly loud fluttering/stuttering sound but it's very rare I can even get to this point. If I do I have to pulldown the menu rapidly and switch "Dolby Digital over AirPlay" to Off to make sound work but don't know how to make this default. I've tried the suggestions in that thread for surround sound users such as setting the "Surround Sound" mode (in my case from Auto to Stereo) and setting the "Audio Mode" to 16 bit but they don't help. I've also played with all the settings in Infuse and turned the Dolby and DTS options on and off in different combinations, all in 4.0.1. No joy.

Details, although I don't think relevant: my server is a Synology NAS running SMB at the latest update level, and I've tried forcing SMB versions 2 and 3 and I get the same. Because of the reasons above it's not a basic network problem, server or protocol issue, and the ones that don't play on my Apple TV play fine on Infuse 3 on my iPhone with AirPlay enabled to the Apple TV, which magically passes the audio onto the AirPort Express, and all works fine. So the problem is only in the Apple TV version of Infuse.

InFuse(Apple TV) -> AirPlay(audio) -> AirPort Express - loads forever, fails
InFuse(iPhone) -> AirPlay(video and audio) -> Apple TV -> AirPlay(audio) -> AirPort Express - works
InFuse(iPhone) -> AirPlay(audio) -> AirPort Express - works

I appreciate this is a first production version but I'm hoping there's a fix I can employ now, or this is a known problem with solution soon? I posted asking whether this was fixed in 4.0.1 but didn't get a response and it isn't. Happy to provide any more information but increasingly frustrated from getting no response and I'm hoping not to have to seek a refund. Please give us non-Dolby AirPlay users some love too. Thanks!

  December 14, 2015 - 11:23pm
cyberchriss's picture
Offline
Joined: Jun 2011
Posts: 3
Kudos: 0

Can confirm this bug that is also reported in http://firecore.com/forum/topic/13755.
Hope there will be a fix soon, so that we can enjoy infuse pro Wink

  December 14, 2015 - 11:44pm
dave1447's picture
Offline
Joined: Dec 2015
Posts: 24
Kudos: 3

I also have the same issue. ATV sends audio to Airport Express with speakers connected, but I cannot play any files in Infuse Pro unless I switch the audio output back to the ATV (i.e. TV speakers). No issues with any other apps etc.
This is a huge deal breaker for me, as I assume such functionality to be pretty standard for any Apple device and more than a given for a 'Pro' app. Cannot understand how such a bug could pass QA. Would like to see this fixed in 4.0.2 update ASAP.

  December 15, 2015 - 6:18am
honey's picture
Offline
Joined: Dec 2015
Posts: 10
Kudos: 0

I'd ask that everyone on this thread please log a formal support call to bring their attention to it. I did, I had a one-line reply and then the call seemingly disappeared. But I think we should try. I'd like at least an acknowledgement from staff that they hear us, whether they can reproduce it, and what the ETA for a fix is.

  December 21, 2015 - 6:26am
bradlyn.4667's picture
Offline
Joined: Dec 2010
Posts: 3
Kudos: 0

I am having the same problem as the above poster (and other members). It's kind of a real drag. A response would be appreciated!

  December 22, 2015 - 10:56am
honey's picture
Offline
Joined: Dec 2015
Posts: 10
Kudos: 0

I think a response is unlikely - I've been trying for weeks both via the forum and via support requests, which just disappeared. I'm not sure why Firecore are unconcerned that a basic feature of the Apple TV is non-functional in their app, or that they'd at least acknowledge it and say they're working on it. All other movie apps work with AirPlay. I'm about give up and seek a refund, but this put FireCore/InFuse in a very poor light.

  December 22, 2015 - 7:00pm
dave1447's picture
Offline
Joined: Dec 2015
Posts: 24
Kudos: 3

I'm starting to feel the same way. This is really a huge deal breaker. Such a basic requirement. I paid for Pro and would prefer to stick with Infuse, but when there's plenty of other good options out there I'm starting to feel like abandoning the platform. Firecore developers have been active on the forums on other topics since this issue was reported. There are now a number of posts on the topic all being ignored. All that is asked for is an official acknowledgement to reassure users that their investment is worth sticking with. But the lack of any comment from Firecore is concerning and suggests this issue will be resolved (which is really baffling, I mean, why wouldn't you just acknowledge and start to fix?)

  December 23, 2015 - 10:26am
james's picture
Staff
Online
Joined: Jun 2008
Posts: 14,558
Kudos: 1,280

Streaming audio over AirPlay has not yet been implemented, though it is something we are hoping to add.

Infuse 6 for iOS and Apple TV is now available!

  December 23, 2015 - 12:49pm
honey's picture
Offline
Joined: Dec 2015
Posts: 10
Kudos: 0

Thanks at last for at least an acknowledgement of this, James. I can't say I really understand it though so if you could explain more I'd appreciate it: no other app has problems with sending audio over AirPlay. My understanding is that this is a core Apple TV feature, not one that needs to be implemented on a per-app basis, and therefore this is a bug in InFuse that breaks Apple TV functionality.

Sending audio on from apps to an AirPlay server (such as an AirPort Express) is something that many users will expect to be able to do, and indeed need to do on a routine basis. If turning this Apple feature on disables InFuse completely then surely this requires an urgent fix? Could you therefore give us an approximate timescale for this fix and the priority you're placing it at, so that those of us who have spent money on this app and haven't been able to use it know whether to wait or seek a refund?

  December 23, 2015 - 9:14pm
dave1447's picture
Offline
Joined: Dec 2015
Posts: 24
Kudos: 3

Thanks for the acknowledgment, James. This is appreciated and I will continue to stick with infuse for now. However, I echo the comments from @honey, as this is also my understanding