5 posts / 0 new / Last post
#1  February 8, 2018 - 11:11pm
Blake Eiseman's picture
Offline
Joined: Feb 2018
Posts: 4
Kudos: 0

I am hoping someone could help me decipher what just happened, and hopefully, avoid it from happening again.

I have my library set up using Plex. I am new to Infuse, and while I'm very excited about the upcoming Plex integration, I figured I would get my feet wet and learn the ins and outs using the currently supported DLNA method.

So I started Infuse on my iPad, selected Add Files, and then under Available Shares, I selected my Plex Media Server. I then chose my Movies and TV Shows folders, and then went back to the Settings folder. I waited for awhile, letting Infuse scan those folders in my Plex library.

While this was happening, I decided to go check out Plex, and was surprised to find the "Now Playing" status was going haywire. Apparently during the scanning process, Infuse was randomly "playing" some files, partially or fully, and marking them as played. To make matters worse, since I had Trakt activated, they were being tagged as played in Trakt as well.

Once I realized what was happening, I stopped the process, but the damage was already done, as it was already mostly though my library. What I was left with was a mess ... I just spent the last hour and a half going through and marking things "unwatched" that I have not yet seen.

What is so strange is that it was seemingly random. Only some episodes from shows that I haven't watched, or was in the process of watching, were marked as watched, while others were left alone. And only some of the movies we marked as watched.

At this point, I'm a bit afraid of trying to use Infuse again, because I don't want to go through this again. I might just wait for the Plex integration, unless someone knows what happened and how to fix it / avoid it from happening again.

Thanks!

  February 9, 2018 - 10:26am
james's picture
Staff
Online
Joined: Jun 2008
Posts: 10,190
Kudos: 436

Unfortunately, this is a quirk that can appear in some cases when streaming from Plex via DLNA.

One thing we're working on for the upcoming 5.7 update is an all-new native Plex integration, which will provide a much better experience when browsing and streaming videos stored in Plex.

In the meantime, you may consider streaming via SMB or NFS instead of through Plex as this will avoid this issue entirely.

Infuse 5.6 with a fresh new look + HDR is now available!

 

  February 9, 2018 - 10:43am
Blake Eiseman's picture
Offline
Joined: Feb 2018
Posts: 4
Kudos: 0

Hi James, thank you for your reply. Yes, the Plex integration is what drew me to your application in the first place. I have signed up for the beta, so hopefully I will be chosen to participate. Can you make sure I am added to the beta? And do you know when the beta will begin?

Thanks so much for your help!

  February 9, 2018 - 11:38am
james's picture
Staff
Online
Joined: Jun 2008
Posts: 10,190
Kudos: 436

We anticipate having the first beta of 5.7 available later this month.

Drop me a PM if you don't get an email once this rolls out.

Infuse 5.6 with a fresh new look + HDR is now available!

 

  February 12, 2018 - 3:56pm
Blake Eiseman's picture
Offline
Joined: Feb 2018
Posts: 4
Kudos: 0

Hi James,

While waiting for the new Plex integration, I went ahead and connected to my shares via SMB. I'm still noticing something weird ... similar to the problem I had before, but nowhere near as serious.

I have Trakt integration enabled, so I would expect Infuse to grab all my watched statuses from Trakt. However that doesn't seem to be happening, at least not accurately.

It seems that some episodes that have already been watched are correctly tagged as watched, but the vast majority show a 0:02 or 0:03 second progress ... in other words, Infuse thinks I watched the first couple seconds of the show, and then stopped. So these shows are incorrectly marked as partially watched.

Luckily, these errors have not been transferred back to Trakt, or to Plex. However in Infuse, they are incorrectly marked.

The same thing goes for movies ... some movies are correctly marked watched, and others have a :08 second "in progress" marker. The numbers vary, anywhere from :01 to :08 or so.

It's almost as if the scanning process in Infuse actually starts playing the media, as if the user was actually watching it, rather than idly scanning it. This would match what happened when I had it connected to Plex, because Plex went haywire, thinking I was playing the first 2-5 seconds of each piece of media.

I think it would be great to get this fixed, but more importantly, hopefully it will not continue into the next version with Plex integration, because that could royally screw up the Plex database.

Please let me know if there is any additional info I can provide to help you track down this important problem.