5 posts / 0 new / Last post
#1  April 21, 2018 - 3:31pm
Edwink's picture
Offline
Joined: Apr 2018
Posts: 2
Kudos: 0

Hi,
Movies appear double in the library when moved to another folder since Infuse 5.7.
Can this be fixed? Thanks.
More details:
This happens when I move a movie on my Synology NAS from one folder to another folder.
Folders are both part of the library.
For one of the two movies in the library get a message that the file does not exist.
Happens on Ios as well as apple tv. Currently iphone is on 5.7, and shows the double movies.
Ipad is still on infuse 5.6, and shows one occurence of the moved movie. There the problem does not exist.

  April 24, 2018 - 10:36am
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 14,091
Kudos: 1,206

Welcome to the forum!

This can actually happen if you move a file, and Infuse has not yet finished an update scan. Once the scan completes, Infuse will add any new files it finds and remove and old files it notices have been deleted (or moved).

Scans generally happen automatically when opening the app, but you can also force a scan by tapping the refresh icon that appears on the main Library screen, or use the option found in Settings > Library.

Infuse 6 for iOS and Apple TV is now available!

  April 25, 2018 - 12:05pm
Edwink's picture
Offline
Joined: Apr 2018
Posts: 2
Kudos: 0

Thanks for yor reply. Tested it again, now with Infuse 5.7.1 on Iphone and again 5.6.11 on ipad. Total of 630 movies in the library. Use NFS on Synology NAS.
First did scan for changes on both ipad and iphone.
When that was finished: moved folder for one movie.
Then scan for changes on both ipad and iphone.
Result when finished: duplicate movie on infuse 5.7.1 in library => all movies. One movie on infuse 5.6.11 on ipad in library => all movies.
Remarkable: When clicking on the duplicate movie in infuse 5.7.1 for which the folder does not exist anymore and then doing a scan for changes: then the duplicate movie is gone. That would be quite a some work to do though..
Is it possible to fix this duplicate problem when moving folders with movies on the NAS?

  November 26, 2019 - 8:46am
NetHawk's picture
Offline
Joined: Nov 2019
Posts: 1
Kudos: 0

I have this issue even without having moved any file. Some new files I add are shown twice on my iPad and on Apple TV. My version is 6.2.2 (2815). Is there a way to force a complete rebuild of the database? Or does anyone know of any trick to remove the doubles? It's not the end of the world, but still quite annoying.

  November 26, 2019 - 9:21am
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,785
Kudos: 383
  NetHawk wrote:

I have this issue even without having moved any file. Some new files I add are shown twice on my iPad and on Apple TV. My version is 6.2.2 (2815). Is there a way to force a complete rebuild of the database? Or does anyone know of any trick to remove the doubles? It's not the end of the world, but still quite annoying.

Welcome to the forum!

First, is there any way that you may actually have two copies of those files? Second are you by any chance connected via UPnP?

There are settings on the ATV version that allow you to delete the metadata and rebuild but you shouldn't have to for doubles. The clear metadata option is located on the main "Settings" screen on ATV. It's highlighted in red.

The only time I've ever seen doubles is when I actually had multiples of the same file caused by me forgetting I had already copied it over. You may want to check to see if you may have multiples of those files but in different formats like one mp4 and one AVI or similar. I've had that bite me too.

If you're shares are connected via UPnP you may want to try a different protocol like SMB. UPnP can cause some strangeness and the library doesn't work with it well if at all.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•