6 posts / 0 new / Last post
#1  May 27, 2018 - 4:24am
lambdan's picture
Offline
Joined: May 2018
Posts: 3
Kudos: 0

I have a season of a TV show that is encoded like this, in MKV containers:

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main 10@L5@Main
Codec ID                                 : V_MPEGH/ISO/HEVC
Duration                                 : 52 min 15 s
Bit rate                                 : 15.4 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 10 bits
Bits/(Pixel*Frame)                       : 0.077
Stream size                              : 5.62 GiB (98%)
Default                                  : Yes
Forced                                   : No
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709

Audio
ID                                       : 2
Format                                   : AC-3
Format/Info                              : Audio Coding 3
Codec ID                                 : A_AC3
Duration                                 : 52 min 15 s
Bit rate mode                            : Constant
Bit rate                                 : 384 kb/s
Channel(s)                               : 6 channels
Channel positions                        : Front: L C R, Side: L R, LFE
Sampling rate                            : 48.0 kHz
Frame rate                               : 31.250 FPS (1536 SPF)
Bit depth                                : 16 bits
Compression mode                         : Lossy
Stream size                              : 144 MiB (2%)
Title                                    : English
Language                                 : English
Service kind                             : Complete Main
Default                                  : Yes
Forced                                   : No

+ a ton of SRT files embedded (like 20 of them)

In the Plex app this video won't even play. It just goes black and after a while I get an error.
On Infuse Pro 5, I get the video to play (I can see things) but it freezes and drops frames like crazy (like 2-3 secs of 10 fps footage, then frozen for 5 secs, then movement again).
Is there anything I can do to fix it or should I re-encode it?
I tried viewing it through both an SMB share setup and a "Connect to Plex" setup - makes no difference.

  May 27, 2018 - 10:25pm
Magenof's picture
Offline
Joined: Dec 2017
Posts: 35
Kudos: 3

I’m absolutely not a pro at encoding but shouldnt 4k 10 bit content be BT.2020 instead of BT.709? Maybe thats why plex and infuse have problems?

  May 29, 2018 - 11:56am
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 14,558
Kudos: 1,279

If you have a chance, would you mind uploading a sample we could review here?

https://firecore.com/upload

Infuse 6 for iOS and Apple TV is now available!

  May 29, 2018 - 5:19pm
lambdan's picture
Offline
Joined: May 2018
Posts: 3
Kudos: 0
  james wrote:

If you have a chance, would you mind uploading a sample we could review here?

https://firecore.com/upload

I cut out a 60 sec chunk with ffmpeg (-c copy) and was able to reproduce the issue with the sample file. I uploaded it to you and called it "lambdan-sample.mkv".

  May 29, 2018 - 8:26pm
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 14,558
Kudos: 1,279

Thanks! We'll take a look.

Infuse 6 for iOS and Apple TV is now available!

  November 24, 2018 - 7:27am
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 14,558
Kudos: 1,279

Quick update.

We believe this issue was resolved in the 5.9 update.

Please let us know if you see any further issues.

Infuse 6 for iOS and Apple TV is now available!