10 posts / 0 new / Last post
#1  June 26, 2018 - 11:57pm
claire78's picture
Offline
Joined: Jun 2018
Posts: 30
Kudos: 3

In version 5.7.4 there’s a new option to select subtitles: subtitles On, only Forced, or Off.
If selected On or Forced it plays always Forced track.
Would be great with selection On, it would play Full track of selected subtitle language.

  July 16, 2018 - 10:24am
claire78's picture
Offline
Joined: Jun 2018
Posts: 30
Kudos: 3

It will be fixed in next release?? I don’t see in next release fixes..

  August 3, 2018 - 8:34am
claire78's picture
Offline
Joined: Jun 2018
Posts: 30
Kudos: 3

It is still problem with Hungary subtitles in latest release. May I have an answer? @james?

  August 3, 2018 - 9:37am
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 13,585
Kudos: 1,115

It sounds like the forced track may in fact be the first subtitle track.

Infuse selection this is sort of expected, since with the setting set to ON, it will select the first subtitle track that matches your language.

One way you could avoid this is to rearrange the order of your subtitle tracks, so that the full subtitle track is listed as #1 with the forced track listed as #2.

Infuse 6 for iOS and Apple TV is now available!

  August 3, 2018 - 12:21pm
claire78's picture
Offline
Joined: Jun 2018
Posts: 30
Kudos: 3

How do you that exactly think? Should I remux all ~400 movies to rearrange subtitles? :O
It is worked when there wasn’t option to select Forced/On/Off. Used to play movies with full subtitles with selected language..

  August 3, 2018 - 3:06pm
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 13,585
Kudos: 1,115

One other thing you can try is changing the language in Settings > Subtitles from Auto to your desired language.

Doing this, will have the effect of Infuse ignoring the 'default' flag which could also be causing the forced tracked to be selected (if it is also tagged as default).

Infuse 6 for iOS and Apple TV is now available!

  August 4, 2018 - 12:41am
claire78's picture
Offline
Joined: Jun 2018
Posts: 30
Kudos: 3

Always was desired language selected.
I don’t understand why it’s worked before und why doesn’t now. Frown

  August 6, 2018 - 9:34am
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 13,585
Kudos: 1,115
  claire78 wrote:

Always was desired language selected.
I don’t understand why it’s worked before und why doesn’t now. Frown

How Infuse handles subtitle selecting will vary based on the actual flags you have set in your files, but you may try selecting the 'Auto' option as this will allow Infuse to respect the default flag if it's set for the main track.

Infuse 6 for iOS and Apple TV is now available!

  August 6, 2018 - 10:28am
claire78's picture
Offline
Joined: Jun 2018
Posts: 30
Kudos: 3

So, usually these movies have 4 subtitles: 2 hungarian (forced + full), 2 english (forced + full). Hungarian forced is default track (with hungarian audio track).
Infuse can detect forced subtitle, and can detect language of subtitle. May could select hungarian subtitle which not forced?

  August 6, 2018 - 10:40am
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 13,585
Kudos: 1,115

Infuse 5.7.3 and later will respect the default flag (if set) when Settings > Subtitles is set to Auto. Previous versions of Infuse would simply select the first track that matched the default language, and this behavior can be mirrored by switching from Auto to a preferred language.

Unfortunately, I don't think there's not going to be any good logic that would allow Infuse to intentionally skip over a track that is listed first and is tagged as forced and default, as these are used by many others to indicated their preferred audio/subtitle tracks.

However, track selections made manually while playing a video in Infuse will sync to iCloud, so Infuse will remember these selections whenever the same video is played again in the future.

Infuse 6 for iOS and Apple TV is now available!