13 posts / 0 new / Last post
#1  October 25, 2018 - 2:44pm
manuelc.4627's picture
Offline
Joined: Jan 2012
Posts: 9
Kudos: 0

Hi
In the last two days every time I tried to download the subtitles from opensubtitles.org I get a error message.
Is something wrong with this page API?
Thanks

  October 29, 2018 - 10:04am
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 12,047
Kudos: 846

OpenSubtitles has been experiencing some downtime as of late. We are working with them to improve reliability and plan to have these changes available in a future version of Infuse.

For now, you can keep an eye on OpenSubtitles' uptime here.
https://stats.fireco.re/

Help get Dolby Atmos on Apple TV (more info)

  November 7, 2018 - 3:33pm
manuelc.4627's picture
Offline
Joined: Jan 2012
Posts: 9
Kudos: 0

Hi
it is again not working again and the page you gave us is not working too.

  November 7, 2018 - 7:35pm
NC Bullseye's picture
Moderator
Online
Joined: May 2016
Posts: 1,303
Kudos: 241
  manuelc.4627 wrote:

Hi
it is again not working again and the page you gave us is not working too.

I just checked and the stat page appears to be working.

https://stats.fireco.re/

The subtitle source api site seems to still be having issue though.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  November 8, 2018 - 1:08pm
manuelc.4627's picture
Offline
Joined: Jan 2012
Posts: 9
Kudos: 0

Hi. The stats page now works but it is not accurate. Right now doesn’t work properly and the page doesn’t show it.
Seriously this functionality is basic for most of us. For a ome of us even more important than the sound and it seems that it is more important 4K or pass through than this.

  November 8, 2018 - 1:30pm
NC Bullseye's picture
Moderator
Online
Joined: May 2016
Posts: 1,303
Kudos: 241
  manuelc.4627 wrote:

Hi. The stats page now works but it is not accurate. Right now doesn’t work properly and the page doesn’t show it.
Seriously this functionality is basic for most of us. For a ome of us even more important than the sound and it seems that it is more important 4K or pass through than this.

You have to remember that the status is checked once every 5 minutes so it the server happens to be having issues but only sporadically, it may be up for the few seconds the check is done but it could be down the rest of the 5 minute time frame. I'm not saying it's only up for the test but the timing could still show as up even though the server is having issues.

Also the response time can have a lot to do with it, your request through the API may be timing out waiting for a response from the server even though if it waited longer it may get the data. The difference between a tenth of a second to get a response and a half second (to over 2 full seconds like recently) can seem like an eternity when you're waiting for a response.

I know it gets old running into issues and I'm not trying to make excuses, I'm just trying to clarify what the stats can show. I know that Firecore has said they are working on the problems with subtitles so I just try multiple times if I need them and they always seem to get through after multiple attempts over time.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  November 8, 2018 - 4:26pm
manuelc.4627's picture
Offline
Joined: Jan 2012
Posts: 9
Kudos: 0

Yes. You are probably right.
Thanks

  November 9, 2018 - 4:01pm
eeeightzz's picture
Offline
Joined: Oct 2017
Posts: 6
Kudos: 0

Why don't they just update the app with a fix for this right now instead of waiting for the big 5.9 release?

It's been going on for a while and is a real PITA, I just tried 30 times to get a subtitle.

  November 9, 2018 - 4:24pm
NC Bullseye's picture
Moderator
Online
Joined: May 2016
Posts: 1,303
Kudos: 241
  eeeightzz wrote:

Why don't they just update the app with a fix for this right now instead of waiting for the big 5.9 release?

It's been going on for a while and is a real PITA, I just tried 30 times to get a subtitle.

As James said, the fix is in progress so it's on their radar. I don't think it's part of the 5.9 update though, the list of improvements doesn't show it for 5.9, just in process.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  November 9, 2018 - 5:22pm
remotevisitor's picture
Offline
Joined: Oct 2011
Posts: 328
Kudos: 23

My understanding from what James has said, the fix requires both improvements on the opensubtitles site as well as Infuse.

From things James has previously said on other threads about this issue, I believe that opensubtitles are working on changes to the interface used by programs to access the service and only when they have done that work can Firecore make changes to Infuse to use the new interfaces. So Firecore are dependent on the work by opensubtitles being completed.

  November 17, 2018 - 6:18am
MartinM's picture
Offline
Joined: Nov 2018
Posts: 5
Kudos: 0

When can we expect opensubtitles download to work again?

  November 17, 2018 - 8:41pm
NC Bullseye's picture
Moderator
Online
Joined: May 2016
Posts: 1,303
Kudos: 241
  MartinM wrote:

When can we expect opensubtitles download to work again?

Just DL'ed 3 different episodes without a hitch. Last night it took a couple of tries for a movie but it finally came through. Firecore has it on their radar so hopfully we'll have better luck soon.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  November 20, 2018 - 5:36pm
MartinM's picture
Offline
Joined: Nov 2018
Posts: 5
Kudos: 0

Well, i hope this get fixed soon, because i still cant download subtiles no matter how many times i try. Just an error that i need to check my connection and try again later.