13 posts / 0 new / Last post
#1  February 27, 2019 - 4:37pm
Anderella's picture
Offline
Joined: Feb 2019
Posts: 7
Kudos: 0

Hi,

I read the guides and tried kind of "everything", but didn't succeed.....

#

I can connect to my QNAP NAS for example with:

NAME: KOPI-NAS (SMB)
Protocol: SMB
Address: KOPI-NAS.local
Username: XXX
Password: ZZZ

at home, in the same network.

if I try to connect from "outside", I cannot connect Frown

tried both ways to connect - like I connect to my NAS with the QFILE-App: (on my IOS iPad Pro)

V1:
NAME: KOPI-NAS
Protocol: SMB
Address: KopiCloud.myqnapcloud.com
Username: XXX
Password: ZZZ

V2:
NAME: KOPI-NAS
Protocol: SMB
Address: External IP (with or without Port), for example: 213.44.22.176:443
Username: (Same)
Password: (Same)

Always ends with "Sorry, error occurred during connection)

Help very much appreciated....

  February 27, 2019 - 8:54pm
JarvisMeier's picture
Beta Tester
Offline
Joined: Dec 2011
Posts: 328
Kudos: 28
  Anderella wrote:

Hi,

I read the guides and tried kind of "everything", but didn't succeed.....

#

I can connect to my QNAP NAS for example with:

NAME: KOPI-NAS (SMB)
Protocol: SMB
Address: KOPI-NAS.local
Username: XXX
Password: ZZZ

at home, in the same network.

if I try to connect from "outside", I cannot connect Frown

tried both ways to connect - like I connect to my NAS with the QFILE-App: (on my IOS iPad Pro)

V1:
NAME: KOPI-NAS
Protocol: SMB
Address: KopiCloud.myqnapcloud.com
Username: XXX
Password: ZZZ

V2:
NAME: KOPI-NAS
Protocol: SMB
Address: External IP (with or without Port), for example: 213.44.22.176:443
Username: (Same)
Password: (Same)

Always ends with "Sorry, error occurred during connection)

Help very much appreciated....

You’ll need to open up SMB ports on your firewall. I recommend NOT doing this. It’ll open you up to all sorts of security vulnerabilities. Consider installing plex on your QNAP and using that as your remote access solution.

  March 1, 2019 - 2:07am
Anderella's picture
Offline
Joined: Feb 2019
Posts: 7
Kudos: 0

Hi,
thank you very much for your advise and help..... unfortunately my QNAP is not compatible with PLEX. (TS-221)

Any other options?

  March 1, 2019 - 11:10am
JarvisMeier's picture
Beta Tester
Offline
Joined: Dec 2011
Posts: 328
Kudos: 28
  Anderella wrote:

Hi,
thank you very much for your advise and help..... unfortunately my QNAP is not compatible with PLEX. (TS-221)

Any other options?

You could run plex on a desktop or laptop and have it connect to your qnap for your videos. I haven’t looked into whether it’s possible but you could also buy a raspberry pi and run plex off of that and have it connect back to your qnap

If your router has VPN server capabilities you could also connect to your VPN when away. This should let you access your qnap via SMB however this won’t work with an Apple TV as they don’t support VPN clients.

  March 8, 2019 - 2:58am
Constantine's picture
Offline
Joined: Feb 2016
Posts: 11
Kudos: 0

Hi,

I use QNAP TS-112P via FTP and Infuse.

works with no issues Smile

  March 16, 2019 - 6:28am
Anderella's picture
Offline
Joined: Feb 2019
Posts: 7
Kudos: 0

Hi,
thanks for your replies.

@Constantine:
How Did you manage that?
What settings would you suggest?
Thanks.

  March 16, 2019 - 6:32am
Constantine's picture
Offline
Joined: Feb 2016
Posts: 11
Kudos: 0

Hi

I just used
PROTOCOL FTP
Address: the IP of the NAS
port: 21
User name and password.

  March 16, 2019 - 6:53am
Anderella's picture
Offline
Joined: Feb 2019
Posts: 7
Kudos: 0

Hm, can't connect.

Do I have to change any settings on my NAS?
Just verified: I have FTP activated, Port 21.

I entered my "external" IP, username, password and Foldername. No success.

  March 16, 2019 - 11:07am
Constantine's picture
Offline
Joined: Feb 2016
Posts: 11
Kudos: 0

You have to use the external IP of the nas.

  March 16, 2019 - 11:42am
Anderella's picture
Offline
Joined: Feb 2019
Posts: 7
Kudos: 0

I entered my "external" IP (as mentioned before)

  March 16, 2019 - 7:19pm
JarvisMeier's picture
Beta Tester
Offline
Joined: Dec 2011
Posts: 328
Kudos: 28
  Anderella wrote:

I entered my "external" IP (as mentioned before)

You’ll need to open port 21 on your firewall and have it mapped to the internal IP of your NAS.

  May 31, 2019 - 5:21am
Jpbouillon's picture
Offline
Joined: Dec 2017
Posts: 1
Kudos: 0

I have the same problem with my TS119p+. So I have 2 QNAP NAS in my network.

I open port 21 on my routeur

Entered my external IP address like xx.xx.xx.xx
User & pass

And it’s not worked ...

Attachments: 

Jean-Pierre Bouillon

  May 31, 2019 - 7:01pm
JarvisMeier's picture
Beta Tester
Offline
Joined: Dec 2011
Posts: 328
Kudos: 28

Can you connect to it with an FTP program on a desktop? If not then you have something wrong with your settings in either your NAS or your router.