44 posts / 0 new / Last post
#1  May 1, 2019 - 12:09pm
Deschain's picture
Offline
Joined: Mar 2018
Posts: 81
Kudos: 13

I can no longer freely select artwork for the favorites icons. It always defaults to the 'favorites-av.png' no matter what other picture I select.

  May 1, 2019 - 12:16pm
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,484
Kudos: 366

Are you saying that if you follow the steps in the users guide https://support.firecore.com/hc/en-us/articles...

that it doesn't use the graphic you select?

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  May 1, 2019 - 1:01pm
Deschain's picture
Offline
Joined: Mar 2018
Posts: 81
Kudos: 13

Yes.

All my icons used to have custom graphics. But, today when I opened Firecore, it had reverted back to the default graphics and I cannot change it anymore. When I try to change it, it does show the custom graphics I select in the menu, but when I exit out to the main screen, the icon graphics are all default.

  May 1, 2019 - 1:10pm
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,484
Kudos: 366

Have you tried restarting your ATV? Sounds like something may have been corrupted during the update.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  May 1, 2019 - 1:16pm
Deschain's picture
Offline
Joined: Mar 2018
Posts: 81
Kudos: 13
  NC Bullseye wrote:

Have you tried restarting your ATV? Sounds like something may have been corrupted during the update.

Yes, doesn't help.

  May 1, 2019 - 1:26pm
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,484
Kudos: 366

Id say the next step would be to delete Infuse and reload it. If I understand iCloud sync it should pick up your settings and most of the metadata.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  May 2, 2019 - 12:51pm
Deschain's picture
Offline
Joined: Mar 2018
Posts: 81
Kudos: 13
  NC Bullseye wrote:

Id say the next step would be to delete Infuse and reload it. If I understand iCloud sync it should pick up your settings and most of the metadata.

Tried that, still no joy Frown

  May 2, 2019 - 12:58pm
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,484
Kudos: 366

Is "favorites-av.png" a file you have somewhere on your server? If so, have you tried removing it from your server? If not have you searched for it?

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  May 2, 2019 - 1:05pm
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,484
Kudos: 366

It sounds like you may mean "favorite-atv.png" not "favorite-av.png". If you have a favorite-atv in each of your favorites I think that will override your picks via the "Select Artwork" option so you may need to go and remove all of the "favorite-atv.png" files from each of the favorites folder first.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  May 2, 2019 - 1:19pm
Deschain's picture
Offline
Joined: Mar 2018
Posts: 81
Kudos: 13

Yes, I do of course mean 'favorites-atv.png'.

Now it gets strange... I have a favorites icon named '3D Movies' and the graphics for that icon is in my 3D movie folder on my NAS. So, in my 3D movie folder, I have '3D.jpg' (the one I want to use and have used before) and 'favorites-atv.png'.
I deleted the 'favorites-atv.png' and selected the '3D.jpg' again. But, the 'favorites-atv.png' icon is still displayed on the home screen.... Rebooted the ATV, still displays the 'favorites-atv.png' icon...

Are the graphics for the favorites icons backed up somewhere (iCloud) and being used from there instead of the ones you select?

It was never a problem until the latest Infuse release.

  May 2, 2019 - 1:27pm
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,484
Kudos: 366
  Deschain wrote:

Yes, I do of course mean 'favorites-atv.png'.

Now it gets strange... I have a favorites icon named '3D Movies' and the graphics for that icon is in my 3D movie folder on my NAS. So, in my 3D movie folder, I have '3D.jpg' (the one I want to use and have used before) and 'favorites-atv.png'.
I deleted the 'favorites-atv.png' and selected the '3D.jpg' again. But, the 'favorites-atv.png' icon is still displayed on the home screen.... Rebooted the ATV, still displays the 'favorites-atv.png' icon...

Are the graphics for the favorites icons backed up somewhere (iCloud) and being used from there instead of the ones you select?

It was never a problem until the latest Infuse release.

I don't think that the graphics are backed up to iCloud but the selection of which graphic may be so you may have to wait until it finishes an iCloud Sync before it shows the new one. That's just a guess though. One other option is to change the 3D to "favorite-atv.png" and see if that works without having to select one.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  May 2, 2019 - 1:35pm
Deschain's picture
Offline
Joined: Mar 2018
Posts: 81
Kudos: 13
  NC Bullseye wrote:

I don't think that the graphics are backed up to iCloud but the selection of which graphic may be so you may have to wait until it finishes an iCloud Sync before it shows the new one. That's just a guess though. One other option is to change the 3D to "favorite-atv.png" and see if that works without having to select one.

I have always been able to change the icon graphics/artwork instantly.

I tried to change my graphics file to "favorite-atv.png", but it still shows the default graphics, which means that it must be picking the graphics from some other location (iCloud?) and not from the location you select via the 'Add Artwork' menu. So, a bug it must be Wink

  May 2, 2019 - 1:42pm
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,484
Kudos: 366

I just did a test and changed my favorite-atv it didn't change until I long pressed on the favorite, clicked on "Select Artwork" and then selected "Reset Artwork" then the new graphic was used by infuse.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  May 2, 2019 - 1:49pm
Deschain's picture
Offline
Joined: Mar 2018
Posts: 81
Kudos: 13

Thanks, but that doesn’t change anything here.

Also, the fact that you had to select 'Reset Artwork' to get it to change, indicates to me that something is wrong. That wasn't necesarry earlier and it is not mentioned in the User Guide.

  May 2, 2019 - 2:01pm
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,484
Kudos: 366

I don't know what to suggest to you now. I've been able to swap out the graphic for a favorite by switching the "favorite-atv" file and then selecting "Reset Artwork".

I would imagine that the reason it's required to select "Reset Artwork" to change the graphic is so that Infuse doesn't have to constantly scan that folder for changes unless you actually change the graphic.

I haven't eliminated the "favorite-atv" file and then tried to select a new graphic with a different name but then it may update instantly.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  May 2, 2019 - 2:03pm
Deschain's picture
Offline
Joined: Mar 2018
Posts: 81
Kudos: 13

Ok, thank for trying Smile

  May 3, 2019 - 7:42am
denis75's picture
Beta Tester
Offline
Joined: Jan 2016
Posts: 15
Kudos: 1

Same problem here since 6.05, tried several things, no luck so far...

  May 3, 2019 - 8:59am
Deschain's picture
Offline
Joined: Mar 2018
Posts: 81
Kudos: 13
  denis75 wrote:

Same problem here since 6.05, tried several things, no luck so far...

Thanks, good to know that I'm not alone Smile

  May 3, 2019 - 9:28am
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,484
Kudos: 366
  Deschain wrote:

Ok, thank for trying Smile

This has got my curiosity up, if you're up to some trial and error trouble shooting could we try removing the artwork both favorite-atv file and any other jpg or png files in that favorite folder then click on "Select Artwork" and then select "Reset Artwork" . I want to see if that reverts you back to the generic icon (orange with a star I think)

If it does can you then
1. Place the graphic file you want to use with the favorite-atv.png name
2. See if the favorite now has the desired artwork.
if not
3. Then click on "Select Artwork" and then select "Reset Artwork"
4. See if the favorite now has the desired artwork.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  May 3, 2019 - 10:10am
Deschain's picture
Offline
Joined: Mar 2018
Posts: 81
Kudos: 13
  NC Bullseye wrote:

This has got my curiosity up, if you're up to some trial and error trouble shooting could we try removing the artwork both favorite-atv file and any other jpg or png files in that favorite folder then click on "Select Artwork" and then select "Reset Artwork" . I want to see if that reverts you back to the generic icon (orange with a star I think)

It doesn't. It still uses the 'favorite-atv.png' that is no longer in the folder.

However, in the menu where you select "Reset Artwork" there is the preview of the artwork, and there it did change to the default one with the star. But, no change on the home screen.

  May 3, 2019 - 10:19am
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,484
Kudos: 366
  Deschain wrote:

It doesn't. It still uses the 'favorite-atv.png' that is no longer in the folder.

However, in the menu where you select "Reset Artwork" there is the preview of the artwork, and there it did change to the default one with the star. But, no change on the home screen.

Could you do a restart on the ATV after you deleted all of the graphics and see if it goes to the generic icon? If not, could you do a search for "favorite-atv" and see if there are any lost files somewhere with that name? It's so strange that it keeps using a pic that is no longer present.

Just to clarify, I mean a search on the server with the servers search engine. Not saying you didn't understand the first time but just to short circuit Murphy's law. Wink

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  May 3, 2019 - 10:24am
Deschain's picture
Offline
Joined: Mar 2018
Posts: 81
Kudos: 13
  NC Bullseye wrote:

Could you do a restart on the ATV after you deleted all of the graphics and see if it goes to the generic icon? If not, could you do a search for "favorite-atv" and see if there are any lost files somewhere with that name? It's so strange that it keeps using a pic that is no longer present.

Just to clarify, I mean a search on the server with the servers search engine. Not saying you didn't understand the first time but just to short circuit Murphy's law. Wink

Restarted, still no joy.

No "favorite-atv.png" on the server. It is indeed very strange? I still think it might be backed up in iCloud and linked to that.

  May 3, 2019 - 10:26am
denis75's picture
Beta Tester
Offline
Joined: Jan 2016
Posts: 15
Kudos: 1

Same here, deleted the files (on my SMB NAS) and still showing them...
Weird ...

(I'm having two AppleTV, an iPad and an iPhone all with Infuse)

  May 3, 2019 - 10:34am
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,484
Kudos: 366
  Deschain wrote:

Restarted, still no joy.

No "favorite-atv.png" on the server. It is indeed very strange? I still think it might be backed up in iCloud and linked to that.

There is the nuclear option, you can delete the infuse data on icloud. You can do that from an ios device or a Mac I believe. Just the icloud data for Infuse6. Just a thought, if you're the least bit hesitant we'll keep on hammering on it.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  May 3, 2019 - 10:46am
Deschain's picture
Offline
Joined: Mar 2018
Posts: 81
Kudos: 13
  NC Bullseye wrote:

There is the nuclear option, you can delete the infuse data on icloud. You can do that from an ios device or a Mac I believe. Just the icloud data for Infuse6. Just a thought, if you're the least bit hesitant we'll keep on hammering on it.

I don't have any iOS devices, other than the ATV.

  May 3, 2019 - 11:12am
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,484
Kudos: 366
  Deschain wrote:

I don't have any iOS devices, other than the ATV.

EDIT: The following was sent before James replied in the thread. Please see his post before you do anything further. Smile

Do you have a Mac with the same user id as the ATV?

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  May 3, 2019 - 11:21am
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 13,685
Kudos: 1,130

If you have a chance, can you send in a report from your device so we can look further into this?

https://support.firecore.com/hc/en-us/articles...

Infuse 6 for iOS and Apple TV is now available!

  May 3, 2019 - 2:34pm
Deschain's picture
Offline
Joined: Mar 2018
Posts: 81
Kudos: 13
  james wrote:

If you have a chance, can you send in a report from your device so we can look further into this?

https://support.firecore.com/hc/en-us/articles...

I have sent the diagnostics from the ATV Infuse App. The code is: B1EQC.

  May 4, 2019 - 1:21am
busard's picture
Offline
Joined: Nov 2017
Posts: 3
Kudos: 4

Hi all! I have a similar problem.
Suddenly the favorite artwork shows incorrectly. Although the PNG images have the right/recommended resolution of 1920x1080, the image is only partially shown.
When I go to the "select artwork" screen (long-press favorite icon), the image shows completely. However, on the homescreen the favorite artwork only shows partially.

Any idea what's going on? I have tried to resize the PNG images, reset artwork etc. to no avail...

  May 4, 2019 - 9:15am
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,484
Kudos: 366
  busard wrote:

Hi all! I have a similar problem.
Suddenly the favorite artwork shows incorrectly. Although the PNG images have the right/recommended resolution of 1920x1080, the image is only partially shown.
When I go to the "select artwork" screen (long-press favorite icon), the image shows completely. However, on the homescreen the favorite artwork only shows partially.

Any idea what's going on? I have tried to resize the PNG images, reset artwork etc. to no avail...

Have you tried restarting Infuse and the ATV? The issue in the thread may be a bit different since it's a problem with the favorite showing a graphic that doesn't appear to exist and can't be changed to a different pic. If you problem is different you may want to start a new thread so as to not muddy the water on this problem and make sure you get attention to your specific problem. Wink

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  May 4, 2019 - 9:48am
denis75's picture
Beta Tester
Offline
Joined: Jan 2016
Posts: 15
Kudos: 1
  NC Bullseye wrote:

There is the nuclear option, you can delete the infuse data on icloud. You can do that from an ios device or a Mac I believe. Just the icloud data for Infuse6. Just a thought, if you're the least bit hesitant we'll keep on hammering on it.

I did the nuclear option (deleting icloud data from my Mac), no effect...
Looks like there is a local cache ?
Denis