6 posts / 0 new / Last post
#1  June 21, 2019 - 9:28am
kai0n7's picture
Offline
Joined: Jun 2019
Posts: 11
Kudos: 1

Hello all, new user here who just jumped on the APTV bandwagon after finally cutting the cord. After learning how to mitigate some of Infuse's quirks, I've even been able to mostly retire all of my dedicated MediaPortal PC/local file share setups. Very happy so far!

The file shares on my Synology NAS are set up like so:

/Movies/Movie Title (Year)
-- Movie Title (Year).mp4
-- Movie Title (Year).jpg
-- Movie Title (Year)-fanart.jpg

One issue I haven't been able to figure out is how to best handle instances where I have two versions of the same movie. I love old Toho monster movies, and am using "Frankenstein Conquers the World" (US) and "Frankenstein vs. Baragon (JP) as my use case example.

The movies have different titles, are in their own folders, and have different sets of local artwork. When Infuse scans them, they're both recognized as the US version, and it applies the same metadata to both movies. It ignores the alternate versions artwork, even though the artwork is stored locally.

I have tried creating custom XML files and applying them through the "Edit Metadata" interface, and am able to change the details of the movies (such as the title & release year), however the artwork is still problematic. After first applying the custom metadata, it will pick up the alternate artwork and all is well. But if I scroll away from it or view the movie information and back out, it always seems to revert back to showing the "default" artwork for both files. Sometimes, it will show the "alternate" artwork for both files as well... very frustrating.

In cases where the "alternate" title is sufficiently different (no listing comes up on TMDB), it behaves as desired, reading the custom xml file and applying the local artwork.

Anyways, thanks for reading, and hope you all have a wonderful day!

  June 25, 2019 - 9:56am
kai0n7's picture
Offline
Joined: Jun 2019
Posts: 11
Kudos: 1

Any thoughts from the development team on why this might be happening?

One of the things I've noticed is that if I select the custom xml file through the "Edit Metadata" interface, it changes the data displayed for the film. But if I go back into "Edit Metadata", it shows the TMDB entry is still selected. Can't quite wrap my head around it.

Could an option to simply not search for a TMDB match if a custom xml file is present be implemented? It looks like there's an option that's halfway there already.

  June 25, 2019 - 10:27am
elchupete's picture
Beta Tester
Offline
Joined: Oct 2014
Posts: 209
Kudos: 85

What are the names of the movies and what exactly is thr folder structure look like?

One option could be using a Plex Server to manage your files and Metadata including artwork.

  June 25, 2019 - 12:10pm
kai0n7's picture
Offline
Joined: Jun 2019
Posts: 11
Kudos: 1

The answers to your questions are in my first post.

Not sure I want to go the Plex route for something like this, considering it's only one or two movies in my collection and its working perfectly otherwise. Since the ability to turn off metadata fetching already exists within Infuse, it seems like it should be a simple fix.

  June 25, 2019 - 12:31pm
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 13,801
Kudos: 1,152

This probably stems from TMDb having a single entry that covers both of these videos.

One thing you could do in the current version is to direct Infuse to use local metadata for these 2 items.

To do this, follow these steps.

  1. Place both movie folders inside another folder. You can call this folder whatever you want, but for this example we'll call it 'Local'
  2. Add your artwork and XML files, placing them inside the relevant movie folders
  3. Browse through a folder favorite in Infuse and locate the Local folder.
  4. Once found, long-press on the Local folder and select the 'Use Local Metadata' option

This will remove any fetched metadata for the files in this folder, and rely on only the local metadata.

Infuse 6 for iOS and Apple TV is now available!

  June 26, 2019 - 9:09am
kai0n7's picture
Offline
Joined: Jun 2019
Posts: 11
Kudos: 1

Hi James. Thanks for the suggestion, it does work, though its more of a workaround than a solution.

Do you think a more proper handling of situations like this could be implemented in future versions?