7 posts / 0 new / Last post
#1  June 27, 2019 - 12:39am
fox1401's picture
Offline
Joined: Jun 2019
Posts: 2
Kudos: 0

I have recently upgraded the MacOS to Catalina (public beta), since then Infuse Pro cannot access the linked folder in my computer, it shows "Access denied".
Any ideas?

  June 27, 2019 - 8:18am
NC Bullseye's picture
Moderator
Offline
Joined: May 2016
Posts: 2,248
Kudos: 352

Have you set up SMB sharing in Networks? Have you set the folders to shared or the drive itself?

New OS sometimes means having to redo permissions for net access.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  June 27, 2019 - 9:09am
fox1401's picture
Offline
Joined: Jun 2019
Posts: 2
Kudos: 0

I have set the folders to share. I have checked that the SMB sharing status remains the same after the MacOS upgrade.

  June 30, 2019 - 11:15pm
danemacmillan's picture
Beta Tester
Offline
Joined: Jul 2017
Posts: 245
Kudos: 143

I actually experience this on Mojave. Only the default ~/Public directory appears, despite adding new directories.

  • Infuse Pro Lifetime
  July 3, 2019 - 9:24am
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 13,424
Kudos: 1,098

Thanks for the reports.

This seems to be something new in the b3 update. It's not yet clear whether this is an Apple bug, or something requiring a change in Infuse.

  danemacmillan wrote:

I actually experience this on Mojave. Only the default ~/Public directory appears, despite adding new directories.

This will happen if you attempt to connect as a guest (empty username and password) from Infuse to macOS.

Infuse 6 for iOS and Apple TV is now available!

  July 20, 2019 - 3:07am
Frantisek.Hagara's picture
Offline
Joined: Jul 2019
Posts: 1
Kudos: 0

I have the same problem with Catalina and Infuse on Apple TV. Maybe it has something in common with disabled NetBIOS in macOS 10.15.

There is release notes in Catalina beta 4 - https://developer.apple.com/documentation/maco...

"NetBIOS is disabled in macOS 10.15 to speed up mounting, browsing, and connecting to SMB shares. Some older printers and file servers may require NetBIOS to connect. (51119111)

To enable NetBIOS, you can create or edit the /etc/nsmb.conf file. If your system doesn't already have an /etc/nsmb.conf file, use the following Terminal commands while logged in as an Administrator:

echo "[default]" | sudo tee -a /etc/nsmb.conf
echo "port445=both" | sudo tee -a /etc/nsmb.conf

To disable NetBIOS, you can safely delete the /etc/nsmb.conf file."

I tried, but it didn't help.

  July 20, 2019 - 3:10am
john.burn's picture
Offline
Joined: Jan 2017
Posts: 2
Kudos: 0

I renamed my computer and recreated the shares and all is working just fine... Maybe you can try this? I also created a sharing only user on my Mac. I did all the things toward the same time so not sure which did the trick I'm afraid.

John.