3 posts / 0 new / Last post
#1  October 2, 2019 - 9:50pm
cyberschnauzer's picture
Offline
Joined: Oct 2019
Posts: 2
Kudos: 0

I'm encountering a strange issue and have had no luck figuring out why it's happening or how to stop it. It happens in iOS and tvOS, across multiple devices.

When browsing folders NOT in list view, the cover images for files will often change to the image for one of the other files. Sometimes this affects just one file... sometimes all of theme. The change will sometimes happen as I'm looking at the directory without me interacting with the app in any way -- images just start shuffling around, seemingly at random. This does NOT happen in list view, and switching to list view on the fly will show the proper image (switching back will still show the wrong images). Clearing the metadata cache will fix this temporarily, but within moments it usually starts happening again.

Attached are some screenshots, all of the same folder.

Image 1 - the folder looking normal right after I'd cleared the metadata cache and opened it.
Image 2 - Some of the files have taken on the image from another one, even though I haven't touched the screen.
Image 3 - Exited the folder and re-entered, and more of the images have been overtaken.
Image 4 - I clicked on a file to see its details (in another folder), and when I return the Season 3 folder, now that image has overtaken the rest.
Image 5 - Switching to List View shows the normal cover photos.

I have seen this behavior very occasionally in other places, but it's far more frequent in this particular show's folder. I've tried renaming the season folders, renaming the files, altering my meta data files, deleting all the NFO files, turning on/off Online/Local metadata... all to no avail. Here is an example of the file names from this folder:

/Mystery Science Theater 3000/Season 03/MST3K 0301 - Cave Dwellers.jpg
/Mystery Science Theater 3000/Season 03/MST3K 0301 - Cave Dwellers.mp4
/Mystery Science Theater 3000/Season 03/MST3K 0301 - Cave Dwellers.nfo
/Mystery Science Theater 3000/Season 03/MST3K 0302 - Gamera.jpg
/Mystery Science Theater 3000/Season 03/MST3K 0302 - Gamera.mp4
/Mystery Science Theater 3000/Season 03/MST3K 0302 - Gamera.nfo

Does anyone have any idea how to stop this from happening?

Attachments: 
  October 7, 2019 - 3:48pm
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 13,802
Kudos: 1,153

Welcome to the forum, and sorry for the trouble.

What type of device are you streaming from? Are you using SMB, or something else to connect?

Is the same issue present if you browse this series via the Library (via the Home or via the Search/Browse tab)?

Infuse 6 for iOS and Apple TV is now available!

  October 7, 2019 - 4:25pm
cyberschnauzer's picture
Offline
Joined: Oct 2019
Posts: 2
Kudos: 0
  james wrote:

Welcome to the forum, and sorry for the trouble.

What type of device are you streaming from? Are you using SMB, or something else to connect?

Is the same issue present if you browse this series via the Library (via the Home or via the Search/Browse tab)?

Thanks, James!

To answer your questions:

  1. The device streaming the files is a WD MyCloud EX2 Ultra.
  2. It's using SMB. To test I just set up a new SMB link directly to this show's folder, and the issue started happening once I'd entered/exited about 75% of the season folders (pausing inside each one for it to read and start showing the cover images). Once the issue started, going back to the folders it'd initially shown the proper images for immediately showed improper images (often not even images from the same season).
  3. Yes, the cover image issue happens from the Library as well. Under search, I searched for "MST" (the initial letters in all the file names) and about 95% of the results came back showing the same (incorrect) cover image. As I scrolled down, the image being shown incorrectly across 95% of the files flipped to a different one without me selecting anything.

Please let me know if I can supply any more details or test anything that might help identify the problem.