20 posts / 0 new / Last post
#1  December 17, 2019 - 10:33pm
webminster's picture
Offline
Joined: Oct 2019
Posts: 18
Kudos: 3

I observe that playback progress on titles I am playing in Infuse 6.x does not match progress on same movie I've been watching on another Plex client. E.g., on my Roku, I'm an hour into a movie. If I look at same through Infuse, it shows me only 30-ish minutes in (I think, where I left off playing on Infuse). I also noticed that if I start playback on Infuse, I regress to Infuse's idea where I'm at - and it screws up my real progress, as seen by the Roku.

Doesn't Infuse try to "play nice" with PMS so clients all have an idea where playback paused? Also, checking the PMS Web UI, it corroborates the Roku view, that I'm an hour in. So Infuse has a different metric, its own, apparently...
-Alan

EDIT: Additional data point, the official Plex client on the ATV4k shows the correct progress (same as Web UI and Roku).

  December 19, 2019 - 6:41am
gertgerman's picture
Offline
Joined: Nov 2019
Posts: 23
Kudos: 6

I've just tried this on my setup and my watch status is always the same on plex and infuse no matter which device I watch on and whether I use plex or infuse to watch on. For me they synchronise fine between plex and infuse.

  December 19, 2019 - 2:09pm
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 56
Kudos: 10

For me, since version 6.2.3, Plex and Infuse are out of sync (Progress and Watched Status)

https://firecore.com/forum/topic/24230

Since this imporvement was added: Faster indexing of Plex recently added items, Plex and Infuse are out of sync

  December 19, 2019 - 5:15pm
webminster's picture
Offline
Joined: Oct 2019
Posts: 18
Kudos: 3

Definitely could be this, am glad I'm not only one seeing this. Thanks for reply.
-Alan

  December 22, 2019 - 1:16pm
webminster's picture
Offline
Joined: Oct 2019
Posts: 18
Kudos: 3

Any comment from Infuse about this? Seems I'm not the only one with issue, and it's happened to me several times, several movies, when I switch back and forth from Infuse and my Roku Plex app. Particularly, if I watch a little bit on my Roku in one room, then come back to Infuse in another - Infuse has the wrong progress and wants to start playing from where IT left off, not where the server knows I left off.

  December 22, 2019 - 3:05pm
NC Bullseye's picture
Moderator
Online
Joined: May 2016
Posts: 3,007
Kudos: 397
  webminster wrote:

Any comment from Infuse about this? Seems I'm not the only one with issue, and it's happened to me several times, several movies, when I switch back and forth from Infuse and my Roku Plex app. Particularly, if I watch a little bit on my Roku in one room, then come back to Infuse in another - Infuse has the wrong progress and wants to start playing from where IT left off, not where the server knows I left off.

Are you letting Infuse complete it's sync after launching it? If you go to the settings > Library you'll see the status of iCloud sync and when all is done you'll see a "Last Updated" along with a date/time
Remember Infuse isn't allowed to run continuously it has to wait for the tvOS to allow it to do a background update. If you're trying before it's been given the chance it probably won't show the correct sync.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  December 22, 2019 - 3:31pm
webminster's picture
Offline
Joined: Oct 2019
Posts: 18
Kudos: 3

Yes, I am allowing it to complete, watching for the spinner to stop. Doesn't make a difference.

  December 22, 2019 - 7:09pm
NC Bullseye's picture
Moderator
Online
Joined: May 2016
Posts: 3,007
Kudos: 397
  webminster wrote:

Yes, I am allowing it to complete, watching for the spinner to stop. Doesn't make a difference.

The spinner does not indicate that it has finished it's sync. That's why I mentioned the library screen in the settings. The spinner only shows when it's updating content and metadata, not the sync. If you watch, you'll see it's still syncing after the spinner stops.

•Just Another Infuse User• •Not An Employee Of Firecore• •Certified Curmudgeon•

  December 22, 2019 - 7:17pm
webminster's picture
Offline
Joined: Oct 2019
Posts: 18
Kudos: 3

OK, so I can look at that after I play on the Roku later. If true, this sounds a bit counterintuitive - if the spinner doesn't indicate a sync has completed, surely I'm not supposed to go to the library screen each time and watch that to be sure?

  December 24, 2019 - 11:17am
webminster's picture
Offline
Joined: Oct 2019
Posts: 18
Kudos: 3
  NC Bullseye wrote:

The spinner does not indicate that it has finished it's sync. That's why I mentioned the library screen in the settings. The spinner only shows when it's updating content and metadata, not the sync. If you watch, you'll see it's still syncing after the spinner stops.

So, I tried this a couple of times. I started Infuse 6.2.4 after I'd watched to a specific point on the Roku. I watched specifically on the Library view to make sure it completed that sync. Went to play back the video in Infuse, and it was NOT at the point where the Roku Plex client stopped. It was at the point where I stopped Infuse playback before.

IMHO, there's something wrong here...
-Alan

  December 25, 2019 - 1:13pm
webminster's picture
Offline
Joined: Oct 2019
Posts: 18
Kudos: 3

Just as another data point... I compare the start point of a movie that I watched on Infuse, then watched more on the Roku Plex client. On my ATV 4k, if I start Infuse and definitely wait for the syncs to finish (looking at spinner and the Library view), it asks if I want to restart at 19:27. If I switch over to the Plex app on same box and hit play, it asks about starting at 35 minutes.

So Infuse appears to not be syncing the Plex server progress, and the Plex client is. Looks like Infuse only cares about playback progress in Infuse. Still looks like a bug or regression.

  December 27, 2019 - 11:06am
webminster's picture
Offline
Joined: Oct 2019
Posts: 18
Kudos: 3

How can I have someone look at this as a potential bug?

  December 28, 2019 - 9:00am
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 14,267
Kudos: 1,247

We're looking into a few reports of this.

If you have a chance to replicate this and send in a quick report, it may be helpful. Thanks!

https://support.firecore.com/hc/en-us/articles...

Infuse 6 for iOS and Apple TV is now available!

  December 28, 2019 - 12:15pm
webminster's picture
Offline
Joined: Oct 2019
Posts: 18
Kudos: 3

Thanks. Uploaded a diagnostic. No problem reproducing it, happens every time.

  January 4, 2020 - 1:07pm
webminster's picture
Offline
Joined: Oct 2019
Posts: 18
Kudos: 3

Any luck replicating this issue? Any hope for a fix?

  January 6, 2020 - 10:02am
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 14,267
Kudos: 1,247

We believe we've tracked down what's going on here, and plan to have a fix available in the upcoming 6.2.6 release.

Thanks for your patience.

Infuse 6 for iOS and Apple TV is now available!

  January 13, 2020 - 3:41pm
webminster's picture
Offline
Joined: Oct 2019
Posts: 18
Kudos: 3

Any idea when 6.2.6 will release?

  January 14, 2020 - 4:41pm
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 14,267
Kudos: 1,247

6.2.6 was just approved by Apple and should be available on the App Store shortly.

Thanks for your patience.

Infuse 6 for iOS and Apple TV is now available!

  January 15, 2020 - 1:09am
vdatanet's picture
Offline
Joined: Jul 2019
Posts: 56
Kudos: 10

Tested version 6.2.6 and progress sync with Plex shares seems to work now. Thanks!

  January 16, 2020 - 3:34pm
webminster's picture
Offline
Joined: Oct 2019
Posts: 18
Kudos: 3

It does look much better, from my preliminary testing. Thanks!