596 posts / 0 new / Last post
#1  January 13, 2011 - 9:35am
james's picture
Staff
Offline
Joined: Jun 2008
Posts: 12,014
Kudos: 833

Full details on jailbreaking the Apple TV 2 with Seas0nPass can be found here.

https://support.firecore.com/entries/387605

Trouble with DFU mode

Pre-launch checklist

  1. Ensure you're using a silver (aluminum) Apple TV remote. The older white (plastic) Apple TV remotes are missing the dedicated play/pause button and will not work.
  2. Disable the 'remote control infrared receiver' option through System Preferences --> Security --> General. (Mac only)

If you're having trouble getting the Apple TV into DFU mode try the steps below once you're at the 'Waiting for DFU' step.

  1. Disconnect Apple TV from USB. 
  2. Reconnect, and wait for the rapid flashing light.
  3. (Optional) If you're not seeing a rapid flashing light, hold down the menu and down arrow buttons for about 7 seconds (or until you see the rapid flashing light). 
  4. Hold the menu and play/pause buttons together for 7 seconds (count slowly - one thousand 1, one thousand 2, one thousand 3, etc...)

If all else fails...

  1. Connect the power cable along with the USB cable to get into DFU mode. Disconnect the power cable once the restore process begins.
  2. Try a different USB cable - a good, low cost cable can be found here.

Mac specific issues

  • Some users have reported issues when Filevault or Clean My Mac are in use. Disabling these should resolve most issues that arise during the jailbreak process.
  • If you're getting errors when creating the IPSW (stuck on Patching Ramdisk) please try the fix found here.

PC specific issues

  • If you're receiving errors regarding Microsoft .NET framework you can download and install the latest version here.
  January 13, 2011 - 10:03am
shahheidari's picture
Offline
Joined: Jan 2011
Posts: 3
Kudos: 0

james,I did everything correctly and when I connect my apple tv (black) to the HDMI it is stuck at the Apple logo as the light on the device is just a slow steady blinking...any idea with what going on?  I have jailbroken and did the tethering as well...thanks!

  January 14, 2011 - 6:41am (Reply to #2)
five12plus's picture
Offline
Joined: Jan 2011
Posts: 4
Kudos: 0

This was what I observed when I booted the aTV untethered... try repeating the tethered boot.

  January 14, 2011 - 5:12pm (Reply to #3)
pmcd's picture
Offline
Joined: Nov 2010
Posts: 80
Kudos: 0

I did to a tethered boot. I am a bit confused here. Is the process as follow? - jailbreak using SeasonPass with the atv attached to a Mac only with the usb wire.- unattach temporariliry- reattach usb and put in power chord at which point it boots ( do you have to force a boot somehow or is pressing tethered booth enough)- unattach the usb cable- attach to TV and ethernetInstall atv flash from Mac ( it sees the atv). Go to ATV----At this point my atv is showing the white Apple screen forever---- Now what? Each time we restart the atv will we then have to jailbreak again and go through the whole process or is the jailbreak permanent until a firmware upgrade? Do we have to keep the atv attached to the mac via the usb cable? I have tried all of this several times. The jailbreak part is easy ( with .66 of SeasonPass). It would be nice to be able to reuse the modified restore images. I think I will wait.... don't want to brick the atv. Plex is nice but not that nice. philip 

  January 16, 2011 - 3:56am (Reply to #4)
roemerv.107071's picture
Offline
Joined: Dec 2010
Posts: 2
Kudos: 0

Dear Philip, I experience exactly the same problems. It works one go, and than next time you start it up (next morning the 2nd time) it got hung and a restart lets the apple TV hang on the Apple Logo. I restored the Apple TV 2 now with Apples update. I hope it is not bricked now.I will wait further developments, it is now to buggy on several levels unfortunately.Warmest regards,Roemer

  January 17, 2011 - 6:21am (Reply to #5)
macmaniac's picture
Offline
Joined: Oct 2008
Posts: 12
Kudos: 0

The same for me here, it works till I toggle the power (to restart) and the there was the apple logo..... for ever....Hopefully you can fix that

  January 17, 2011 - 10:01am (Reply to #6)
rsands's picture
Offline
Joined: Jan 2011
Posts: 3
Kudos: 0

I have the exact same problem as described above. I hope there's a solution.

  January 17, 2011 - 2:23pm
breban's picture
Offline
Joined: Nov 2010
Posts: 16
Kudos: 0

I've been unable to get my Atv 2 into DFU mode.  Tried the instructions and other tricks online but still won't work.  Any suggestions?  I'm on 4.1.1.

  January 17, 2011 - 6:10pm (Reply to #8)
kerryk.17854's picture
Offline
Joined: Dec 2010
Posts: 3
Kudos: 0

make sure you are putting your apple tv into dfu mode before you do the tethered boot

  January 17, 2011 - 6:13pm (Reply to #9)
kerryk.17854's picture
Offline
Joined: Dec 2010
Posts: 3
Kudos: 0
  breban wrote:

I've been unable to get my Atv 2 into DFU mode.  Tried the instructions and other tricks online but still won't work.  Any suggestions?  I'm on 4.1.1.

  I can help you out if you can tell me exactly what you are doing and at which point of the jailbreak you are doing it. I have been raping my apple tv 2g the past couple of days working on figuring out other peoples problems :) happy to help,kerryk.17854 (nandor690)

  January 17, 2011 - 7:28pm
pmcd's picture
Offline
Joined: Nov 2010
Posts: 80
Kudos: 0
  james wrote:

4. When performing a tethered boot timing seems to be important. You will want to ensure the HDMI cable is connected promptly once the tethered boot process is complete, and before the white light on the AppleTV stops flashing.

 Hi James,I think for some ATV users the jailbreak process goes fine, but tethered boot will not work with the current instructions to put the ATV back into DFU mode. The power cable has to be not connected to get it into that mode. If the SeasonPass instructions could be modified to include that then that would be great. I tried many times with SeasonPass and the tethered boot. It failed right at the DFU stage.I could be wrong but I suspect that is the problem. The utility is otherwise really nice for me. philip 

  January 18, 2011 - 12:13am
bliip1234's picture
Offline
Joined: Jan 2010
Posts: 5
Kudos: 0

I had everything up and running for a couple of days.  While playing with Plex, I caused my ATV2 to reboot.  At this point I had to do another tethered boot and all appeared to be okay until I noticed that the ATV2 could no longer detect wireless networks.  I restored firmware in iTunes & that cured the issue.  Please note, it did not just forget networks, it could not detect them at all.  I will re-install atv Flash tomorrow when possible. Wonder if others have run into this issue?  My cable box rebooted, so it could have initially been related to a power surge rather than atv Flash. BLiip

  January 18, 2011 - 12:25am (Reply to #12)
pmcd's picture
Offline
Joined: Nov 2010
Posts: 80
Kudos: 0
  roemerv.107071 wrote:

Dear Philip, I experience exactly the same problems. It works one go, and than next time you start it up (next morning the 2nd time) it got hung and a restart lets the apple TV hang on the Apple Logo. I restored the Apple TV 2 now with Apples update. I hope it is not bricked now.I will wait further developments, it is now to buggy on several levels unfortunately.Warmest regards,Roemer

 Ok, I think I have this figured out. The reason why seasonpass fails with me is that my ATV will not go into  DFU mode with the usb and power cable plugged in. I then used PwnageTool and this linkhttp://www.youtube.com/watch?v=4EWKr7Ww_c0 which describes how to jailbreak it. The jailbreak went fine but the tethered boot didn't because the explanation that he gives to get the ATV back into tethered mode didn't work in my case. I had to - connect usb (wait 10 secs or so) and then the power- press menu+down for 6 secs ( until you get the faster flashing)- remove the power <-- this is the key- put the ATV into DFU mode by menu+play for 7 secs or so ( until faster flashing)- plug in power- it tranfers what it needs to- you get this weird error at the end but disregard- disconnect usb and plug in HDMI and then my network cableI can now ssh in. There is no way SeasonPass will work on my setup without slightly modifying the instructions to get it back to DFU mode when tether booting, but apart from that minor modification I am sure Seasonpass would work and that would be far nicer. I am now ssh'd into the ATV and I can install atvflash, although I'd like the latest version of Plex. philip Edit: Just installed Plex. Will remove it and install atvflash when it supports the latest Plex client.

  January 18, 2011 - 4:35am
russellk.3458's picture
Offline
Joined: Jan 2011
Posts: 8
Kudos: 0

Hi all, i would agree that the firmware flash seems to work find,  I am unable to tether boot the unit, half a day Smile it seems timing is important, although (laughing) i cant be fast enough.Looking forward to getting this working sometime, although i searched for the logs and cant find them, I use filevauilt and although trying several install locations wonder if this is one reason it is not working, oh well it is a beta and i will keep looking back for tips.

  January 18, 2011 - 4:35am
russellk.3458's picture
Offline
Joined: Jan 2011
Posts: 8
Kudos: 0

Hi all, i would agree that the firmware flash seems to work find,  I am unable to tether boot the unit, half a day Smile it seems timing is important, although (laughing) i cant be fast enough.Looking forward to getting this working sometime, although i searched for the logs and cant find them, I use filevauilt and although trying several install locations wonder if this is one reason it is not working, oh well it is a beta and i will keep looking back for tips.

  January 18, 2011 - 10:57am (Reply to #15)
breban's picture
Offline
Joined: Nov 2010
Posts: 16
Kudos: 0
  kerryk.17854 wrote:
  breban wrote:

I've been unable to get my Atv 2 into DFU mode.  Tried the instructions and other tricks online but still won't work.  Any suggestions?  I'm on 4.1.1.

 
 
I can help you out if you can tell me exactly what you are doing and at which point of the jailbreak you are doing it. I have been raping my apple tv 2g the past couple of days working on figuring out other peoples problems Smile
 
happy to help,
kerryk.17854 (nandor690)

 
Thanks Kerry.
 
I downloaded Seas0nPass and followed the instructions on http://support.firecore.com/entries/387605.  I'm having no problems up to step 4. I am following the instructions to plug in the aTV with my micro USB (and not the power cord).  I've tried just pressing Menu/Play for 7 seconds but nothing happens.  Other instructions recommend Menu/Down Arrow for 6 seconds (or until light flashes) and Menu/Play for 7 seconds (or until light flashes).  My aTV is recognized by iTunes but just sits there.  The screen on Step 4 doesn't go away.  Keeps telling me 'Waiting for device to enter DFU Mode'.  That's pretty much as far as I can go.
 

  January 18, 2011 - 4:53pm
genie's picture
Offline
Joined: May 2009
Posts: 2
Kudos: 0

Awesome engineering job, even script in itunes knocked me over as it paused and I was about to select IPSW ...lol   Obvious bug on mine here are the steps I took:   First Time: Tether boot worked first time youtube also ran although did not have Home Sharing On and Firecore ATV Black software could not see Ethernet number of ATV but only a AirPort Express 192.168.1.50 Could not seem to get Home Sharing On to connect   on 2 restart no menus in Movies or Internet - Brocken on 3 restart no video not even if you did not do tether boot on 4 restart no video rebuilt IPSW and restored on 3 restart no video on 4 restart no video   not sure but looks black listed now, problem with this approach is u have to log into home sharing to get music and thats where I do't trust Apple  not to be looking over my shoulder.   ooops will try itunes restore back..... keep me posted

  January 19, 2011 - 12:43am
sagdusmir's picture
Offline
Joined: Jan 2011
Posts: 2
Kudos: 0

Entering DFU mode for jailbreaking was not a problem. After that i had to find the right time to plug the power supply for doing a tethered boot.Except this: smooth sailing. The Webbrowser kind of sucks (Ad popups will replace your desired url, some javascript url onload foo does not work) and i do not need the weather app but Plex looks very promising. I love it. Thank you so much!

Life is wasted on the living.

  January 19, 2011 - 2:42pm
gustavk.33186's picture
Offline
Joined: Dec 2010
Posts: 7
Kudos: 0

Hey James,I did everything according to firecore and you after a power cut then the wifi disapaired. Before i could update to aTV Flash but with the new version of SeasOnPass I just get the standard apple software without aTV Flash. Could It have something to do with Itune used to update the software? Does Itune put back the original software in some way? or do you have eny oterh ideas? (I choose the right file to be used to update the software after pressing Restore and holding the Option-key) Everything looks correct while updating. Best rgds,gurrak29 

  January 21, 2011 - 12:47am
martinp.1353's picture
Offline
Joined: Jan 2011
Posts: 3
Kudos: 0

Hi! I want to jailbreak my ATV 2nd gen. I downloaded the seasonpass software and press create ipsw. As the download is complete it goes to unzipping sofware. After that it goes to patching ramdisk. This step never ends in my case. I let it run over the hole night and it was still patching ramdisk next morning.What can I do?Thanks!

  January 21, 2011 - 4:16am
stuartdonaghy's picture
Offline
Joined: Dec 2010
Posts: 18
Kudos: 0

Tried 3 times today to get it to work & have been unsuccessful. First time i managed to get it to boot up but couldn't SHSH in with aTV & the 2nd & 3rd time i could get it into DFU mode. Not sure what else to do no. Might just wait for untethered JB for Pwange Tool to arise. 

I'm a DJ, producer, gamer & geek. I work for the super-club brand Slinky & I'm also the label manager of Digital Remedy + a director at Promo Push

  January 21, 2011 - 10:13am (Reply to #21)
stuartdonaghy's picture
Offline
Joined: Dec 2010
Posts: 18
Kudos: 0

4th time of doing it & got it to work straight away :). I do have one question though., if i put my AppleTV to sleep or it goes on standby, will i need to boot tether it again?

I'm a DJ, producer, gamer & geek. I work for the super-club brand Slinky & I'm also the label manager of Digital Remedy + a director at Promo Push

  January 21, 2011 - 10:45am (Reply to #22)
MetalPhreak's picture
Offline
Joined: Jan 2011
Posts: 3
Kudos: 0
  pmcd wrote:

 - connect usb (wait 10 secs or so) and then the power- press menu+down for 6 secs ( until you get the faster flashing)- remove the power <-- this is the key <---- Seriously, this is really important.- put the ATV into DFU mode by menu+play for 7 secs or so ( until faster flashing)- plug in power- it tranfers what it needs to- you get this weird error at the end but disregard- disconnect usb and plug in HDMI and then my network cable

 Thanks for this. It's what actually got Seas0nPass to work flawlessly on my macbook pro. No errors with restore at all. You have to do the same thing each time you do a tethered boot as well.  before this, i was getting pretty much every different error you could think of Grin 1600/1602 mainly

  January 22, 2011 - 12:05am
andrewo.13266's picture
Offline
Joined: Feb 2010
Posts: 1
Kudos: 0

Can I use Seas0nPass on mac os x 10.5.8? What must I do?

  January 22, 2011 - 5:46am
andyf.01808's picture
Offline
Joined: Dec 2010
Posts: 2
Kudos: 0

This might sound stupid but how can you tell that the ATV2 is successfully jailbroken?

  January 22, 2011 - 7:12am
hanv.6614's picture
Offline
Joined: Jan 2011
Posts: 1
Kudos: 0

Hi James, Is it correct that I have to connect the TV by the HDMI cable to run the JailBreak properly? I'm having problems getting it running, and maybe this is the clue. However my TV set is two floors down, so it's rather inconvenient.

  January 22, 2011 - 10:53am (Reply to #26)
prawntoast's picture
Offline
Joined: Jan 2011
Posts: 2
Kudos: 0

No - you"ll only need to do a tethered reboot if you switch off completely.

  January 22, 2011 - 1:23pm
newrazr's picture
Offline
Joined: Dec 2008
Posts: 2
Kudos: 0

how long should "patching ramdisk" take?  Mine has been going for half-hour and so I'm wondering at what point do I know that it's not working and I should start over?  Thanks.

  January 22, 2011 - 5:28pm
reggiesfriend's picture
Offline
Joined: Jan 2011
Posts: 1
Kudos: 0

i've tried both pwnage and seas0npass and both times i can't get the computer to detect the atv2. i literally bought the atv2 today, and i'm using osx 10.6.6 and itunes 10.1.1i also can't find anyone else who is having this problem hit me up on here if you have any ideas... or at reggiesfriend@yahoo.com i bought the atv2 to install xbmc on its, and i hit a wall at what should be an easy part (feelin discouraged)

  January 22, 2011 - 6:04pm
guanghe's picture
Offline
Joined: Jan 2011
Posts: 1
Kudos: 0

When I create IPSW and enter DFU mode,Sea0nPass prompt "iTunes restore script failed! selecting IPSW in finder..."Who can help me?

  January 22, 2011 - 9:41pm
Fred.1's picture
Offline
Joined: Jan 2011
Posts: 1
Kudos: 0

I tried this about five times and gave up after the last time (which finally seemed to have worked) left my atv unable to detect my wifi network (or any other network either).

I'm currently restoring to factory and will wait and see as this project matures.

  Locked