615 posts / 0 new / Last post
  April 13, 2012 - 9:18am
jrb89728's picture
Offline
Joined: Jan 2012
Posts: 22
Kudos: 0

Any ideas on how to do this on the Mac? I wish iFaith were available for the Mac.

  April 13, 2012 - 4:41pm
dax3k's picture
Offline
Joined: Sep 2011
Posts: 5
Kudos: 0

OK so I accidently did a shift restore with itunes using a different signed IPSW blob (from another apple tv) on the apple tv. Itunes gave me a restore error 1600. Now my apple tv just keeps blinking fast (like it in a DFU mode constantly).

Any ideas what can be done in this case? thanks

  April 13, 2012 - 5:15pm
dax3k's picture
Offline
Joined: Sep 2011
Posts: 5
Kudos: 0

I do have the SHSH blobs saved from the Apple TV. Is there any way to restore this apple tv back to it's original state (4.4.4).

It looks like after trying to restore it in itunes with another signed blob, it put the apple tv in a constant DFU mode.

Please help!

  April 14, 2012 - 1:02am
Pochoco's picture
Offline
Joined: Apr 2012
Posts: 2
Kudos: 0

Hi!

Got ATV2 jb with the firmware 4.3  Want to go up to 4.4.4

Well I follow the instructions and finish with the same jb 4.3 (2557) instead 4.4.4., totally confused since I did never see nothing about 4.4.4.

What I did: First step 000xxxxxx_Apple_TV_2-4.3_(8F455)-blobs.ifaith, step 2 download and build the ipsw xxxxxxx_Apple_TV_2-4.3_(8F455) signed.

Step 3 (here my confusion) open Seas0nPass and get the 4.3(8f455) and follow all the other instructions to finally created the custom ipsw on desktop.

In what part I have to grab the 4.4.4?  Thanks in advanced!!

  April 14, 2012 - 4:02am
itimpi's picture
Moderator
Offline
Joined: Dec 2010
Posts: 2,055
Kudos: 112

You cannot get to 4.4.4 unless you already have 4.4.4 blobs for that particular ATV2.

Not quite sure what you did wrong but there is not much point in trying again.. You either have to stay on the 4.3 you already have, or go to the 5.0 tethered jailbreak.

I AM A USER - NOT A FIRECORE EMPLOYEE

  April 14, 2012 - 11:01am (Reply to #546)
Pochoco's picture
Offline
Joined: Apr 2012
Posts: 2
Kudos: 0
  itimpi wrote:

You cannot get to 4.4.4 unless you already have 4.4.4 blobs for that particular ATV2.

Not quite sure what you did wrong but there is not much point in trying again.. You either have to stay on the 4.3 you already have, or go to the 5.0 tethered jailbreak.

 

Ok, now I get the point, thanks!

  April 14, 2012 - 12:24pm (Reply to #547)
badassdes's picture
Offline
Joined: Jan 2012
Posts: 19
Kudos: 0
  ormanton wrote:

no that file in C disk is original. Ifaith should create its own file on your desktop.

I jailbroke (untethered) an Apple TV2, running 4.4.4  Just bought another Apple TV2 running 4.3.1 and trying to jailbreak.  When I jailbroke the 1st one, the 4.4.4 Firmware was saved on my MacBook computer (I can see the original file in "My Document" folder) . Is there's a way I can use this file and have a successful untethered jailbreak?  How can I use this method with these file saved in my computer?  Totally lost... Thanks in advance!

EDIT:  Just saw the above post.  Guess I cannot use the 4.4.4 file.

 

 

 

  April 23, 2012 - 11:37am
DrSavant's picture
Offline
Joined: Dec 2010
Posts: 1
Kudos: 0

The original guide is great, however my situation is somewhat unique - I hope the solution may end up being useful for someone.

 

Had to put up quite a fight to jailbreak my ATV2, while keeping 4.4.4, now that you can't do the whole SHSH upload biz.

My situation is also somewhat unique, as I don't have access to a normal Windows machine, having switched everyone in my house to Macs. I am running XP as a virtual machine in Parallels, on my Macbook though, and I have an old Asus laptop running a barebones XP for my kids to play with.

So, here's a custom guide to what I had to do (you will see the difference from the original guide in the body):

  1. Use IFAITH to "dump shsh blobs" from your official atv2 ipsw. disconnect it for now. (This was done on the ASUS).
  2. Use IFAITH to "build signed ipsw w blobs" (with device still unplugged). BUT DO NOT USE IT to jailbreak. Let it sit down on your desktop. (This was done on the VM)
  3. Use SEAS0NPASS (version 0.3.52.4905, new version will not work) to build custom firmware -right mouse click on ''create ipsw'' and choose your version -(with device still unplugged) BUT DO NOT USE IT to jailbreak. Let it sit down in My documents>seasonpass (VM)
  4. Download and install TOTAL COMMANDER(wincmd) (VM)
  5. Create new folder on desktop (VM)
  6. Drag SEAS0NPASS custom ipsw firmware onto TOTALCOMMANDER icon . You shoud now see the contents of the ipsw file on the left side. (VM)
  7. On right side of TOTALCOMMANDER navigate to the empty folder you just created. (VM)
  8. Mark the only 2 dmg files from left side and drag them to right side, let it extract to that empty folder. (VM)
  9. After extract close total comander. (VM)
  10. Now drag the IFAITH signed firmware from the desktop onto the TOTALCOMMANDER icon. (VM)
  11. On the left side you should see IFAITH ipsw files,on the right side 2 files extracted in step 8. (VM)
  12. Select the 2 files on the right and drag them to left side, into IFAITH signed ipsw. Let it overwrite. (VM)
  13. After all is done close total comander. (VM)
  14. You have now IFAITH firmware ipsw file on your desktop with signed blobs and SEAS0NPASS custom ipsw inside. Move the new IPSW out of the virtual machine onto your desktop. (Mac)
  15. Open Terminal and type "sudo vi /etc/hosts". Type in your password. Now scroll to the bottom, to a line saying 74.208.10.249 gs.apple.com. Hit DD, and then WQ - this will delete the line, save the file and exit. This will help you avoid the dreaded error 1600. (Mac)
  16. Connect your ATV2 to your Mac, (no power cord, USB only!), and enter DFU mode (hold menu and play for 10 seconds). Run RedSn0W and hit Pwned DFU (Mac)
  17. After it's done, open itunes , hold the Option key and click "Restore". Navigate to the file on your desktop called 00000xxxxx_IFAITH_Apple_TV_2-4.4.49A406a_signed.ipsw (Mac)
  18. Now iTunes will do a proper restore, using your custom built and signed firmware. Voila, you have a jailbroken, untethered 4.4.4 ATV 2
  April 24, 2012 - 10:09pm
shinings's picture
Offline
Joined: Apr 2012
Posts: 1
Kudos: 0

Hi all!

I'm new here. I just bought an ATV2 with stock 4.2.2 firmware. After reading this post i think i'm out of luck in upgrading to 4.4.4 and untethered jailbreak it.

My only options seem to be:

  1. Backup my 4.2.2 SHSH blob using iFaith and jailbreak it with Seas0nPass. (According to http://forum.firecore.com/topic/3418 4.2.2 should be untethered)
  2. Backup my 4.2.2 SHSH blob using iFaith and upgrade to 5.0 and tethered jailbreak (if i'm not happy, i can revert to 4.2.2 using my SHSH blob and jailbreak it under 4.2.2 untethered???)

Am i right, especially the second option in that i will be able to downgrade to 4.2.2 with my backed up SHSH blob?

It seems nowadays jailbreaking ATV is more complicated so i want to make sure that i don't do something only to regret later by not having the right knowledge.

Thanks for any help!

  April 29, 2012 - 7:51am
thewired1's picture
Offline
Joined: Apr 2012
Posts: 2
Kudos: 0

I'm trying to add a 2nd ATV2 to my house. First one I jailbroke with 4.3 around the holidays. No problems there and running fine. NOW, I'm trying to jailbreak another atv2 with 4.3. It's brand new and never jailbroken. I'd like to stay on 4.3 since it's untethered and the XBMC forums seem to recommend staying on 4.3 or older for performance with Eden.  Currently I cannot get past part one of this guide. iFaith keeps giving me an "unknown IOS detected" and shutting down.

Any ideas? Can I use tinyumbrella instead of iFaith for part 1?

 

 

  April 29, 2012 - 8:35am (Reply to #551)
andyfei's picture
Offline
Joined: Mar 2012
Posts: 65
Kudos: 0
  thewired1 wrote:

I'm trying to add a 2nd ATV2 to my house. First one I jailbroke with 4.3 around the holidays. No problems there and running fine. NOW, I'm trying to jailbreak another atv2 with 4.3. It's brand new and never jailbroken. I'd like to stay on 4.3 since it's untethered and the XBMC forums seem to recommend staying on 4.3 or older for performance with Eden.  Currently I cannot get past part one of this guide. iFaith keeps giving me an "unknown IOS detected" and shutting down.

Any ideas? Can I use tinyumbrella instead of iFaith for part 1?

 

 

Have you try more than one time? Sometime it does happened, also try different cable and PC.

  April 29, 2012 - 8:49am (Reply to #552)
thewired1's picture
Offline
Joined: Apr 2012
Posts: 2
Kudos: 0
  andyfei wrote:

Have you try more than one time? Sometime it does happened, also try different cable and PC.

 

I've tried about 3 times in a row all with the same results. I'll try again though. Regarding the cable; it's the same one I've used for the other atv2 with no issues so I'm fairly certain it's fine. I am doing it on a winxp image via parallels on osx. I'm going to try on an actual pc shortly. 

  April 30, 2012 - 2:13pm
c0de's picture
Offline
Joined: Apr 2012
Posts: 9
Kudos: 0

can you use atv flash with a jailbroken atv done with snowbreeze ?

keep getting error 1600 when using the guide here Frown

 

//c0de

  May 9, 2012 - 1:29am
JREED's picture
Offline
Joined: Oct 2011
Posts: 164
Kudos: 0

First time use this method step by step and successe Smile

Awesome instructions!

Thank you Cool

  May 10, 2012 - 2:25pm
atv2jber's picture
Offline
Joined: May 2012
Posts: 16
Kudos: 0

 

The only reason I registered to this site was to say "Thank you" for the wonderful instructions. I have an ATV2 with iOS 4.3 (8F455), older refurb. These steps (with the appropriate ipsw)  worked great! 

 

  May 12, 2012 - 8:57pm
CYBERxNUKE's picture
Offline
Joined: Mar 2012
Posts: 56
Kudos: 0

glad this helped everyone out.

That which is, is often forgotten, and that which has not, will remain forever.

  May 17, 2012 - 4:24pm
sk's picture
sk
Offline
Joined: Mar 2012
Posts: 8
Kudos: 0

I have two apple TVs one with version 4.1 (8M89) and 4.2(8C150). I've saved SHSH but I am not able to get the Seasonpass file for both of them as Seasonpass is not supporting any of them. I tried getting seasonpass on both a window and a Mac machine. Window machine doesn't even list any of these firmware and mac machine gives error message that this version is not supported.

How can I now get the untethered jailbreak for both of them?

  May 18, 2012 - 12:07am (Reply to #558)
Leven's picture
Offline
Joined: May 2012
Posts: 2
Kudos: 0
  sk wrote:

I have two apple TVs one with version 4.1 (8M89) and 4.2(8C150). I've saved SHSH but I am not able to get the Seasonpass file for both of them as Seasonpass is not supporting any of them. I tried getting seasonpass on both a window and a Mac machine. Window machine doesn't even list any of these firmware and mac machine gives error message that this version is not supported.

How can I now get the untethered jailbreak for both of them?

 

Similar issue to SK.  also posted a related question here (http://forum.firecore.com/topic/8069) looking for a version of MAC seas0npass that can build 4.1 (8M89) ispw without checking for valid saved blob 

  May 19, 2012 - 11:47am (Reply to #559)
sk's picture
sk
Offline
Joined: Mar 2012
Posts: 8
Kudos: 0
  Leven wrote:

 

Similar issue to SK.  also posted a related question here (http://forum.firecore.com/topic/8069) looking for a version of MAC seas0npass that can build 4.1 (8M89) ispw without checking for valid saved blob 

 

Hi,

The quoted message also doesn't have any resolution, may I know the version of season pass that can be used to build the custom IPSW for this version?

  June 12, 2012 - 2:16am
sHINE's picture
Offline
Joined: Jun 2012
Posts: 3
Kudos: 0

Hi!

I'm trying to use this tut to downgrade and jb my new atv from 4.4.4 to 4.3.

Problem is on step 3: I should use seas0npass to build the custom firmware. But if I choose the desired version it always tell's me to connect my atv2 before proceeding. Now what? If I connect it it says something like 'device not eligible'. Tried with all firmware-versions, except the v5.x ones, no luck. I'm using the seas0npass-version linked in the first post.

Also tried using sn0wbreeze 2.9.3 which builds me a new ipsw but iTunes wouldn't allow me to restore this (error 3194.

 

  June 12, 2012 - 7:09am (Reply to #561)
micheal96's picture
Offline
Joined: Apr 2012
Posts: 124
Kudos: 0
  sHINE wrote:

Hi!

I'm trying to use this tut to downgrade and jb my new atv from 4.4.4 to 4.3.

Problem is on step 3: I should use seas0npass to build the custom firmware. But if I choose the desired version it always tell's me to connect my atv2 before proceeding. Now what? If I connect it it says something like 'device not eligible'. Tried with all firmware-versions, except the v5.x ones, no luck. I'm using the seas0npass-version linked in the first post.

Also tried using sn0wbreeze 2.9.3 which builds me a new ipsw but iTunes wouldn't allow me to restore this (error 3194.

 

 

first, do you have the blobs for 4.3 if you just got the apple tv it's highly doubtful you have the blobs so the answer is no you can not down grade. Just jailbreak the 4.4.4 it's a  5 minute process

  June 12, 2012 - 8:20am
sHINE's picture
Offline
Joined: Jun 2012
Posts: 3
Kudos: 0

No, don't have the blobs for 4.3. Thought it was even possible without em Frown

I need to go back to 4.3 cause the new xbmc nightly builds won't run under iOS 5.x. My custom builds with pvr-support are based on the latest sources. I could use the official eden-release but without pvr-support which is useless for me.

So I have a new atv2 and can't use it like I would...too bad.

Regards

  June 12, 2012 - 10:47am (Reply to #563)
CYBERxNUKE's picture
Offline
Joined: Mar 2012
Posts: 56
Kudos: 0

Technically you could go back, just use any 4.3 blob to create your ipsw.

BUT it would be tethererd.

 

I have been successful in tethering every blob version i found online, tethered of course.

and if you cant find anything to tether with, i copied my tether files to the corresponding folders in Seas0npass that i would be using to tether.

 

 

 

  sHINE wrote:

No, don't have the blobs for 4.3. Thought it was even possible without em Frown

I need to go back to 4.3 cause the new xbmc nightly builds won't run under iOS 5.x. My custom builds with pvr-support are based on the latest sources. I could use the official eden-release but without pvr-support which is useless for me.

So I have a new atv2 and can't use it like I would...too bad.

Regards

 

That which is, is often forgotten, and that which has not, will remain forever.

  June 12, 2012 - 12:23pm
sHINE's picture
Offline
Joined: Jun 2012
Posts: 3
Kudos: 0

Hi!

Could you just point me to a small tutorial on how to do it. Doesn't matter if untethered or not, just want to use my custom xbmc builds. And could you send me a 4.3 blob, can't find one or I'm using the wrong search query Smile

Thanks!!

  June 12, 2012 - 6:48pm (Reply to #565)
CYBERxNUKE's picture
Offline
Joined: Mar 2012
Posts: 56
Kudos: 0
  sHINE wrote:

Hi!

Could you just point me to a small tutorial on how to do it. Doesn't matter if untethered or not, just want to use my custom xbmc builds. And could you send me a 4.3 blob, can't find one or I'm using the wrong search query Smile

Thanks!!

 

http://youtu.be/EJzwzoI83Qc

 

http://www.cyberxnuke.com/AppleTV/blobs/0000001D8906D5F6_4.3%20(8F455)_cache.ifaith

 Since i was at work, i forgot to show how to tether the device.

let me know if you want me to explain it..

its not hard, but you have to pay attention to what your doing.

 

That which is, is often forgotten, and that which has not, will remain forever.

  July 17, 2012 - 1:51pm
hre1's picture
Offline
Joined: Jan 2012
Posts: 4
Kudos: 0

after 3 days of trying to restore the 4.4.4 version on my atv2 i'm ending in the middle of nowhere... Frown no matter what i've done, i getting the 1600 error in itunes. i tried all the stuff:

  • ifatith with injecting (thanks to CYBERxNUKE and ormanton)
  • snowbreeze with costum IPSW
  • itunes down- and upgrading (10.4.2.1 to 10.6)
  • new usb cable
  • other pc

...

no way... the curious thing that it works with the 4.3 version. i' m able to restore my atv2 with the in the past (2011) originally saved ifaith blobs. the problem is that i only own that special 4.3 ifaith blob file. all my other shsh blobs are saved with tiny umbrella and they don't work with both above methods. so my question is, is there anybody out there which have success in restoring his atv2 with tiny umbrella blobs an when how did you do that?

@CYBERxNUKE

could you please explain how you restore the 4.4.4 tethered version with a arbitrary shsh blob?

thanks in abdvance!

  July 17, 2012 - 3:11pm
ormanton's picture
Offline
Joined: Feb 2009
Posts: 418
Kudos: 0
  1. 5.0.2 works well, no need to play around .
  2. Ifaith reads tinyumbrela files as well.
  3. Use redsnow to send your saved umbrela blobs to cydia server, then you can dowgrade upgrade from seasonpass with right click.
  4. 444 is untethered.
  5. 5.0.2 works well, no need to play around.

2008-atv1
2011-atv2
2012-atv3 (getting dusty waiting for a miracle)

  July 18, 2012 - 6:55am (Reply to #568)
hre1's picture
Offline
Joined: Jan 2012
Posts: 4
Kudos: 0
  ormanton wrote:

1. 5.0.2 works well, no need to play around .
2. Ifaith reads tinyumbrela files as well.
3. Use redsnow to send your saved umbrela blobs to cydia server, then you can dowgrade upgrade from seasonpass with right click.
4. 444 is untethered.
5. 5.0.2 works well, no need to play around.

thank you for you fast response ormanton. i tried to upload all my tiny umbrella shsh with redsnow (redsnow says also they get a valid ticket in cydia), but seasonpass don't recognize them. if i want to restore they 4.4.4 seasonpass says "this device isn't eligible for the requested build" and left me allone... The problem is, that 5.0.2 don't work well with xbmc pvr builds and i need the 4.4.4 for a special wake on lan configuration, so i need really this version...

Do you really sure that the tiny umbrella shsh works? Did yourself try that out? I can definitely say that when i use the tiny umbrella shshs, there is no success on build an ipsw. itunes throws the 1600 at the beginning of the restoring process and stops. But when i use my ifaith blob file i'm able to restore the 4.3 version and when i use a downloaded ifaith 4.4.4 blob from cybernuks webserver itunes beginn to restore the atv2 and breaks on the point where itunes try to restore the firmware.

I know that 4.4.4 is unthethered because i've got them on my atv2 in the past. Cool but in this thread cybernuke wrote, that it is possible using any ifaith blob for building an signed ipsw with the disadvantage of a tethered restore.

  July 18, 2012 - 1:48pm
ormanton's picture
Offline
Joined: Feb 2009
Posts: 418
Kudos: 0

1.What blobs do you have?

2.What firmware you want to be on?

3.PC or MAC ?

2008-atv1
2011-atv2
2012-atv3 (getting dusty waiting for a miracle)

  July 19, 2012 - 2:31am (Reply to #570)
hre1's picture
Offline
Joined: Jan 2012
Posts: 4
Kudos: 0
  ormanton wrote:

1.What blobs do you have?

2.What firmware you want to be on?

3.PC or MAC ?

 

  1. Tiny Umbrella 4.3.0, 4.4.2, 4.4.4 (don't work), ifaith 4.3.0 (work), ifath 4.4.4 form your webseite http://www.cyberxnuke.com/AppleTV/blobs/000000... (don't work)
  2. 4.4.4
  3. PC

 

Can you please guide me how do i jailbreak my atv2 box with a arbitrary shsh blob (like you say in Post #565)?

 

If you nee more information, please feel free to ask me Smile

 

Thanks in advance!