Today we're proud to introduce 'Seas0nPass' - a new jailbreak tool designed specifically for the AppleTV.

Seas0nPass was created exclusively for the AppleTV user, as previously no AppleTV specific jailbreak tools were available. Seas0nPass allows you to easily create custom AppleTV IPSW files and restore them in iTunes (similar to the existing Pwnage Tool app). Also included is a simple 'tethered boot' option which aids in using newer AppleTV firmwares when an 'un-tethered' jailbreak is not yet available.

Seas0nPass is available for free, and is open source. The source code is available on Github.

What can I do with Seas0nPass?

  • Jailbreak the AppleTV with the latest 4.1.1 (iOS 4.2.1) software.
  • Easily perform a 'tethered boot' (when necessary).

What is the difference between a 'tethered' and 'un-tethered' jailbreak?

A tethered jailbreak requires the AppleTV to be connected to a computer for a brief moment during startup. An un-tethered jailbreak removes this restriction. Un-tethered jailbreaks are are a bit more complex and take more time to complete.

How much does Seas0nPass cost?

Seas0nPass is available as a free download - no strings attached.

What are the minimum requirements?

Mac: OSX 10.6 or later

Windows: coming soon

Can I use this on my iPhone, iPad, or other iOS device?

Nope. Seas0nPass is designed exclusively for the 2nd gen AppleTV.

Sounds great! Where can I download it?

The Seas0nPass app, and user guides can be found at Seas0nPass.com

Comments are welcome below. Enjoy Smile

Update: Seas0nPass 0.6.4 has a bug that is preventing items from the 'Manage Extras' menu from being installed. An update will be available shortly.

Update 2: 0.6.5 has the Manage Extras menu install bug fixed.

Update 3: 0.6.6 includes a handful of fixes most notably one that addresses a pesky wifi network issue.

Update 4: 0.6.7 includes a number of improvements. Full changelog here.

If you're still having trouble when using the latest version please view the troubleshooting tips here.

Comments

Submitted by Anon on January 16, 2011 - 12:34pm

I found that by ensuring that all other programs and windows are closed, including iTunes allowed the script to work properly.

Also note that after the installation, remove the USB cable for a seconds, then reconnect for tethered reboot. Once the process is complete, plug in the power supply BEFORE disconnecting the USB cable.

Then disconnect the USB cable, and get the HDMI cable connected.

Let the box come up and you should be good to go.

Submitted by Anon on January 16, 2011 - 1:05pm

I agree, peeps think there internet game is good. prob a nerd and there moms smacks them around. on top that dont have no idea how to even use a JB, and most people got it to work, except this winney lil baby. and your lazy too! waiting on them to release a better JB. But NOOO u cant make one your self. Do you even know what BETA is. NOPE! i bet not cause your an idiot!

Submitted by Anon on January 16, 2011 - 3:12pm

I have updated to 0.6.6. Still got the problem that I always have to connect to my WIFI manually again after starting from sleep mode.

Submitted by Anon on January 16, 2011 - 3:21pm

Learn how to spell, then write your post...

Submitted by defenderoftheo on January 16, 2011 - 5:05pm

Worked fine for me. Just because you are hidding behind a computer screen does not give you permission to be an Ass. If you dont like it and it does not work for you, go use something else.

Submitted by defenderoftheo on January 16, 2011 - 5:06pm

Beta = Testing. What part of that dont you get?

Submitted by jhernandez86 on January 16, 2011 - 6:35pm

I am still running the old 0.6.4 JB version since I do not have major issues.  Plex is version 0.6.4 and I am still able to play movies.  However, I did notice some picture degracion on a 1080p movie.  I am running both Boxee and ITV2g

and the picture queality is a bit noticeable, but it may be becasue the Graphic card on Boxee is much powerfull.  Plex is currently up to version 0.6.6 but people are having some issues with it.

Once again this is a beta test, and people should aknowledge that under beta you are going to have a lot of issues, Hence Beta testing.

 

Submitted by Anon on January 17, 2011 - 10:39am

Hey Firecore. I know you are waiting on an un-tethered' jailbreak and that is ok, but in the mean time please be sure to keep everything else that you want inside the aTV2 ready before this release. Most of us can only relate to a complete "point and click" interface installation. People only feel ripped off, when they can't get it to work properly and don't understand the concept of "beta". You might consider calling the " beta " something like, advanced user testing release even though most of us feel it's easy in some cases.

Regards

IQunder80

Submitted by Anon on January 17, 2011 - 11:57am

I'm having the same problem

Submitted by catj.36136 on January 17, 2011 - 2:02pm

thats true im still have the same wifi problem

Submitted by catj.36136 on January 17, 2011 - 2:04pm

it's like seasonpass 06.6 didnt fix the wifi problem,people still havi the problem goin on 

Submitted by davidp.3483 on January 17, 2011 - 3:29pm

Guys—I have two Apple TV 2Gs that I have jailbroken with your help—thanks again! One with seas0npass and the other with the standard pwnage instructions on appletvblogr.com. Both have been working great and streaming with Plex, etc. installed via ATVFlash and working great for days.
After about three days both seem to have lost HDMI output. I can hear the sound from the menu/remote buttons but neither output video. I can also SSH into the ATV2 fine.  Have you seen any that have the HDMI fail after days of working fine?
The only thing that has been done is adding an HDMI switch box and plugging a new HDMI cable on each. The video worked after this but stopped sometime several hours later when I went back to them.
Also the tethered boot seems to fail based on the below, but still actually boots the ATV2 back to a solid light, the beep when I hit menu/remote keys, but still no video out from the HDMI.  I can SSH in too so it is up and running but still no video?
Should I jailbreak them from the beginning again?
Help!
David
Device must be in DFU mode to continueopening device 05ac:1227…Found device in DFU modeChecking if device is compatible with this jailbreak Checking the device type Identified device as AppleTV2,1 Preparing to upload limera1n exploit Resetting device counters Sending chunk headers Sending exploit payload Sending fake data libusb:error [darwin_transfer_status] transfer error: timed out Exploit sent Reconnecting to device libusb:error [darwin_close] USBDeviceClose: no connection to an IOService Waiting 2 seconds for the device to pop up…opening device 05ac:1227…Uploading iBSS.k66ap.RELEASE.dfu to device [==================================================] 100.0% libusb:error [darwin_reset_device] ResetDevice: device not responding libusb:error [darwin_close] USBDeviceClose: no connection to an IOService Waiting 10 seconds for the device to pop up…opening device 05ac:1281…Setting to configuration 1Setting to interface 0:0Uploading kernelcache.release.k66 to device [==================================================] 100.0% libusb:error [darwin_transfer_status] transfer error: device not responding (value = 0xe00002ed) Exiting libpois0n David-Pleskos-Mac-mini:tethered david$ =

Submitted by jhernandez86 on January 17, 2011 - 3:34pm

So today I was giving the option to update both Plex and CouchSurfer.  I have not tested couchSufer but I was able to play with Plex 0.6.6.  The movie section not gives you the option to resume a movie from where you left off.

Note:  I played a 100p animation movie "Dispicable Me" on both ITV and Boxee, and the quality is noticiable to the naked eye.  The opening scene has clarity, light, saturation and contrast.  On the Boxee box you can notice that the image is fully taking advantage of 1080p.  On the ITV2g, the picture quality is not as crisp and vivid.

However, this may change with a posible hardware upgrade in ITV3g.

 

 

Submitted by Anon on January 17, 2011 - 6:26pm

Come on guys where's the Windows version?

Submitted by tuckero.5881 on January 17, 2011 - 9:39pm

Hey I love the beta however nothing in nito TV will download and couch surfer, plex and last.fm wont. I just get error messages. Maintenance and nito tv come up though. Jail broke with seasonpass using beta 2. If anyone can help?

Submitted by wim.nijntjes on January 18, 2011 - 1:08pm

I'm not the only one having this problem but what is the cause?
                                    Itunes restore script failed!, selecting IPSW in Finder
Why can some people jailbreak their Apple-TV and why I can't ????
Bill

Submitted by richardm.5449 on January 18, 2011 - 3:19pm

I jumped at the chance to get the beta version for the price.

Already had my appletv jailbroken and running windows.

Few months down the road nothing for the windows users and ZERO updates.

Give us something to test or this is nothing but A JOKE.

Yes every 1 chime in and say what doesn't the end user understand what BETA means and don't start sh*t here.

 

 

 

Submitted by Anon on January 18, 2011 - 4:13pm

Are you retarded? I think you are getting upset? However, I hear quite a bit of anger in your responses because you didn't do your homework! Dumb@ss

Submitted by Anon on January 19, 2011 - 4:47am

Do you have a release date for Seas0nPass to windows? When it's released ill buy firecore . but not untill then. Like buying a locked bicycle without the key Wink

Submitted by wim.nijntjes on January 19, 2011 - 8:42am

Hawkroad, is this a question for me?
I justdownloaded the Seas0nPass from this site.
So I assume it's the latest.
Wim
 

Submitted by Anon on January 19, 2011 - 10:57am

No sorry, off-course question for fire-core crew ...

Submitted by rvmeush on January 19, 2011 - 6:31pm

I'm having a power issue trying to connect the Apple TV to my Macbook Pro.   Every time that I try to connect the ATV to the usb port I get a popup error message saying that a usb device was drawing too much power and that the usb ports are being disconnected.   I have the Macbook connected to the charger but that doesn't seem to make any difference.   After removing the ATV I can connect a 2.5" external drive and it seems to get power without any problem from the Macbook.  I have also tried having the ATV powered and that also doesn't seem to make any difference.   Can anyone tell me why this ATV might be causing problems, and if there is any way to correct it?   Thanks.

Submitted by GoPronto on January 19, 2011 - 8:46pm

i think this may be a question for Apple Support.. not Firecore Smile

Submitted by wim.nijntjes on January 20, 2011 - 7:05am

Updated the SeasOnPass to the latest.
Error is still there.
 
  

Submitted by Anon on January 20, 2011 - 10:12am

Any plans to add wireless keyboard and mouse support? There is news of hack that supports Wiimote and Bluetooth Keyboard. Is this going to be part of ATV anytime soon. How are people entering url's on couchsurfer?

Submitted by 180 on January 20, 2011 - 11:26am

currently, using soft key interface like when u r entering wifi pwd or like when enabling home sharing.

Submitted by batman on January 20, 2011 - 12:01pm

Yeah that's painful right? :) one key at a time... rather would be great to have a qwerty keyboard support...something like boxee qwerty remote.

Submitted by gustavk.33186 on January 20, 2011 - 12:55pm

Exactly the same problem for me, have tried 10 times without the new menus!!

Submitted by 180 on January 20, 2011 - 1:14pm

definitly!

though there is a blootooth stack u can download and istall using nioTV in order to connect bt keyboard. though enter and arrow buttons only would work Frown

Submitted by carlosfhdez@gma... on January 20, 2011 - 2:24pm

After $50 and several hours of reading posts and trying with the software and my apple tv, I just have to say that I totally regret to waste $50.

This is a waste of money and time and this is a garbage of software.

Submitted by carlosfhdez@gma... on January 20, 2011 - 2:26pm

After $50 and spend so many hours reading posts and trying with the software and my apple tv, connect, disconnect, reconnect, press menu and paly/pause, etc... I have to say this is a totally waste of money and time.

This is GARBAGE!!!!!!!

Submitted by carlosfhdez@gma... on January 20, 2011 - 2:28pm

How can be plug at the same time the HDMI and micro USB???? This is amazing,...

Submitted by Anon on January 20, 2011 - 5:42pm

Simple, you don't you unplug the hdmi cable and just use usb and power

Submitted by jdubsu on January 20, 2011 - 5:59pm

I accidentally clicked DON'T ENABLE UI in the first step. Now I tried to reinstall and it does not prompt me to enable/disable UI. Any help on how to get back to the option?

Submitted by Anon on January 20, 2011 - 8:53pm

Okay I'm new to this but learning fast. You can use your iphone or ipad w/ the remote app as a keyboard. Also when you are on a website you can click the center button on your apple remote and it can be used as a mouse.

Submitted by carlosfhdez@gma... on January 20, 2011 - 9:20pm

Finally I was able to complete the whole process. BE ALERT, because DOESN'T WORK!!!!!! Don't waste your money and time in this piece of junk of software,.....

Submitted by Anon on January 20, 2011 - 9:26pm

Did anyone try installing the XBMC on the Apple TV 2G yet ? If yes, feedback plzz

Submitted by Anon on January 20, 2011 - 9:46pm

just tried it. it froze halfway through the install process and now my atv is bricked. Trying to restore.

Submitted by GoPronto on January 20, 2011 - 9:48pm

As it has been said many times before, its a Beta , Read befor you buy !..
 

Submitted by Anon on January 20, 2011 - 11:11pm

Same here....mine bricked and now wont teether reboot or do anything. Grrrr

Submitted by Anon on January 20, 2011 - 11:14pm

I use to have this problem with my MacBook Pro 17," oddly it seemed to be cable specific. I switched to a different USB cable and no error message; switchback and got the error message. Problem has since resolved itself, it was the MacBook Pro, as I could not reproduce the error with a MacBook Pro 13"

Submitted by pmcd on January 21, 2011 - 1:10am

"So today I was giving the option to update both Plex and CouchSurfer.  I have not tested couchSufer but I was able to play with Plex 0.6.6.  The movie section not gives you the option to resume a movie from where you left off."

 

Mine resume just fine.

 

philip

Submitted by Anon on January 21, 2011 - 4:06am

had do SSH to install XBMC. went fine but loads up and then just shuts down.

Submitted by 180 on January 21, 2011 - 7:43am

thats an expensive keyboard Smile

Submitted by dwightb.5612 on January 21, 2011 - 8:45am

I would like to personally thank Firecore for the jailbreak and atv. I upgraded my macbook with snow leopard last night and jailbroke the apple tv. I purchased the atv app and it installed without any problems other than plex. Last fm, nito, and couch surfer work great but after I installed plex and rebooted it went to the apple logo with the box flashing. I will try to install plex again sometime over the weekend but I must say I am impressed with the whole bundle. This little box is fairly quick on the web; email, craigslist, best buy, compusa etc. Facebook didn't work, nor did the music on the band's myspace page. I just wanted people to know that this jailbreak indeed works as does the beta software. I like the weather and rss feeds also. Thanks again firecore

Submitted by 180 on January 21, 2011 - 9:31am

does anyone know how to uninstall, lets say last.fm? it is great that i can install it, but how to get rid of?

Submitted by richardm.5449 on January 21, 2011 - 10:03am

Maintenance,manage extras,right click what you want to delete and you'll have the option

Submitted by 180 on January 21, 2011 - 10:30am

thaaaaaank you :D

Submitted by jhernandez86 on January 21, 2011 - 10:40am

go back to maintanance and find the install application use the left arrow click on the remote and that should do it