Today we're happy to release new versions of Seas0nPass and aTV Flash (black) that are compatible with latest 5.0 (iOS 5.1) software running on the ATV2. A ton of work has gone into getting everything updated, and a huge thanks go out to Brandon Holland (@640774n6) and Dustin Howett (@DHowett) who both contributed immensely in adding support for 5.0.

Is this a tethered or untethered jailbreak? What's the difference?

Seas0nPass currently provides a tethered jailbreak for the new 5.0 (iOS 5.1) Apple TV software. Functionally, both jailbreak types are identical, the only difference being that a tethered jailbreak requires the Apple TV to be connected to a Mac/PC when first powering it on. Since the Apple TV doesn't have a battery, and is rarely ever powered off, this usually only needs to be done once.

What's new in the 5.0 Apple TV software? Should I update?

  • New interface: - Fast, visual access to all content choices
  • Movie purchases in iCloud: Support for buying movies on Apple TV and playing back purchased movies from iCloud
  • Genius Recommendations: Recommendations for content on the iTunes Store based on previous rentals and purchases
  • Screensaver photos: New National Geographic photos built-in for screensaver
  • On-device sign-up: On-device sign up for content partners on Apple TV using your Apple ID

Updating to the new 5.0 software is not required, and all aTV Flash (black) features will continue to be supported on Apple TV versions 4.2 and later.

What about the ATV3, will this work?

Unfortunately not. Work is still ongoing for the ATV3, and we hope to have more news soon. For the latest updates be sure to follow us on Twitter.

Which plugins are currently supported on 5.0?

  • Couch Surfer (works)
  • Last.fm (works)
  • Maintenance (works)
  • Media Player (works)
  • NitoTV (works)
  • Plex (works)
  • Remote HD (works)
  • Rowmote (works)
  • RSS Feeds (works)
  • Weather (works)
  • XBMC (works)
  • Overflow (not working)

Note: Non-working items require an author update for 5.0 compatibility.

Screenshots! Give us screenshots!

We listened to all the feedback we received and integrated the new icons in a way that should please virtually everyone. Check out the screenshots below for the final result.


Media loves to live in the top row.


If you don't have room, it will hang out in its next favorite spot.


All-new top bar navigation means navigating through your media has never been easier.

Superb! Where can I get it?

Seas0nPass 0.8.3 is available as a free download from Seas0nPass.com.

aTV Flash (black) 1.4.1 can be found in your account under the Downloads tab.

If you're not yet using aTV Flash (black) you can learn about all the great benefits here.

Enjoy. Smile

Comments

Submitted by CrashHouse on March 31, 2012 - 3:57pm

Btw PLEX does work, only lacks icon in main screen and server must be added manually.

Submitted by CrashHouse on March 31, 2012 - 4:04pm

Not sure if I like the new layout for my Apple TV. Maybe just have to get used to it.

 

Submitted by iksg_photo on March 31, 2012 - 4:12pm

Thank you so much for this new update....awesome.  So far so good except one noticeable issue and this could be just me.  After jail breaking my ATV2 and installing aTVFlash the device does not pickup my wireless.  I have to use the ethernet port.  Any suggestions?

Submitted by Anon on March 31, 2012 - 4:29pm

If I update the maintenance tab, will this install the latest version of Atv2 version 5 ? And make it into the tethered version. Without the extras like xbmc. I have updated all the features in manage extras, except for maintenance. In fear that it will update me to the new version 5. Is this the case?

Submitted by gordonr.1446 on March 31, 2012 - 4:35pm

I am still having an issue in the tethered mode.

 

 

Please assist if you can. I have done this process over and over today and yesterday.  I am obviously doing something wrong in the tethered boot. 

When it says to hook up the HDMI cable to the ATV2, does the other end of the HDMI cable need to be plugged into the TV? If so it's just a matter of dragging my iMac out to the other room beside my TV.

Submitted by ianm.6743 on March 31, 2012 - 4:48pm

Me too -- only have two icons showing  'Computers' and 'Settings'.  the settings has the Firecore logo.

 

I've tried jailbreaking twice now...no luck. 

HELP!!

 

Submitted by johne4281 on March 31, 2012 - 5:10pm

I have a concern, if anyone can help.

I managed to Jailbreak my ATV2 but once you unplug the power cable it reset the ATV 

The reset was an image of a USB cable and the itunes icon. IS this always the case or am I missing something or some step.

Please help if possible.

 

Thanks.J

Submitted by Anon on March 31, 2012 - 5:13pm

do you get pass the itunes restore?

Submitted by tobyc.6286 on March 31, 2012 - 5:32pm

I keep getting an AFP error when going into Media Player.  I get "An Error Occured, AFP connection failed, unreachable network or incorrect login."  But it won't let me go to the settings section to put the correct login info.  When I press the menu button it just pops back up until the ATV2 reboots.

Don't use your settings backup it ain't worth shit.

Oh and now the constant buffering is back.  Joy of joys.

Tethered boot, and buffering, should have stayed with 4.4.4

 

Submitted by johne4281 on March 31, 2012 - 5:36pm

I get the same thing any solutions?

Submitted by Anon on March 31, 2012 - 6:25pm

If the Apple TV simply reboots/reloads/relaunches (which is pretty common when jailbroken) do you still need to be tethered? What about when holding both Menu and Play/Pause for 10 seconds to reboot, will you need to be tethered then? Or is it ONLY when the power is lost or disconnected that you need to be tethered?

Submitted by thomasm.2118 on March 31, 2012 - 6:25pm

thanks work like a charm B-) looking forward to the atv3 update.... good work

Submitted by Anon on March 31, 2012 - 6:33pm

What, you're not done making it work yet? I was waiting on you :).

Submitted by Anon on March 31, 2012 - 7:36pm

I found he easiest way was to take the laptop into the lounge room to do the whole process , meant I was near anything I needed to disconnect etc.

Easier when in a home theatre set-up

So after doing the tethered boot , disconnect the usb from the aTV , then hook-up the HMDI. then all was good.

Submitted by tobyc.6286 on March 31, 2012 - 8:36pm

Yes this is to be expected.  This is a "tethered boot" jailbreak.  Which means each time you boot the ATV it needs to be tethered to the computer.  Eventually they'll come out with an untethered jailbreak.

 

 

Submitted by masses33 on March 31, 2012 - 9:00pm

I don't see the file (4.4.4) in download tab in my account. Why? 

Submitted by masses33 on March 31, 2012 - 9:04pm

Sorry 1.4.1...

Submitted by stuckinjail on March 31, 2012 - 9:39pm

Does anyone else get a black screen, ipsw and restore went perfectly, then booting it up i got itunes logo with usb cable, so i did tethered boot, adding hdmi cable before led goes solid results in no signal, hdmi cable unplug/replug results in a black screen...

What did I do wrong?

Submitted by gordonr.1446 on March 31, 2012 - 9:48pm

I have the same problem. I have been trying since yesterday with no luck. Really can't figure out what step I am missing.

I am still not sure about the HDMI cable thing. Do you have to have one end of the HDMI cable plugged into the TV when plugging in the other end into the ATV2 during the tethered mode.

Submitted by gordonr.1446 on March 31, 2012 - 9:48pm

I have the same problem. I have been trying since yesterday with no luck. Really can't figure out what step I am missing.

I am still not sure about the HDMI cable thing. Do you have to have one end of the HDMI cable plugged into the TV when plugging in the other end into the ATV2 during the tethered mode.

Submitted by gordonr.1446 on March 31, 2012 - 9:48pm

I have the same problem. I have been trying since yesterday with no luck. Really can't figure out what step I am missing.

I am still not sure about the HDMI cable thing. Do you have to have one end of the HDMI cable plugged into the TV when plugging in the other end into the ATV2 during the tethered mode.

Submitted by gordonr.1446 on March 31, 2012 - 9:48pm

I have the same problem. I have been trying since yesterday with no luck. Really can't figure out what step I am missing.

I am still not sure about the HDMI cable thing. Do you have to have one end of the HDMI cable plugged into the TV when plugging in the other end into the ATV2 during the tethered mode.

Submitted by stuckinjail on March 31, 2012 - 10:04pm

I left it with black screen for ages and my atv's screensaver kicked in, the screen wigged out but its now working, i just putting atv black on it now and it just restarted - back to black screen, so hopefully when screensaver kicks in again it'll be all good. *fingers crossed*

 

Edit: Yep its all good! Installing Media Player now... 

Submitted by Anon on March 31, 2012 - 11:27pm

Make sure you have the power cord in and the light doesnt stop blinking....did the same thing to me and I found out my cord wasnt plugged in all the way

Submitted by Anon on March 31, 2012 - 11:29pm

How do I get nitoTV on with 5.o?? Its not working for me

Submitted by fradex on March 31, 2012 - 11:52pm

Easy download and install. Thanks. My comment is a request. The new Apple setup is cluttered by the time one adds the ATVFlash features. A great addition would be a feature that allowed reorganizing the icons to personal priorities. The major fault in Apple's design is that the icons cannot be turned off. I will NEVER use this structure to watch MLB, the NHL, etc. But I can't turn them off. My screen has become cluttered. Can you create an On/Off or at worst a "Grouping" category under which non-used icons can reside? I really preferred 4.4 as these same locations were hidden in the menu driven format. What you have done vastly improves what Apple has created, but that has been the case all along. Thanks for your efforts.

Submitted by Anon on April 1, 2012 - 12:04am

Same problem here... Idk what to do... I can restore to 5.0 just fine... Jaailbreak gives me 1604

Submitted by Anon on April 1, 2012 - 12:46am

Hi Firecore,

Could you kindly clarify if after updating to 5.0, and installing ATv Flash 1.4.1, can we restore from backup? Since the backup does not store passwords, we get stuck at the 'incorrect login' pop-up. My settings, watched files etc are backed up and I would like to use the restore function after updating to 5.0.

thanks, and keep up the good work!

Submitted by vanbatenburg.jo... on April 1, 2012 - 2:22am

XBMC working already B-)

Check here

 

By the way BIG thnx Firecore ;)

Submitted by Anon on April 1, 2012 - 2:54am

Submitted by carolines.4760 on April 1, 2012 - 3:24am

Once they get it working, you can get Overflow, that puts all your unused menus in one place so they aren't visible.

http://www.youtube.com/watch?v=0P6ynXzzz84&sns=em

Submitted by carolines.4760 on April 1, 2012 - 3:31am

Read?

Submitted by Anon on April 1, 2012 - 3:53am

nitoTV is working for me with latest 5.0 (iOS 5.1)

Thanks

Submitted by Raingods on April 1, 2012 - 5:02am

FC logo/button NOT showing after JB. solution: Switch ATV language to English, mine was on Dutch so it was not showing the FC logo after a succesfull JB

YES now i am sure it has been JB....Great, lets play.

 

Submitted by sacomino@optusn... on April 1, 2012 - 5:37am

Installation went well - ISPW all OK, Restore successfully completed in i-Tunes. Then I unplugged the USB, plugged in the power and then HDMI --- PROBLEM -- I also had the itunes logo with usb cable, so i did tethered boot, I believe that the trick is as follows:

Keep the power plugged into the ATV, simply unplug the HDMI cable, and then plug in the USB cable. Perform the Tethered Boot. Follow the instructions as the device enters DFU mode, Press and Hold the Menu and Play/Pause for 7 seconds as instructed.

When SeasOnPass completes the Tethered Boot, guess what, the light is no longer rapidly flashing..

Now unplug the USB cable, keep the power plugged in and simply plug in the HDMI cable ... and no more itunes logo with usb cable! I was then able to install ATV Flash .. Well, it took me ALL Day to get it sorted - but it's working like a charm now ...

Cheers to All... It's time for a beer or three now Cool

Submitted by smbatts on April 1, 2012 - 6:22am

Here is the bad news... try restarting your Apple TV or turning off the Power once every thing is working.  You will need to ReTether again, this stinks! Sorry to pass on the bad news.

Submitted by sacomino@optusn... on April 1, 2012 - 6:54am

I was really happy until I read your post ...

Very True... You lose everything - the whole lot - all gone....

Forget this update totally until Firecore FIX it ...

Not worth wasting ANY MORE TIME on it !!!

Now I need a bottle of Scotch ... Frown

Submitted by smbatts on April 1, 2012 - 7:04am

I wrote FCore and mentioned the problem... if I hear back I will post.  Enjoy the Scotch!

:X

Submitted by sacomino@optusn... on April 1, 2012 - 7:17am

Thanks, look forward to a resolution soon...

Scotch is going down a real treat - will sleep well tonight !

Cheers,

Grin

Submitted by Anon on April 1, 2012 - 7:48am

I installed Sea0npass on my ATV flash black with 5.0 software installed with no problem. After installing ATV flash 1.4.1, restarted the Apple TV, to take the update and teetered it to start again. I see no difference.I still see the Firecore Logo. I don't see the Maintenance setting anywhere. After Installing ATV Flash, no errors. It installs to the correct ip address, but why can't I see the maintenance tab, only the Red Firecore Logo. Any suggestions. I tried installing it a few times. No change.

Submitted by fradex on April 1, 2012 - 8:01am

Adding Overflow would greatly improve the situation. Hope you're right - that it's just a matter of getting it working with 5.0.. Overflow is an answer. I had forgotten I had used it in the past versions of ATVFlash. Thanks.

Submitted by daveh.9348 on April 1, 2012 - 9:15am

No problems with install but I'm having picture stutter and lip sync issues.

Any one else?

Checked all settings and its on a wired network so I'm guessing its the media player.

Any help would be appreciated.

Submitted by robrushe on April 1, 2012 - 10:19am

Perfect. No bugs for me!! Every went as instructed and works fine.:)

Submitted by Anon on April 1, 2012 - 10:41am

Buy a brain...

Submitted by Anon on April 1, 2012 - 10:57am

I hope Firecore address this issue. I am tired of going throught the entire process just to have it revert as soon as it loses power. My computer is not close to my TV so everytime I go to attach to the HDMI and power, it reverts.

Submitted by cosmos503 on April 1, 2012 - 11:49am

Can anyone who has done the tethered jailbreak please respond to this simple question? I would love to know.

Submitted by koolenboer on April 1, 2012 - 12:05pm

I got the same problem Frown

Submitted by Anon on April 1, 2012 - 2:31pm

I'm having a problem with the jb after I perform the ether boot and connect to my tv the fire core settings ion is there and there is a empty spot that says "maintenance" and i can click on it and I go in to manage extras but there isn't anything there....HELP

Submitted by Anon on April 1, 2012 - 2:52pm

I tried to do the JB with seasonpass and I can't seem to enter dfu. Please help

Submitted by Anon on April 1, 2012 - 2:57pm

Hey thanks man,

i was going crazy...that was the best tip...
my language was german.

Now I know that my tav is working too Wink