We've had our nose to the grindstone as we work to add features and squash bugs, so without any further ado we're happy to present you with a brand new version of Media Player.

What's new in version 0.6?

  • Added AC3 (5.1+ surround) sound
  • Added access to DVD menus during playback (press menu)
  • Added low buffer detection warning (prevents stuttering)
  • Improved playback of larger files
  • Improved buffering and re-buffering (when required)
  • Improved FF/RW controls for larger files
  • Improved audio decoding performance
  • Improved center channel (voices) audio mixing
  • Improved DVD file playback
  • Improved file sorting logic
  • Improved performance and memory management
  • Improved error handling
  • Resolved DVD subtitle issues
  • Resolved stalls observed with some files during and after FF/RW
  • Resolved synchronization issues observed after buffering some files
  • Resolved audio synchronization issues
  • Resolved rare floating crash observed at the end of some files
  • Resolved resume related playback issues
  • Resolved various screensaver related issues
  • Local files are now hidden when one or more remote shares are setup
  • Minor metadata fetching improvements
  • Minor UI improvements
  • Other miscellaneous fixes

How do I get it?

Media Player 0.6 can be installed on your ATV2 through the Maintenance --> Manage Extras menu.

Enjoy!

Comments

Submitted by Anon on July 28, 2011 - 3:46am

Hi !
How do i activate the AC3 5.1 sound. With all sources (DVD, MKV, M4V) i only have 2.1 sound, eventhough my ATV2 is connected to my reciever with an HDMI cable. When I stream from itunes files (airplay), the 5.1 works perfectly well. Could you help me ?

Submitted by søren on July 28, 2011 - 5:17am

Hi!
Media Player crashes every time I start fetching from my shared external WD-Harddrive.
The Harddrive is USB connected to my iMac. All the dvds are in ISO format.
What am I doing wrong? 

By the way. I tried to attach a screendump to this post, but when I click on the image icon it jumps to a page saying "Page not found"?

Regards
Søren 

Submitted by davige on July 28, 2011 - 8:43am

FYI - You need to go here for that:

http://forums.plexapp.com/index.php/topic/2606...

You'll need to use Terminal to SSH into your AppleTV. If you're a newbie, Google instructions. It's easy!

 

 

Submitted by duncanv.0851 on July 28, 2011 - 10:21am

Works fine here! It only crashes when going through the menus. Once playing it always keeps playing.

The problem seems to occur when browsinhg through HD's connected via an Airport Extreme after my AppleTV went to sleep or when the screensaver was active. The HD's are there but once you want to browse one again.. the AppleTV2 restarts.. this can happen a couple time when you have to go a couple layers deep (external HD 1/movies/science fiction for example). Sometimes is restarts at every level I want to go into to. SO in the case of the example I had 3 reboots. Not always though. But again once playing I'm fine.

Q: why not include the beta and rc of Plex so I don't have to go through the terminal approach ;)

Keep up the good work!

 

Submitted by james on July 29, 2011 - 9:43am

The AC3 and DTS sound options can be found in the Media --> Settings menu.

Submitted by james on July 29, 2011 - 9:44am

Best to submit a bug report so we can look further into it.

http://forum.firecore.com/topic/4291

Submitted by james on July 29, 2011 - 9:45am

Hmm, can you submit a bug report and provide more info?

http://forum.firecore.com/topic/4291

Submitted by james on July 29, 2011 - 9:45am

Great. Glad to hear you're enjoying it. :)

Submitted by hirohashi on July 29, 2011 - 2:11pm

working great!! i've heard that srt subtitles will be supported in the next version. 

 

BUT, what about subtitles within the media files ? i have a bunch of mp4 with video, audio AND subtitles (not vobsub).

 

congrats !!! great work !

Submitted by Anon on July 30, 2011 - 6:45am

I am getting serious digital noise/distortion via the ATV2 optical out when AC3 or DTS is enabled, and the MKV file being played has one or other of those soundtracks. Once I disable DTS for a file with a DTS soundtrack, I get stereo audio fine - same goes for AC3.

Submitted by eidetic on July 30, 2011 - 6:49am

I'm getting serious noise/distortion issues via the ATV2 optical out when AC3 or DTS is enabled in Media Player, and the file type being played (MKV) has either of those soundtrack types. Once disabled, the stereo audio plays fine.

Submitted by Anon on July 31, 2011 - 1:07am

Hi,

I have downloaded the beta black version of Apple TV.

But how do I access my Media on my computer - I need instructions please. I have tried playing around with it, but cannot find my media files.

Submitted by willem.foto@gma... on July 31, 2011 - 4:38am

How can I uninstall an application, for example "weather"?

 

By the way, I ve also the same problem with aTV crashing when browsing an external HD or my Time Capsule. The strange thing is that it worked for a couple of weeks. Could it be something with my update to Lion?

Submitted by eidetic on July 31, 2011 - 8:13am

Solved by updating to latest ATV2 firmware and re-jailbreaking.

Submitted by Anon on July 31, 2011 - 3:14pm

Cheers Mate !!!

Submitted by Anon on August 2, 2011 - 9:16pm

Just want to say I really like your product! Really like the progress you are making. My only issue is I have no luck with ISO support whatsoever. Media player will recognize VIDEO_TS folders as ISOs but will not recognize an actual ISO. I have tried using a SMB share on a Win 7 drive as well as from my freenas. Any ideas?

Submitted by Anon on August 3, 2011 - 9:53pm

But it´s in the features list of this version!!... one of the reasons that I bought the aTV software...!!??

Submitted by rukan2011 on August 4, 2011 - 7:36am

I have huge library of MP3 files on my home server, but the media player sees those files recogineses the album art but does not show or play the MP3 files. Please help me. Movies no problem. Pictures no problems. Wish there was a slide show included in the player.

Thanks

Submitted by james on August 4, 2011 - 12:00pm

A guide for getting everything set up can be found here.

http://support.firecore.com/entries/20322512-m...

Submitted by james on August 4, 2011 - 12:01pm

Most of the browsing related crashes will be resolved in the next version. Stay tuned.

Submitted by james on August 4, 2011 - 12:02pm

We're planning to add a robust music player in a future version, but as of right now MP3s are not currently supported. Sorry.

Submitted by kimmogimble on August 5, 2011 - 7:11am

Any idea when next update is coming? I want subtitles! :)

 

Submitted by james on August 5, 2011 - 10:06am

We're planning to have a new version (that supports subtitles) available next week.

Submitted by james on August 5, 2011 - 10:07am

Any unwanted items can be removed through the Maintennace --> Manage Extras menu.

Simply highlight the item to remove, and press the right arrow (>>) button.

Submitted by james on August 5, 2011 - 10:08am

We're working on embedded subtitles as well, though it's 50/50 at this point on whether or not these will be supported in the next version.

Submitted by ausafk.2567 on August 7, 2011 - 6:16pm

Having a bit of a problem when playing a ripped 1080p blu ray mkv format getting an playback error each time and the file size is about 30gb 

any solutions?

Submitted by ausafk.2567 on August 7, 2011 - 6:24pm

Hey Mate 

Just wondering about your mkv file by any chance is it a blu ray rip

Submitted by Anon on August 7, 2011 - 10:00pm

Just want to say I really like your product! Really like the progress you are making. My only issue is I have no luck with ISO support whatsoever. Media player will recognize VIDEO_TS folders as ISOs but will not recognize an actual ISO. I have tried using a SMB share on a Win 7 drive as well as from my freenas. Any ideas?

Submitted by james on August 8, 2011 - 8:29am

Best to submit a bug report so we can look into it.

http://forum.firecore.com/topic/4291

Submitted by superdifficult on August 8, 2011 - 8:43am

The new player works FLAWLESSLY (so far) for me. Awesome work guys and I'm thrilled to know it's just going to get better. Money well spent.

 

Patrick

Submitted by peterj.3872 on August 9, 2011 - 5:12am

Any estimate of when we might see this new player?

I've also got a library of mp3s that I'd like to be able to play via the ATv2

Submitted by globuze on August 9, 2011 - 10:49am

MP 0.6 works effortless and it's definitely the killer app as it does not require a central server.

Big thanks to the dev team.

Is there a similar app or further development for IPad ?

Submitted by Anon on August 9, 2011 - 11:21am

I'm also having crash problems. They used to happen every now and then, especially when I would take a few minutes to choose a file to play and the HDD attached to my Airport Express would go to sleep. It never bothered me that much: ATV2 would restart in a second and I'd choose the file and it was fine (not great, but I could live with it).

But a couple of days ago, every time my ATV2 starts there is a message "Waiting of network time..." (that will never end. I have to press MENU on my remote so it will quit this message), and since then ATV2 has been crashing EVERY FEW MINUTES. Whenever I choose a netflix movie, or a file from the HDD, and even sometimes I don't have to do anything-- it will crash FROM THE MAIN MENU, completely out of the blue.

At the moment I am reseting my Airport Express, re-jailbreaking my ATV2, and reinstalling everything. I hope it works, but I REALLY wish I didn't have to reboot everything... It is the biggest pain.

Submitted by Anon on August 9, 2011 - 1:54pm

Trying it out but every 720p mkv I try streamed via smb from my synology will start out fine and smooth(no stuttering) but freezes eventually. Sometimes after 2mins, sometimes after half an hour. This will be a great product if playback can be made more robust!

Will file a bugreport..

Submitted by Anon on August 12, 2011 - 6:14am

Hi Guys!

I also have the black aTV running and tested a lot of different solutions before. But on any movie player it is necessary to have a streaming-server in my network. Not here! I enables direct streaming from a NAS or a shared folder from any system.

With this good work in mind I would appreciate to find a similar solution for my iPad! Can you suggest something, or are you developing a fork for it?

Thank you very much for your attention.
Markus

Submitted by Anon on September 4, 2011 - 5:09am

Installed the software after the latest seasonopass and everything works fine, exempt the Plex software doesn't work anymore. I saw at the Plex forum that many users have this problem. I hope either plex, or seasonopass developers find a solution. I am sure, but if you are depending on plex don't update yet via a new jailbreak or latest Firecore software.

Submitted by Anon on March 31, 2012 - 11:02pm

Do you have any plan to have Media Player to support RMVB format? That is the only thing left for me to think FireCore is the PERFECT solution.

Submitted by johnp.33080 on April 21, 2012 - 8:30pm

Having recent troubles with audio distortion during loud or intense portions of a movie. when i enable any audio features in settings it gets worse. it is a recent thing yet i can't recall updating any features, nor does it seem related to any particular file or format. is there a setting I am missing? are all audio settings for media player resident under settings?