Today we're proud to introduce 'Seas0nPass' - a new jailbreak tool designed specifically for the AppleTV.

Seas0nPass was created exclusively for the AppleTV user, as previously no AppleTV specific jailbreak tools were available. Seas0nPass allows you to easily create custom AppleTV IPSW files and restore them in iTunes (similar to the existing Pwnage Tool app). Also included is a simple 'tethered boot' option which aids in using newer AppleTV firmwares when an 'un-tethered' jailbreak is not yet available.

Seas0nPass is available for free, and is open source. The source code is available on Github.

What can I do with Seas0nPass?

  • Jailbreak the AppleTV with the latest 4.1.1 (iOS 4.2.1) software.
  • Easily perform a 'tethered boot' (when necessary).

What is the difference between a 'tethered' and 'un-tethered' jailbreak?

A tethered jailbreak requires the AppleTV to be connected to a computer for a brief moment during startup. An un-tethered jailbreak removes this restriction. Un-tethered jailbreaks are are a bit more complex and take more time to complete.

How much does Seas0nPass cost?

Seas0nPass is available as a free download - no strings attached.

What are the minimum requirements?

Mac: OSX 10.6 or later

Windows: coming soon

Can I use this on my iPhone, iPad, or other iOS device?

Nope. Seas0nPass is designed exclusively for the 2nd gen AppleTV.

Sounds great! Where can I download it?

The Seas0nPass app, and user guides can be found at Seas0nPass.com

Comments are welcome below. Enjoy Smile

Update: Seas0nPass 0.6.4 has a bug that is preventing items from the 'Manage Extras' menu from being installed. An update will be available shortly.

Update 2: 0.6.5 has the Manage Extras menu install bug fixed.

Update 3: 0.6.6 includes a handful of fixes most notably one that addresses a pesky wifi network issue.

Update 4: 0.6.7 includes a number of improvements. Full changelog here.

If you're still having trouble when using the latest version please view the troubleshooting tips here.

Comments

Submitted by richard webb on January 12, 2011 - 10:00am

cannot get my internet connect to my app tv 2 anymore now wifi or ethernet any ideas 

Submitted by michaelb.47321 on January 12, 2011 - 10:10am

Will the white remote work for this? I lost the silver one that came with the Black ATV. I can't seem to get it to DFU.

Submitted by dicx.2139 on January 12, 2011 - 10:26am

Got it and good to go. All fixed up now.

 

Two observations:

 

1. It works better if you restore your Apple TV to factory before trying anything.

 

2. You might need to plug in your HDMI cable a few times.

 

Other than that, all set up and now waiting for something good to come out of it Smile

Submitted by Trousers on January 12, 2011 - 10:31am

Sorry Tony I also got the script error once. I basically started all over again. Closed iTunes, unplugged aTV, started with 'create ispw' again. The second time iTunes launch and it looks like it run some sort automated script that goes through a sequence to open the script file (a bunch of widows open/close quickly). This second time it worked. Not sure why and i know that doesn't help too much.

Submitted by dicx.2139 on January 12, 2011 - 10:40am

I know it is just perception, but it seems like I could get it into DFU mode easier from the terminal command than through the Pass, I assume it is the same command in a GUI wrapper.

Submitted by Anon on January 12, 2011 - 10:46am

This looks like the best Apple TV tool available so far, thank you for creating this and I will recommend it to our readers.

Submitted by Anon on January 12, 2011 - 10:54am

I tend to think that you won't be able to give up your mac mini in this circumstance because you still need a provider and a mac to sync to. The aTV is only an accessory to the big picture. Or you can just get an ipad.

Submitted by flolen on January 12, 2011 - 11:02am

1600 error...

tried 2 different cables, tried it on macbook pro, tried it on imac, no chance.... same error every f**cking time i try...

got the same error with 4.0. Frown

there were also no solution,.... pls this time!!!

thx

 

Submitted by tonyelbatal on January 12, 2011 - 11:18am

I do agree with flolen, I did many tests on 2 Macs, and having the same problem. This proves that "Seas0nPass" needs more updating to cover all the possible situations, since many users such me and you are still having the SAME problem. Thanks for sharing Smile

Submitted by richard webb on January 12, 2011 - 11:20am

i jailbroke with season pass and my internet and wifi are gone and wont reconnect to app tv 2 anymore !!! any ideas lads

Submitted by richard webb on January 12, 2011 - 11:21am

i jailbroke with season pass and my internet and wifi are gone and wont reconnect to app tv 2 anymore !!! any ideas lads

Submitted by Anon on January 12, 2011 - 11:22am

I think you are confused Rick. They have not made ANY money off of seas0npass. This is a FREE application that they have developed and provided to us for free. This has nothing to do with ATV Flash(Black) or anything else you may have purchased from FireCore.

As with any jailbreaking application there are going to be bugs, those bugs will get worked out over time but being unappreciative and rude after they have worked hard to make the jailbreaking process easier is not going to solve anything.

Submitted by flolen on January 12, 2011 - 11:22am

tried 3rd cable and 2nd macbook, 1600 error again Wink

are there different apple tv 2g around???

Submitted by maartend.14708 on January 12, 2011 - 11:23am

ERROR 1602

 

Still after 4 attempts the dam thing is not jailbroken...

Submitted by mohammads.1230 on January 12, 2011 - 11:28am

I can't use the old one and now with this the minimum requirements is 10.6!! I have a PowerMac G5 and the sys I have is 10.5.8 and this is the latest sys for this Mac!!....So you mean I have to buy a new Mac to use the App!?

Submitted by Bluntman on January 12, 2011 - 11:38am

I have no problems as long as I don't unplug the power cable after tether, so I used my laptop and am praying for no power outages. Anyone know why it won't load if power is lost to the unit? Also Plex seems to not load anything all the menus look great but when a video, music, app, anything is attempted to load...it doesn't . 

 

Thanks for the good work on the Beta so far.

Submitted by karstenw.41209 on January 12, 2011 - 11:59am

Work fine for me with th efirst try!

Cool

Thank You for the cool stuff and the perfect Software, 

now the smal black one is realy cool, iam happy to wait for the next tools

 

Karsten

Submitted by ajayk.04583 on January 12, 2011 - 12:21pm

A complete waste of time.  After 3 hours got it working and loaded ATV flash that I bought weeks ago but hadn't loaded.  Another hour later got that up....delighted to see new icons on my ATV.....a flashless browser WOW.  Ok I was actually happy bit then...... unplugged everything to take it back to where my TV is connected.  Switched it on...black screen only.  Did the tethered boot 3 times...nothing.  Removing the jailbreak now.  At least my ATV worked earlier, hope it still does after I remove the jailbreak.

Submitted by tonyelbatal on January 12, 2011 - 1:13pm

I suspect this is something related between Apple TV 2G, iTunes version and the software. It's not the cable. iTunes/Seas0nPass are seeing the Apple TV so it's surely not the cable. Any update on that matter?

Submitted by kuse on January 12, 2011 - 2:33pm

Thanks!!!!

I am now owner of aTV Flash (black) Grin

Submitted by Anon on January 12, 2011 - 2:36pm

I am sorry for your troubles I like you have my aTV ready to go in another room, but I have read 2,301 times on this site and quite a few others that once you unplug after the jailbreak and install - YOU'RE GONNA LOSE YOUR WORK- and have to re-tether the aTV. Or you can wait for an UN-Tethered version. (or get and extension cord and a few usb extensions (to bring it into the vicinity of your computer- something my friend did). But at any rate good luck.

Submitted by Brischinski on January 12, 2011 - 2:41pm

This is just crap. There is no other word for it.

Submitted by Brischinski on January 12, 2011 - 2:42pm

This is just crap. There is no other word for it.

Submitted by andrewb.0074 on January 12, 2011 - 2:59pm

I had the same 1600 error and shut down all running applications then used a different USB port and it worked fine. Hope you get it working!

Submitted by craigs.109225 on January 12, 2011 - 3:05pm

Also Can not find WIFI Network after booting up after Season Pass has loaded 

 

Has anyone got any tips to get the WIFI Working?

 

Thanks

Craig

Submitted by tonyelbatal on January 12, 2011 - 3:15pm

And when you tried another port, did the "iTunes script failure" error happen? after you managed the 1600 error, did you manage to tether boot the Apple TV 2G and install the aTV Flash on it? Thank you Smile

Submitted by Trousers on January 12, 2011 - 3:39pm

Thanks Firecore. The 'original' tethered JB looked scary, so was glad to see SeaonPass. 

Pretty much worked out first time (slight hiccup with the script error, just reran the process and it went through). Followed the steps to the letter and my aTV was jb'd, tether booted and aTV flash installed. Installed LastFm, nitoTV and browser. Browser quite impressive for revision 0.7 (or whatever it is). Nytimes looks decent and was suprised to see video worked in the browser when I clicked on some (nytimes isnt flash so thats prob why I assume). Note to others, having an iphone to remote control aTV makes using the browser much easier (entering urls and controlling mouse). Now I'm streaming from lastFM with the artist slideshow just kicked in ... neat. 

Looking forward to the other cool stuff coming down the line. Streaming directly from a disk hung off an Airport Extreme is my number request and the main reason I signed up. 

Keep up the good work. 

 

 

Submitted by GoPronto on January 12, 2011 - 3:42pm

I think you has mist the  point, this is still a beta run its not a finished Product , so you must expect these set backs, it has been good of Fire core to let us all join in the beta when it could have just been an elite few.
Just give them a break...  and relax Smile
 

Submitted by Anon on January 12, 2011 - 4:17pm

Try unpluging the hdmi cable both frm the tv and aTV... (NOT THE POWER PLUG)... that should clear it...

Submitted by ericsch333 on January 12, 2011 - 4:27pm

Ok I got it installed everything is working great I am very happy I am very impressed with this thank you the software is much better if you tried lasT night you might want to try with a new account and re install Itunes. 

Submitted by jhernandez86 on January 12, 2011 - 5:45pm

I was working on Plex, and finally got to play some movies, but the buffer pause is to slow at this time.

If this feature gets to work, I will be really impressed.  Not bad for a beta, can wait to get the un-thethere version so I can move my ITV to the bedroom.

Really promissing

 

 

Submitted by Anon on January 12, 2011 - 6:02pm

Ok, so I've jailbroken the AppleTV, restored it, Jailbroken it again. Unplugged the HDMI from both the TV and aTV and the wifi is still non-existent. What's going on! Does anyone have this problem too? What else can I try? Please help..

Submitted by Anon on January 12, 2011 - 7:36pm

Grrrr... thought I would give the jailbreak a shot and I ended up just giving up... I think i'm going to wait for an untethered jailbreak. Anyway... now i'm having a problem with my ATV2 just stuck in DFU mode. Frown I plug it into my tv with the power and it tells me I need to hook it up to itunes. Hook it up to iTunes and try and do a restore and now it just HANGS.... HANGS.... HANGS.... force quit iTunes and restart it and it just HANGS.... HANGS.... different spots each time. I can't get a full restore to the factory default. Once it hangs - the blinking like it just flickering non stop. Not sure what to do now. Frown Anyone else have problems restoring???

thanks!

Submitted by rvmeush on January 12, 2011 - 7:36pm

Could you please provide a link for the YouTube video showing how to successfully do the jailbreak?  Thanks.

Submitted by xtrne on January 12, 2011 - 8:01pm

Tried twice, but still didn't work.

Restored back to basics again.

Please anyone that knows why it hangs just before it finishes, I would be happy to know.

 

Thanks

Submitted by Anon on January 12, 2011 - 8:06pm

Wow guys, you have done an amazing service to the AppleTV 2 jailbreak community. Seriously awesome work.

Submitted by xavierg0499 on January 12, 2011 - 10:26pm

I  can't wait for this to completely work. I did everything correctly, my apple tv enters DFU mode then the ipsw restore file opens up...then...ITUNES opens .... then......nothing.  I get raplid blinking lights on my ATV but nothing gets restored ... Weird !!!!!

Submitted by Anon on January 12, 2011 - 10:38pm

So, I thought I was pretty savvy at the whole JB thing. So, I gave this a shot. Followed the directions to the T. Everything was perfect until it got to the restore part in iTunes. It hung at about 99% on the status bar. Never finished. Now it won't let me do a normal iTunes factory restore. Am I missing something very obvious? It's been about two days of doing the process over and over again. With the power cable, or without. Anyway anyone else run into this??

Thanks

N

Submitted by Anon on January 12, 2011 - 10:55pm

Me too, ever figure this out?

Submitted by Anon on January 12, 2011 - 10:56pm

Download and install Tinyumbrella, let it run in the background during restore.

Submitted by paulvahe@mac.com on January 12, 2011 - 10:56pm

Same here! Please help!

Submitted by Anon on January 12, 2011 - 10:58pm

Download and install Tinyumbrella, let it run in the background during restore.

Submitted by pzanni on January 12, 2011 - 11:02pm

Same here, hopefully there will be a release soon of seasonpass for ppc macs.

Submitted by pzanni on January 12, 2011 - 11:11pm

Yes, OS X only but nowhere did it state in the beta release that it would be intel only.

A power PC release for seasonpass would be appreciated! 

Submitted by paulvahe@mac.com on January 12, 2011 - 11:11pm

Could you please elaborate? Do we need to run the TSS server? Thanks!

Submitted by flolen on January 13, 2011 - 1:33am

got it working!!!!

itunes script error always appered so it doesn't matter (just choose it manually in itunes)

tried it over and over on all different usb-ports and voila suddenly it works...

didn't change anything... just try and try and try...

Submitted by Anon on January 13, 2011 - 1:48am

Hi there,

Is anyone else having the same problem or know how to help? I've tried running this to the letter but struggling to get into DFU mode. I plug usb in (without power) as described, press menu/play for 7-10 (sometimes longer) but the apple TV does not enter DFU. After 3-4 seconds of pressing the light flashes quickly and this continues until I let go of the buttons. I've also tried holding down menu and down but get the same thing.

Is there another way of entering DFU or restoring using the "AppleTV2,1_4.2.1_8C154_Custom_Restore.ipsw" created by SeasOnPass?

I am in the UK - could this be why?

Many thanks for your time and look forward to hearing comments,
Dan.

Submitted by Anon on January 13, 2011 - 2:05am

DFU mode looks good, but after that:
Itunes restore script failed!, selecting IPSW in Finder....
Can't select AppleTV2,1_4.2.1_8C154_Custom_Restore.ipsw (File is created good)

Whats going wrong, Please Help ????

Submitted by Anon on January 13, 2011 - 2:52am

Now we see that most users have al kinds of problems with jailbreaking, I wonder why this software has been released in the first place. It's quite obvious that this hasn't been tested properly.
Of course, jailbreaking is at your own risk, but the developers have a responsibility also. Now there is a great chance that users are left behind with a non-functional Apple TV which cannot be restored to de factory settings anymore.

Submitted by Anon on January 13, 2011 - 6:37am

Listen folks.. I work for a living, and don't have time to play around with this stuff at home. After a day of triaging servers and databases, I want to enjoy a glass of Pinot Noir and a good movie. I don't have a problem installing a one-off improvement to my ATV, that's why I dropped 20 bucks to FireCore, and waited for an easy installer, with the capability to restore back to where I started from. I don't want a factory install refreshe mode, using a long path with bugs. I'd like a system backup-restore point, which I can use to restore my working ATV with my login and passwrod intact. I haven't yet tried this (and I do want couch surfer), because of the bad experiences other users are experiencing. I'll wait until this s-ware is past the beta releases, and no one is complaining. In the meantime, can you add a point-in-time recovery. I'd be willing to pay more for it, if it was failsafe enabled, and untethered.

Thanks,
Stu
A system administrator with an ATV at home, and 1.5 hours free time/week.