Happy Holidays! 'Tis the season for holiday celebrations, and to kick things off we've got one final installment of aTV Flash (black) for 2011. Featured in version 1.1.1 are a number of goodies including: expanded support for subtitles, metadata performance improvements, and a stocking full of bug fixes. 

Full details on what's new and how to update can be found below.

What's new in 1.1.1?

  • Added support for embedded 'Timed Text' subtitles
  • Added support for external SSA subtitles
  • Added support for .dvr-ms files
  • Added background audio looping for DVD menus
  • Improved metadata loading performance*
  • Improved .SRT subtitles parsing
  • Improved compatibility with AirPlay
  • Improved filter bar selection in list view mode
  • Improved support for special characters
  • Improved file name parsing
  • Improved playlist behavior
  • Resolved rare DVD playback and menu issues
  • Resolved floating crash when accessing remote files
  • Resolved floating crash when audio queue service is not available
  • Resolved rare crash when opening pre-playback screen
  • Resolved playback issues when attempting to use corrupt subtitles
  • Resolved issues related to hiding menu items
  • Resolved issues with installer version check
  • Removed white line visible on some h.264 videos
  • Files that are 90% viewed are now marked as watched
  • Minor UI improvements
  • Other miscellaneous bug fixes

*Note: A one time re-cache will be required to take advantage of the new performance improvements. This will take place automatically when browsing through your media files.

Superb! Where can I get it?

If you're already running a version of aTV Flash (black) the new 1.1.1 version can be installed through the Maintenance --> Manage Extras menu. Links for the new version can also be found in your account under the Downloads tab.

If you're not yet using aTV Flash (black) you can get started here.

Happy Holidays. Smile

Comments

Submitted by Anon on December 22, 2011 - 11:09pm

use xbmc - has a remove from database and disk functionality

Submitted by Anon on December 22, 2011 - 11:11pm

OMG

Submitted by Anon on December 22, 2011 - 11:20pm

THX great work as usual
happy holidays and a happy new year (untethered of course Wink

Submitted by Anon on December 22, 2011 - 11:43pm

IceFilms is working fine on my end. I did notice it just updated the XBMC plug-in for IceFilms.

Submitted by den15 on December 22, 2011 - 11:44pm

Great work! There's one thing I would like to ask. I've downloaded video files (*.m4v) via iTunes and stored them in the network. When I try to start such files in the Media Player I always recieve the followind error "Playback error. An error occurred loading this content". Does anybody else is having the same issue? Is it a decoding problem?

Submitted by stevec.5269 on December 22, 2011 - 11:51pm

Same set-up as I have. Works great, the software is very intuitive.

 

Thank you FireCore team! Y'all are due a few case o' beer, if you ever make to Wisconsin be sure to hit me up for it.

 

Cool

Submitted by cuzue on December 22, 2011 - 11:56pm

Nice christmas present - thank you. Wink

Submitted by Anon on December 22, 2011 - 11:56pm

When im using Xbmc the stream from the Mediathek its crashed every time i use it.
Ive read in a forum this works only with nightly build.
But how can i install nightly build?Please have anyone a Answer.-

Submitted by Anon on December 23, 2011 - 12:31am

Thanks a bunch for the new update.

Any plans to implement search for subtiles in i.e. opensubtitles.org? I got used to this great feature in XBMC.

Submitted by jan.ove on December 23, 2011 - 12:34am

Thanks for the update

Any plans to implement subtitle search and download, like the one in XBMC from opensubtitles.org

Regards

Jan Ove

Submitted by Anon on December 23, 2011 - 1:55am

I have problems with metadata !

Submitted by Anon on December 23, 2011 - 2:07am

The previous reply pointed the direct. To expand, I bought on eBay (UK) a Smart HDMI adapter which alows 3 x HDMI inputs and 1 x HDMI output. In my case I simply switch OFF say ATV and switch ON any one of the other sources and bingo it's on the TV screen. If required the device can manually switched (small push button) to connect the alternative sources without swithing them off. This is a fully electronic autoswitching device.

Submitted by dan9 on December 23, 2011 - 2:50am

Guys,

I purchased 1.1 *yesterday afternoon*  for my 4.4.4 ATV, and my only complaint was the slow loading of movie covers in media player.

So I went to bed, woke up this morning and found 1.1.1 waiting for me.  A 10 minute install later, and my only complaint was fixed.  You guys rock!

Merry Christmas guys Smile

Submitted by Anon on December 23, 2011 - 3:52am

I had the same issue. The problem is the permissions on the file when they are on the network drive. I had them on my mac and had to grant to permissions to that folder in sharing permissions in settings.

Submitted by benjaminmendoza on December 23, 2011 - 4:24am

Hi,

Excellent job you that has been done with aTV flash!!  

Have you thought having the possibility to add a movie "preview" button when watching the metadata info of a movie from my own library? This video could possibly be also saved locally, only with a "...preview" at the end of the name so it can be related to the right movie, or maybe with a link to somewere (imdb for example) where you can get the movies previews?

that would be even nicer to this already awesome job!

Regards,

Submitted by lassel.2549 on December 23, 2011 - 6:37am

when will it support HD wmv files??  2 updates now since the atflash black was released. And still not supporting wmv files.

Submitted by den15 on December 23, 2011 - 8:14am

I only have this problem with the type I mentioned. Other file types don't cause any problems. I have stored all of my videos in the same network share on a NAS sever. The user I use to connect the ATV to the NAS has full rights on all shared folders. I don't think it's because of missing rights. Any other hints?

Submitted by wolfgangp.4894 on December 23, 2011 - 8:39am

I had the same problem. Then I have tested a few settings. After changing the audio settings in ATV to 16 Bit instead of AUTO it works without problems.

Submitted by Anon on December 23, 2011 - 8:40am

It is not possible to watch movies bought from iTunes on atv, if the m4v files are placed on a NAS. its loading a few minutes and after this, the grid/list view returns. So, it is not possible Frown and yes, the account details are correct.

Submitted by mjvolante on December 23, 2011 - 9:23am

These are my observations having used this for sometime now.

Firstly, good progress to date which has accelerated of late.

2) Versions 1.1 and 1.1.1: I can no longer set up my Buffalo NAS via AFP. Gets stuck on 'Loading'. SMB is OK.

3) On pressing OK during playback, and selecting a different Chapter or Audio Track can cause freezing and unit has be to restarted. 

4) Photos - Still take an unearthly long time to load. Would it be possible to extract just enough data to create a thumbnail. The delay puts me off even using this.

5) Judder - I do experience judder on most films. This seems a little better in 1.1.1 but is still there. It can vary, but occurs every 5-10 seconds and can only be best described as if there was an issue with frame rate. I do not get this when watching, for example, using VLC.

6) I cannot enable Dolby or DTS as I will get white noise only. Is this a problem with just certain A/V Receivers? and if so, does anyone know why.

Keep up the good work!:D

Submitted by alexsirota on December 23, 2011 - 10:15am

We had persistent wifi drops as well. The reason for these drops is not ATV or ATV flash black, but rather that your wifi router configuration. It may be competing for channels with other wifi routers running in your neighborhood. Turn off automatic channel selection and switch to a channel that is not used (we selected 8). We have over 30 wifi SSIDs in our vicinity and saw that many routers run on channel 2 or 11 by default. The inSSIDer tool can show you which channels are busy and which are not.

 

This helped us tremendously, but we still have drops every once in a while. Resetting the router always fixes the problem so I know that the problem is now with ATV but rather how wifi is working and interference. Another approach is to switch to the 5Ghz range on 802.11n capable routers. As long as all your devices support the 5Ghz channel you should be fine.

Submitted by rvgulik on December 23, 2011 - 11:58am

I am missing NBA, anyone?

I am on 4.3

Submitted by den15 on December 23, 2011 - 3:08pm

I tried a few different settings as well but nothing changed. No idea what I else can do to get it working. Nevertheless thanks for your help

Submitted by Jinnie55 on December 23, 2011 - 4:13pm

Steve C., the XBMC updated yesterday morning when I turned my APTV on, and then I noticed that there was an update for the Maintenance & the Media Player, so updated them which brought me to Version 1.11, and then I lost access to my IceFilms, I tried removing it, and reinstalled it, with NO luck.

 

Which version are you using? are you also using ATVFlash Black ? Please help me if you can, I would appreciate it.

Submitted by Anon on December 23, 2011 - 7:10pm

Follow on Twitter for more Apple TV updates. I got you covered in all areas. @gainesway

Submitted by Anon on December 24, 2011 - 1:36am

Hi,

Thanks for the 1.1.1 update, except all my metadata and covers on my music is gone (!). But my movies are visible with metadata and cover.
I'm a big fan of atv flash black but this update for me is disappointed. Is it possible to downgrade to 1.1, because on that version metadata and cover on my music works.

Please help !

Thanx.

Submitted by Anon on December 24, 2011 - 3:21am

5) When setting up the ATV on my wireless N network there is no judder, if I connect it via my gigabit wired network there is judder.
6) DTS and Dolby only work over the optical out since this is the only way to support 5.1 audio.

Hope it helps!

Submitted by yogy11 on December 24, 2011 - 3:24am

Wmv files are so windows...
Atv is so not.

I don't think it will ever be fully supported.

Submitted by oxosoft on December 24, 2011 - 4:54am

Hi guy's,

i know i'm probably the 10000000'st one asking this question but is there an approximate time schedule of when the untethered jailbreak for ios5 will become beta at least ? i love your work, progress has been great since the pre-release and my 4.3 just doeas great, yet i'd like to take advantage of the icloud stuff with itunes musik match...

Submitted by JeremyR on December 24, 2011 - 8:39am

Yes I noticed this a few days ago too, before the update. I'm on 4.4.

Any ideas?

Submitted by JeremyR on December 24, 2011 - 8:46am

*

Submitted by viruz on December 24, 2011 - 11:43am

I have a 1 terabyte disk with avi and mkv (720p) attached to my airport extreme. Can I connect the apple tv 2 to my local network and access the movies with plex or xbmc?

Submitted by Jinnie55 on December 24, 2011 - 4:46pm

Ukrainianoiler no I still can't since yesterday, I cannot even open any of the choice in IceFilms, like New Releases, Recently, Popular, and all the others. It starts downnloding, and stops at 3, or 115, or 130 when it should go up to 149 or 150. i wish someone at FireCore would check it out & give us a reply.

 

UPDATE DEC.24TH.

I just decided to uninstall XBMC, from Maintenance, and it also uninstalled it from Nito Tv as well, rebooted, and then reinstalled it in Maintenance, and guess what? IceFilms WORKS NOW!! who would have thought... So I guess if you want to update to 1.11, you can go ahead. I wish I would have heard from Firecore  for this problem...Oh well, thank God it's back up like it was 3 days ago. Let's hope that the next update will not mess it up again:)

 

Merry XMass to everyone!

 

 

Submitted by medivel on December 24, 2011 - 5:54pm

Yes you can Smile

Submitted by jerikschaeffer on December 24, 2011 - 8:16pm

Looks like I spoke too soon, as dvr-ms support looks to pretty buggy at the moment. A support ticket has already been logged.

Submitted by DavidG on December 25, 2011 - 12:35pm

I´ve the same problem. Help please!!!

Submitted by Anon on December 25, 2011 - 2:19pm

No there is no ETA on that because Firecore is just taking credit for other peoples work so when untethered jailbreaks are out for IOS5 on iPhone 3GS, 4 and so on, you will see that they suddenly have it to

Submitted by thegorg on December 26, 2011 - 3:04am

HI all

Does anyone know how to get metadata for TV shows working, i am getting Metadata for movies, i am getting it with music, but i keep getting "No Discription" with TV shows. Now i used to get it for shows, but for about 3 weeks now or maybe 4 weeks, no can do?

 

Thanks, all else really groovy.

Submitted by james on December 26, 2011 - 7:12am

For TV Show metadata you'll need to first tag your TV Shows folder as TV Shows. Details for doing this can be found here.

http://support.firecore.com/entries/20557283-metadata-and-cover-art

Submitted by james on December 26, 2011 - 7:12am

You can stream through Media Player or XBMC. Plex will require you to stream a computer running Plex server.

Submitted by james on December 26, 2011 - 7:15am

As of right now, Pod2G is the one working in the iOS 5 untether, and he's made some exceptional progress thus far.

https://twitter.com/#!/firecore/status/146993227638124544

Once this is completed it will be included with a new Seas0nPass update.

Submitted by thegorg on December 26, 2011 - 5:13pm

James thank you, obviously it worked and i now know when adding other folders to the mix what to do.

 

Thank you again

 

Thegorg :D

Submitted by tomasm.1409 on December 26, 2011 - 8:39pm

I have the same trouble since the beta's versions: I from Argentina, so my language is Spanish (both settings -ATV & Subtitles are configured) and still I can not see correctly them under your media player. For example, every á, é, í, ó, ú shows like À, È, Ö, •, or other. Same as the signs: ¡ or ¿ don't shows. Please, could you fixed these issues on next update? This problems are not present on XBMC, but I preffer to use you Media Player for the features (like metadata) and the look and feel.

Thanks a lot for the new features. Keep going!

Submitted by tpe on December 27, 2011 - 4:20am

Hello, just asking again (guess my post got lost somewhere)..

are you planning any any kind of database and search engine for music files? In huge directories its a bit annoying to scroll down all the way if you for example want to listen to zappa :-).
An other question, all my music covers were "hard" written in the mp3 files in png format. In iCloud all covers - including those I searched manually are displaying correct, i have also got a png picture of the Album in every Album folder.
In atv2 mediaplayer some folder show up correctly with the album cover, some without a cover (just as a music folder) and some show up as a picture folder (when I open those. the mp3 files inside show the right cover) Why is it this way?
Regards
 
tpe

Submitted by Anon on December 27, 2011 - 4:41am

pod2g blogged about A4 unteathered JB beeing released now.
http://pod2g-ios.blogspot.com/2011/12/a4-release.html

Is this what Seas0nPass needs? Can we expect unteathered JB for 4.4.4 very soon?

Submitted by Anon on December 27, 2011 - 5:16am

Hi. Since Beta is over I can't update the software on my ATV2. All programms mean installed, earlier at new update there was writen update. Whats wrong with my box?
Thanks a lot!

Submitted by Anon on December 27, 2011 - 8:29am

A4 Jb is released.
please do what ever it needs and release a new version of Seas0nPass as well.

Submitted by Anon on December 27, 2011 - 8:51am

Since you are using a beta version you have to reset your ATV and re-install like the first time, upgrades after that shall be available from the Maintenance menu. Enjoy!

Submitted by juan manuela.5119 on December 27, 2011 - 11:44am

Hi, 

I tried to use the airplay mirroring and I couldn't make it work. Is This solved in this new version?

Submitted by apptvclient on December 27, 2011 - 7:27pm

Hi I successfully did the jailbreak for 4.4.4 and also installed Atv flash (black) 1.1.1. I am unable to install xbmc through nitotv?. it says

"The following packages have unmet dependencies

 org.xbmc.xbmc-atv2: Depends: org.xbmc.xbmc-seatbeltunlock but not going to be installed

E: Brocken packages"

 

Could you please help me to resolve this? is there any other player which I can use to watch movies?

Thanks