Today we're happy to release a brand new version of aTV Flash (black) which includes a revamped player that is optimized for iOS 5.0 and later. This new player improves performance for virtually all file type resulting in noticeably smoother playback. We've also baked in a number of other goodies including NFS streaming, subtitle timing settings, additional translations and a mountain of other improvements and fixes.

What about the ATV3 and the untethered version for ATV2?

Work is still underway on both fronts, and we've had some encouraging reports come in over the past few days. However, it's still too early to give any kind of ETA but we hope to have more news soon. For the latest updates be sure to follow us on Twitter.


Easy access to subtitle options through the Playback Menu

Full Changelog

  • Revamped player with improved performance (Apple TV 4.4 and later)
  • Added NFS streaming
  • Added Catalan, Czech, Korean and Traditional Chinese translations
  • Added support for localized TV show pattern: TV Show/Season #/S##E##.extension
  • Added manual subtitle time correction (-10.0s to +10.0s)
  • Added support for embedded .FLAC cover art
  • Added support for .AC3, .DTS and .MOD files
  • Improved .EYETV file handling
  • Improved audio synchronization in slow and unstable networks
  • Improved slideshow operation with small images
  • Improved movie folders detection logic to ignore hidden files
  • Improved metadata fetching to support movies split into multiple files (dvd#, cd#, disk#)
  • Improved zoom mode operation for non-square pixels
  • Improved DVD menu handling
  • Improved .OGG file handling (now correctly treated as audio)
  • Improved error handling for connection issues
  • Improved buffering logic
  • Improved installation routine
  • Other minor UI improvements
  • Resolved format detection that was causing rare playback issues
  • Resolved issue with volume level resetting during rw/fw
  • Resolved floating crashes usually observed when using SMB with Windows 7 shares
  • Resolved conflicts with XBMC related to SMB
  • Resolved issues with metadata fetching for 'Show.Name.###.extension' pattern
  • Resolved crashes observed in folders with significant number of files
  • Resolved playback error on DVD and ISO files observed when file path contains '?' character
  • Resolved crashes when working with long file paths
  • Resolved rare issue with incorrect pre-playback screen layout
  • Other miscellaneous bug fixes

Fantastic! Where can I get it?

If you're already running a version of aTV Flash (black) the new 1.5 version can be installed through the Maintenance --> Manage Extras menu. Links for the new version can also be found in your account under the Downloads tab.

If haven't yet tried aTV Flash (black) you can learn about all the great benefits here.

Enjoy. :-)

Comments

Submitted by sebastienl.4755 on April 29, 2012 - 10:04am

i have the same problem.  actually my problem is that all my folders with only a single tv show dont get put in alphabetical order. they all appear at the end of all my shows, regsardless of their first letter... weird...

Submitted by coussey on May 1, 2012 - 6:09am

I have jail broken with season pass.

Now trying to add aTV Flash (black) getting following error?

Version 1.5 has encountered a problem and needs to close.  We are sorry for the inconvenience.

Help?

 

Submitted by ennioromito on May 2, 2012 - 11:44pm

Jailbreak 4.4.4

atv flash 1.5

it's impossible to install into tv from maintenance error log :

"E: dkpg was interrupted you must install manually run dpkg--configure -a' to correct the problem"

How I can solve ? If Install Nito tv from terminal , my ATV2 reboot every 5 seconds

Submitted by skinamo on May 3, 2012 - 7:17am

I am told that the version of aTV Flash that I am getting is not the black version even though that is what I paid 39.95 for. The version that I have keeps asking for a thumb drive, which I am told is for the silver version. I have aTV 2. How do I download the correct version? Thanks.

I found out that I paid for the wrong program, that is why there is only the aTV Flash link on my download page.

Thanks again.

Submitted by Anon on May 4, 2012 - 12:32am

I've updated to aTV Flash 1.5 on my ATV2 Black - it shows in the about section as 1.5 and the installer completed successfully, however all the menus and features are still the same as if still on 1.2, even after reboots? Any suggestions?

Submitted by gregory.dirick on May 5, 2012 - 1:27pm

Good evening,

I did the upgrade "Tethered" via seasonpass but impossible to upgrade to Atv 1.5.  It says "there is no ATv2 available" ! My Atv2 can see my computer via the sharing but in iTunes (MAC OS X 10.7.3 / iTunes 10.6.1) the ATv2 doesn't show up under device !

Any idea on what to do?  I already reinstalled iTunes, restored ATv on iOS5 via iTunes but no way, it doesn't appear under devices.

Thx for your help.

G.

Submitted by abaan on May 6, 2012 - 8:00am

I also have this problem,I installed on the jailbreak4.4.4., also the buffering on the VIDEO_TS/VOB is still not solved,

I am streaming from iMac via Airport Extreme via Airport Express to AppleTV2!

When I convert the VIDEO_TS/VOB with Handbrake to Apple iTunes,than the streaming is not interrupted by buffering.

But it takes 2 hours to convert, therefore I buy ATVFlash to avoid this ,but buffering is irritates me immensely!

Submitted by millefredl on May 6, 2012 - 9:38am

Hi !

For me it was the same problem, I have paid for the wrong version ! I told this to the guys from firecore and I  got the money back without any problems ! Then I pay for the right version and all was o.K.  This is an excellent customer service !:D

Submitted by ganbyt on May 6, 2012 - 3:11pm

I got the same problem

Submitted by gregory.dirick on May 7, 2012 - 11:20pm

So we'll have to Wait&See if they can fix it.  Even by restoring it => no way, doesn't show up !  I Hope I did not "crash" my ATv 2.

Submitted by JesperS on May 8, 2012 - 2:59pm

You probably didn't boot tethered probably

Submitted by gregory.dirick on May 8, 2012 - 10:50pm

At the beginning, I did it wrong... yep :-/

 

Do you think there is a way to come back to 4.4?

 

 

Submitted by tino2424 on May 9, 2012 - 1:38pm

Im having the same problem. I've tried to install on more than one computer and it doesn't show up in the drop down box. I've tried over wireless and connected, still nothing. I've now paid $40 for a program I can't install. I'm not very happy. I've gone through most of the router settings as well as firewall and anti virus and still nothing. I'd really appreciate some help or a way I can ssh the program onto the atv usings a windows 7 pc. Cheers

Submitted by Anon on May 9, 2012 - 3:21pm

btstack doesn´t work on ver 1.5? well make it work then...my atv autoupgraded (?) and now i can´t use bt keyboard...

Submitted by lionelisaac on May 11, 2012 - 3:53am

dose any body know how you install navi x and ice films

Submitted by philip.3793 on May 11, 2012 - 10:10am

Hi download cyber duck on your pc then you will what your ip address from the apple tv
Then run cyber duck program the use name is root and the password is alpine and it has to be set sash hope this helps

Submitted by guilhermec.053810 on May 11, 2012 - 12:59pm

Let me ask a direct question.The PLEX works or not with aTV Flash (Black).Plex directly because I wanted to use the apple tv2If it works how to proceed.Or a tutorialthank you

Submitted by Anon on May 11, 2012 - 11:32pm

Hello, we updated out atv 2 with the latested update 5.0.1, now I can't seem to put this jailbreak 5.0 on. Am I going to have to wait for another update from you. Thanks

Submitted by Anon on May 14, 2012 - 1:51am

I am having the same issue.
After may attempts, I am still being presented with the iTunes and USB connector, each time I connect the ATV after a jailbreak using the latest Seas0nPass.

Submitted by markb.5817 on May 14, 2012 - 6:59pm

I have a issue with Seasonpass, have downloaded latest version but when i try to open its saying i need .net framework 4. have downloaded .nf4 but what do i open it with cos i keep getting a box to ....open with....what do i open with... its doing my friggin head in now...

 

Thanks.

Submitted by Anon on May 16, 2012 - 3:26pm

works a treat apart from certain mkv/ mp4 files,if they dont work just convert with handbrake,occasionally you have to clear the cache file by ssh as it bogs the hard drive down with temp files but quite easy to do once you know how to get to the folder.

Submitted by Anon on May 16, 2012 - 3:27pm

ssh my friend/google and youtube are our saviours

Submitted by Potshot Loki on May 16, 2012 - 6:37pm

I have never had an issue installing net framework X on any device capable of using it. If it is in a zip file, make sure you use whatever extraction tool to extract the progam and then try and install it. Make sure you got it from a trusted source http://msdn.microsoft.com/en-us/netframework/aa569263 should be a valid place to download it. Plus the button there states "install", I don't think you actually need to download it. I would just select that and let microsoft do the work. Make sure you have any virus protection off (make sure what you are installing isn't a virus) and firewalls. 

Make sure your not a Mac.

 

Good luck

Submitted by Anon on May 16, 2012 - 10:18pm

Thanks will have a go the weekend, let you know how i get on...

Cheers
Mark

Submitted by Anon on May 17, 2012 - 12:35pm

Now up and running, brilliant, i had to delete widows downloader programme, then installed net framework 4.

many thanks for the help.
Mark.

Submitted by Anon on May 19, 2012 - 4:20am

its not working! :( i have fircore icon but its on setting i cant see the browse or xbmc :( what can i do!? pless send me email for fix this problem!

Submitted by santoscork on May 23, 2012 - 1:38am

I hope the untethering solution appears sooner than later. I've gone through 3 tethered processes, all of them fail with an iTunes logo after only 1 or 2 days of use. Patiently waiting since joining — 10 weeks now. Thanks

Submitted by 180 on May 25, 2012 - 9:13am

Hi,

trying to install version 1.5.1, but without any success. Installer stucks on "transmitting data".

what can i do? anyone experiencing the same after using untethered seas0npass?

the jb seems to be worked out. i can see fc logo.

Submitted by 180 on May 25, 2012 - 9:26am

interesting! it seems that transmitting data process takes more time as usual. i left it spinning in the background and finally got a confirmation stating that the process has finished. it indeed works!! :D

thanks firecore.

Submitted by lunyfc on May 25, 2012 - 10:40am

allo,

 

could you tell me where I can download apple tv flash back

thanks

Submitted by Anon on May 25, 2012 - 11:17am

My atv flash black 1.5 doesnt work
i got the information that im not connected to the internet or my version is to old but it is 1.5
who can help me??

Submitted by ramandhami on May 25, 2012 - 8:23pm

Does anyone know why aTV Flash Black 1.5 is not working on my apple tv2 with SeasonPass 5.0.1 ?

Submitted by Anon on May 25, 2012 - 8:45pm

I have the same problem. Please provide a solution if u have one.

Thank You Kindly

Submitted by ionutz.8967 on May 26, 2012 - 12:24am

Hello you must stop the Bonjour Service in Task Manager and enter the ip manualy in ATV2 Flash.

Submitted by georgoud on May 26, 2012 - 6:47am

can someone please tell me how we do this as it seems i am having the same problem....

Submitted by imageit on May 26, 2012 - 7:58am

 

aTV Flash (black) 1.5 did not work for me, did the seas0npass but stuck on aTV Flash (Black) Transfering files.... with spinning indicator but nothing happens, ATV shows firecore logo but can't apply aTV Flash (black) 1.5, tried it from scratch 4 times not, something is wrong?

 

Update....  Got it to work by unplugging the USB cable and plugging the cable back in while the indicator was spinning with the Transferring Files... message. This did the trick and everything is working now.

 

Submitted by s3rdarss on May 26, 2012 - 8:00am

Atv flash black 1.5.1 installed but i cannot install xbmc nor other applications... please help?!?!?!?!

Submitted by senator on May 26, 2012 - 6:08pm

the first try was with mac, no chance to install the 1.5 upgrade. than i tried the same procedure with my win7 laptop and all goes well!!! Btw.,

Seas0nPass 5.0.1 works perfect!! Thank you guys for your support!!!

Submitted by Anon on May 27, 2012 - 2:33am

Hi, I cannot update to ios5 (have ATV2), do I need to reset ATV before upgrade to ios5 is possible?

Thanks /Daniel

Submitted by bruday61 on May 27, 2012 - 5:00pm

I purchased ATV Flash Black a while ago having problems get download links. They do not show under my account download section. Does anybody know what i'm doing wrong?

Submitted by Anon on May 27, 2012 - 8:09pm

installed Eden ns tv 1.5.1, seem to be missing alot of he addos like navi as anyone else encountered this problem?

Submitted by Anon on May 31, 2012 - 5:06am

On iOS 5.0.1.
Seasonpass (untethered) and aTV Flask (black) 1.5 installed without a problem.
Afterwards installed Couch Surfer Pro which installed without a problem and is working okay.
Not able to install Media Player nor XBMC. Anyone with the same problem and solution?

Submitted by Anon on June 13, 2012 - 4:20pm

How the hell i find the subtitles? I've installed the last version of aTV but I do not find how to activate the subtitles for a film.

Thanks!

Submitted by Anon on August 14, 2012 - 5:30pm

Very useful, thanks MrAnderson
How did you get on using iPlayer overseas?
I'm thinking of getting an atv, but using iPlayer from the US is a must-have

Submitted by Anon on August 17, 2012 - 2:55am

Atv flash is not anywhere near XBMC and Niti TV. Waste of money. Last tv flash update broke my atv2 and I had to retore it from iTunes.
This is a lot of rubbish, considering that XBMC is free

Submitted by Anon on October 5, 2012 - 1:27pm

I'm thinking about streaming hulu+ on my ATV2 outside of US. Has anyone tried Unotelly for Hulu +? What about the XBMC addon from Bluecop? Still works?

Submitted by Anon on November 30, 2012 - 12:56am

James bought the download this week for app tv gen one. Xbmc will not load dharma or Eden
I keep getting script error 126 when trying to download
Please help!!!!!!!!!!

Submitted by Anon on November 30, 2012 - 1:52pm

Get error message 126 when trying to install xbmc!!!!!!!!!!!
No response makes me wonder if this is a scam!!!!!!!!!!!!!!!
It's been days I need help now!!!!!!!!!!!!!
Please respond