Today we are happy to release a brand new version of Seas0nPass that provides an untethered jailbreak of the latest 5.0.1 (iOS 5.1.1) software for the 2nd gen Apple TV. Massive thanks goes to @pod2g and Co. for the countless hours that went into making this new release possible.

Update 6/6: Seas0nPass has been updated to support the new 5.0.2 Apple TV software.

What about the new 3rd gen Apple TV?

Unfortunately Seas0nPass is not yet compatible with the new ATV3. Work is still ongoing and we'll be sure to announce any and all news as soon as it becomes available. Be sure to follow us on Twitter, Facebook and Google+ for up to the minute info.

Which plugins are currently supported on 5.0.1?

  • Couch Surfer (works)
  • Last.fm (works)
  • Maintenance (works)
  • Media Player (works)
  • NitoTV (works)
  • Plex (works)
  • Remote HD (works)
  • Rowmote (works)
  • RSS Feeds (works)
  • Weather (works)
  • XBMC (works)
  • Overflow (not working)

Superb! Where can I get it?

As always, Seas0nPass is available as a free download from Seas0nPass.com.

Troubleshooting tips can be found here.

Enjoy. Smile

Comments

Submitted by twhiting9275 on May 25, 2012 - 9:39am

We all know that everyone wants ATV3 to be jailbroken. It's just not that easy.

 

Submitted by Anon on May 25, 2012 - 9:40am

Anyone know hot to add xmbc to this once it's jailbroken please?

Submitted by sebastianw.2757 on May 25, 2012 - 9:41am

Well, the update works fine but now i cant reinstall the mediaplayer.

 

The appletv stucks in to "installiere Mediaplayer" and nothing happens, the same thing happens (nothing happens) when i am trying to reinstall my backups on the maintenance mode! 

Submitted by travism.9217 on May 25, 2012 - 9:45am

hi guys!

Cheers for the update, however it won't let me install media player!!!! It keeps stating that installation failed… anyone else having this problem?

Submitted by Anon on May 25, 2012 - 9:48am

I dont' know what I'm doing wrong but evertime I try to restore on iTunes I'm having error (9).

Submitted by DeadGuy on May 25, 2012 - 9:50am

Same problem :(... What the hell???

Submitted by Anon on May 25, 2012 - 9:50am

Before this update my apple tv 2 would boot up all scrambled lines, I had to let it go into standby mode then it would show the screensaver normally and I could access the apple tv menu. Hope this fixes the problems.

Submitted by rikkileigh on May 25, 2012 - 10:08am

You probably need to do a tethered boot. Use the other icon onyour Season Pass and follow the directions, it's easy.

Submitted by travism.9217 on May 25, 2012 - 10:09am

I have tried

couch server - works

RSS Feeds - works

Weather - works

lastfm - not working

media player - not working

nito tv - working

xbmc - not working

 

"the following packages have unmet dependencies"

bla bla bla

E: Broken Packages

Submitted by Anon on May 25, 2012 - 10:15am

How can you back up next BMC files?

Submitted by andrikkos on May 25, 2012 - 10:17am

Same here unfortunately. Some error about dependencies on afp.

Does anyone know how to install from the command line, to see what's actually going on behind the spinning wheel?

 

Submitted by Anon on May 25, 2012 - 10:17am

Why overflows not working on ios 5.0.1.....????

Submitted by alan.dubois on May 25, 2012 - 10:20am

Hey, positive report here. New seas0npass untethered jailbreak worked without a hitch. process seemed even faster than last time. aTV flash ioaded with no drama as well. So far have installed media player and couch surfer pro. Installations went smoothly and both are working great. It seemed to take a little longer than expected time to download and install media player. At one point, thought it might be stalled but waited a couple more minutes and the install completed itself. Its only natural for most posts to be about problems and possible solutions but for folks on the fence about installing, thought it might be helpful to report a success story. If my experience is any indication, go for it.

Submitted by ahsan99 on May 25, 2012 - 10:25am

thanks guys for the amazing work!

eagerly waiting for the upcoming JB on ATV 3,,

Submitted by Anon on May 25, 2012 - 10:26am

Is there any advantage by upgrading to iOS5.0 if my ATV2 is working fine? Is it just the new icon view?

Upgrading (at least for me) represent some major effort and risk since not always things go as they should, so, why fix it if its not broken?

Submitted by curt on May 25, 2012 - 10:30am

I've tried this update with no success - I keep getting error 1601.  I've tried restoring the appleTV to factory settings through itunes, which worked, but still won't take the seas0npass update. I've read the FAQ about error 1601 and did as suggested, with no avail.

When iTunes starts up, it shows two apple tv devices, which I find very odd and could be the problem.  Each time I try to do the update, it adds another appletv device to itunes so now I have 5 of them (they go away after a restart, but still at least shows two).

Ideas?

Submitted by Anon on May 25, 2012 - 10:32am

how have you been using it for quite some time if the JB just came out today?

Submitted by cal8lj on May 25, 2012 - 10:32am

After downloading and running Seas0nPass, ito downloarded the ipsw, unzipped, and decrypting RAM disk, but got stuck on decrypting file system.  It only gets to about a mouse-width and stays there.  I left it for a good 30 minutes.  I've restarted the process and no progress.

 

Incidentally, I believe I ran into this same exact problem when the tethered 5.0 first came out, but after rer-reading the post and seeing Plex wasn't yet working, I just gave up.

 

I've tried "run as" administrator and a few compatability modes.

 

Anyone have something else I can try?

I'm running Windows 7 Professional 64bit SP1, with 8GB of RAM.

I tried a few google searches and didn't come up with anything.

Submitted by travism.9217 on May 25, 2012 - 10:34am

hmmm, mine won't let me install media player….

Submitted by Anon on May 25, 2012 - 10:41am

Jailbreak went through successfully without a problem however, I've tried installing XBMC and it doesn't work. Anyone else having this issue?

Submitted by Anon on May 25, 2012 - 10:43am

I'm having the same issue as well. Anyone else having trouble installing XBMC??

Submitted by Anon on May 25, 2012 - 10:44am

I'm having issues installing XBMC after the untethered jailbreak. It was working fine on the tethered jailbreak so I'm not sure what's going on. Is anyone having trouble with this??

Submitted by robertp.0459 on May 25, 2012 - 10:48am

so, how can we install media player or XBMC? how can we pass dependency tree error?

can you fix com.firecore.libafpclient?

Submitted by Anon on May 25, 2012 - 10:50am

Nice, thank you firecore.
i've been eagerly expecting this release. i've previously using the tethered jailbreak with xbmc. (http://gliblog.blogspot.com/2012/05/apple-tv-jailbreak-ios-51.html)

Submitted by santoscork on May 25, 2012 - 10:57am

Nothing short of Brilliant! All those responsible — my deepest respects and admiration for your incredibly hardwork! Wonderful outstanding work!

 

I look forward to trying this at home…first thing I do this Friday evening after work. I hope all goes well Smile

Submitted by Anon on May 25, 2012 - 10:57am

Tethered jailbreak was out ages ago, untethered was released today.

Submitted by chrisj.9004 on May 25, 2012 - 11:02am

Hi,

 

I am getting the same issue, 1601 error. Although not the multiple devices..

 

Let me know if you have any luck.

Submitted by sebastienl.4755 on May 25, 2012 - 11:16am

jailbreak was fine.  not trying to install ATVflash latest version and it is stuck at "unable to find apple tv device. make sure atv is connected to the network and airplay is enabled." i have 2 atv and it doesnt see any of them.... ideas??

Submitted by Anon on May 25, 2012 - 11:25am

Is it just me or does anyone else currently on the Teathered JB for 5.1.1 see updating to Unteathered as a bit of a waste of time?

I could understand the need to upgrade if you unplug your ATV everytime you finish using it but I'm sure many of us always have ours plugged in, I haven't had to do a Tethered boot since the day FC released the Teathered JB for 5.1.1 and it's a bit of work backing up and restoring XBMC then there is always the risk of problems doing the Teathered JB and iTunes throwing errors which I can see is happening to some, and also Media Player issues also on the Teathered JB.

Just thought I would throw it out there and see what people think? I myself will just stay Teathered till the next Firmware update, cheers.

Submitted by matthewp.3469 on May 25, 2012 - 11:28am

Apt-get update at the command line seems to be hanging on one of the Repos, I guessing one of them is having issues, not sure if it's traffic following the JB release or an technical glitch

Submitted by Steve Mobs on May 25, 2012 - 11:32am

Try putting it into DFU mode using iReb from http://ih8sn0w.com/ for error 1601, not sure about the multiple devices though. Then Shift + Restore in iTunes with .ipsw that Seas0npass created.

Submitted by Steve Mobs on May 25, 2012 - 11:35am

Try restarting from Settings > General. It got rid of my installation failed errors, but now it just hangs on installing.

Submitted by matthewp.3469 on May 25, 2012 - 11:40am

try

apt-get install nano

 

nano /etc/apt/sources.list.d/cydia.list

 

Change

 

deb http://cydia.zodttd.com/repo/cydia/ stable main

 

to

# deb http://cydia.zodttd.com/repo/cydia/ stable main

 

Save and quit (ctrl + X)

 

apt-get update

apt-get install com.firecore.media

reboot

 

It seems the cydia.zodttd.com is hanging during download/update, It doesnt appear to be needed for media player to install but I didn't want to remove it completely since it might be needed for other stuff, adding the # disables it, simply re-edit the file and remove the # to re-enable it.

 

Submitted by adampopovich on May 25, 2012 - 11:44am

I installed Seas0npass per the instructions, and although Seas0npass said the update was successful, when I booted the my ATV2, the "Manage Extras" menu was gone.  I had the "Settings" menu with the FireCore logo on it, but nowhere to install Plex, CouchSurfer, etc.  I also noticed that my screen saver settings didn't work.  No matter what I set the screen saver to (in my case Ken Burns), it would just show the default scrolling slide show.  I tried several of the methods on the FAQ/Troubleshooting page, but to no avail.  The end result was a constant Apple logo on my screen and a flashing light on the ATV2 for about 20 minutes.  For now I'll just restore it to factory settings with iTunes and use it without the JB. Hopefully a fix for this is released, as I would like to continue using PLEX with it, but for now I'll just go without Seas0npass or aTV flash (black).

Submitted by mennob.5620 on May 25, 2012 - 11:49am

Jailbreak went fine, but impossible to install the programs like XMBC / Mediaplayer etc: Stucks in: ""installing Media Player".

Anybody opposing the same problem?

thanks

 

Menno (Holland)

Submitted by Anon on May 25, 2012 - 11:50am

I jailbreak my apple TV2 2 times. i used season pass and then apple TV flash black 1.5. every thing goes smoothly and my apple TV works fine. when ever i remove the power cable from my apple TV2, Its giving me error connect to iTunes. if anyone have a fix for this please let me know.

Submitted by mennob.5620 on May 25, 2012 - 11:51am

Jailbreak is perfect, but stucks on: installing Media Player. Same problem with XBMC and other programs.

 

Anybody?

Submitted by mennob.5620 on May 25, 2012 - 11:51am

Jailbreak is perfect, but stucks on: installing Media Player. Same problem with XBMC and other programs.

 

Anybody?

Submitted by Anon on May 25, 2012 - 11:52am

I always update to untethered jailbreaks because I live in a small apartment and it is easy to trip circuit breakers. That said, my ATV loses power pretty often and I have to reboot, which is a serious pain with a tethered jailbreak.

Also, i'm sure some people encounter bugs/issues with unstable plug-ins that necessitate frequent rebooting. That is probably the best reason untethered jailbreaks are a worthy upgrade.

Submitted by Anon on May 25, 2012 - 11:53am

atv flash does not work for me---saying needs update?
cannot do xbmc can anyone help....dave

Submitted by Anon on May 25, 2012 - 11:56am

Same problem...

Submitted by tailf2000 on May 25, 2012 - 11:57am

Same issue

Submitted by twhiting9275 on May 25, 2012 - 12:01pm

Be patient

For some reason, on some devices, everything from ATV Flash is a bit slow to install. Whether it's  Couch surf Pro, XBMC, Rowmote, etc... These WILL get there, just let them do their jobs. I know, it seems like it takes forever (or gets stuck), but it will get done.

Not sure what causes the delay, other than maybe some of the older devices have some issues with 5.x software? Just be patient though. It will get done.

If it doesn't after say 10, 15 minutes... Re break the device, and this should fix it

Submitted by fransb.9792 on May 25, 2012 - 12:01pm

thedered peddered weather fether jidder.... I thought Apple TV was Apple and not shitty Windows.

Submitted by twhiting9275 on May 25, 2012 - 12:02pm

See my response to the post above yours.

This is something I've seen with a few devices myself. it may seem like it's stuck, but it's working. Sometimes it just takes longer.

Submitted by twhiting9275 on May 25, 2012 - 12:03pm

You can't just run Seas0npass, you must also run ATV flash (black) to get all that back.

Submitted by twhiting9275 on May 25, 2012 - 12:04pm

It depends, honestly.

I've seen plenty of issues with tethered breaks, so yes, it makes perfect sense.

Sometimes these devices just don't want to play nicely on a tethered break.

Submitted by twhiting9275 on May 25, 2012 - 12:04pm

Try re-breaking the device?

Submitted by twhiting9275 on May 25, 2012 - 12:06pm

talk to the software developers. Firecore does not develop individual software such as the one you're mentioning.

Submitted by olafm.0726 on May 25, 2012 - 12:06pm

Hi,

big problem with the restore of the custom IPSW-File in iTunes...message is something like "preparing apple tv for restore" (i use the german version) - and nothing happens...after a few minutes iTunes error message: "unknown error: 1608" - i tried a few times...:-( any hints ? original apple firmware restore works fine...:(