Today we are happy to release a brand new version of Seas0nPass that provides an untethered jailbreak of the latest 5.0.1 (iOS 5.1.1) software for the 2nd gen Apple TV. Massive thanks goes to @pod2g and Co. for the countless hours that went into making this new release possible.

Update 6/6: Seas0nPass has been updated to support the new 5.0.2 Apple TV software.

What about the new 3rd gen Apple TV?

Unfortunately Seas0nPass is not yet compatible with the new ATV3. Work is still ongoing and we'll be sure to announce any and all news as soon as it becomes available. Be sure to follow us on Twitter, Facebook and Google+ for up to the minute info.

Which plugins are currently supported on 5.0.1?

  • Couch Surfer (works)
  • Last.fm (works)
  • Maintenance (works)
  • Media Player (works)
  • NitoTV (works)
  • Plex (works)
  • Remote HD (works)
  • Rowmote (works)
  • RSS Feeds (works)
  • Weather (works)
  • XBMC (works)
  • Overflow (not working)

Superb! Where can I get it?

As always, Seas0nPass is available as a free download from Seas0nPass.com.

Troubleshooting tips can be found here.

Enjoy. Smile

Comments

Submitted by adampopovich on May 25, 2012 - 12:11pm

I'll try everything again later tonight.  It's been a while since I've had to go through this whole process, so I may well be to blame for the problem.  I'll post an update when I do.

Submitted by asiscaurcel on May 25, 2012 - 12:14pm

I have the same problem. I cant install Media Player. Has you achieved solve the problem? Thanks

Submitted by Anon on May 25, 2012 - 12:18pm

what the hell does that even mean?

Submitted by asterisk.it@gma... on May 25, 2012 - 12:18pm

I have the same problem: unable to install the Media Player ;( Any Fix?

Submitted by robertp.0459 on May 25, 2012 - 12:19pm

you are missing the point.... aTV was installed successfully. After that when u get into maintenance - manage software we get an error when trying to install media player or XBMC because of the dependency....

Submitted by AdamDz on May 25, 2012 - 12:23pm

Unplug the Apple TV from the power cable and try again, u helped me, too had a problem.

Submitted by cafeplayboy on May 25, 2012 - 12:23pm

the UI of the 5.0.1 lol...

Submitted by Anon on May 25, 2012 - 12:25pm

tried it didnt work

Submitted by Anon on May 25, 2012 - 12:25pm

atv flash will not recognize any appletv on my network not.... jailbroken but cant install atv flash

Submitted by alsega7 on May 25, 2012 - 12:26pm

The same. I wait patiently for the untethered jailbreak for the ATV2, but now that I upgrade, can not install Media Player, XBMC just to install the software of NITO Tv.
I feel frustrated, and not be as a return to the previous version that worked me perfectly the XBMC, which is what most interests me.
Can anyone of you help me?
Thank you.

Submitted by jcostas on May 25, 2012 - 12:26pm

Unable to install NITO TV, MEDIA PLAYER, XBMC, PLEX, WEATHER, ETC.

Only seas0npass Ok !!!

Submitted by Anon on May 25, 2012 - 12:26pm

atv flash will not recognize any appletv on my network now.... jailbroken but cant install atv flash

Submitted by phunkjp on May 25, 2012 - 12:36pm

Same here. I cant install MediaPlayer,etc.

 

Submitted by Anon on May 25, 2012 - 12:38pm

How are u trying to install xbmc?

U cant install it like a normal ssh.

U have to use these commands:

apt-get update
mkdir -p /Applications/AppleTV.app/Appliances
apt-get install org.xbmc.xbmc-atv2
mkdir -p /Applications/XBMC.frappliance
wget http://dl.dropbox.com/u/14341410/org.xbmc.xbmc-atv2_11.0-3_iphoneos-arm.deb
dpkg -i org.xbmc.xbmc-atv2_11.0-3_iphoneos-arm.deb
rm org.xbmc.xbmc-atv2_11.0-3_iphoneos-arm.deb

The the ones that u use for 4.4.4 dosent work. (at least for me)
This works for me did it 1hour ago.

Submitted by Stingray88 on May 25, 2012 - 12:50pm

For everyone having issues installing Media Player, so long as you can actually get to the "installing media player" screen... just let it be!

It took a total of 22 minutes to install for me, which is absurdly long... but at least it installed and works fine. You also might try restarting the AppleTV and trying again to see if that helps. But I just wanted to add another person who has gotten media player working fine, so keep at it guys!

If instead you're getting an error message when you go to install, I'd try rejailbreaking.

Submitted by Trousers on May 25, 2012 - 12:54pm

Thanks for the info, I'll let it be and see ... 

The other guys if you're getting an error on the first attempt then power cycle the aTV (remove power cord) and then try again, and let it be as above.

Submitted by vongoesseln on May 25, 2012 - 12:56pm

Success, first got an error message while installing the media player. But then i did it again and then waited ... waited ... waited ... approx. 10 minutes later. The main screen appeared with a new icon labeled "median" (german for Media).

Submitted by sebastienl.4755 on May 25, 2012 - 12:58pm

atv flash will not recognize any apple tv on my network.  so it wont install.  jailbreak fine.  no atv flash.  any ideas? i tried full restore already

Submitted by Anon on May 25, 2012 - 1:10pm

Regard unable to install mediaplayer, xmbc, last.fm and so on. Take the powercord out and put it in again, worked for me. Then i could install everything Smile all works !!

Submitted by Anon on May 25, 2012 - 1:13pm

For those having trouble adding any of the extras (media player etc..) try restarting the device.

Settings > General > Restart

Worked for me.

The installation of media player was still extremely slow after (overloaded server) but it got there eventually.

Submitted by jeffa.1207 on May 25, 2012 - 1:31pm

Jailbroke it just fine; can't load atv flash black though, it's been stuck on "transferring files..." for half an hour.

Submitted by gordonr.1446 on May 25, 2012 - 1:34pm

Thanks, thanks ,thanks! for all your hard work and dedication for such a great program.Worked first time.

Submitted by Anon on May 25, 2012 - 1:34pm

after jailbreak my atv is not showing full menu. it only shows the home sharing logo and fc logo. any ideas?

Submitted by Anon on May 25, 2012 - 1:36pm

you still need to apply aTV Flash. The FC logo just means that its JB

Submitted by Ownleame on May 25, 2012 - 1:36pm

It's nice to know we have this kind of support.  I knew it was just a matter of time before a untethered version would come out.  I know how much time and energy has been put in so many, many thanks for all your hard work

Submitted by ricardo.hermann on May 25, 2012 - 1:36pm

same problem.... Anyone can help us?

Submitted by Anon on May 25, 2012 - 1:38pm

Do you have airplay enabled?

Submitted by twhiting9275 on May 25, 2012 - 1:44pm

Try again.

I noticed that with a couple of mine this morning as well. Soon as I unplugged, re-broke the device, it was fixed

Submitted by Trousers on May 25, 2012 - 1:45pm

Maybe Firecore can add a percentage for the install next time, would help to know where it is in the process.

Mine has been installing for 50 mins now ....... 

Submitted by jeffa.1207 on May 25, 2012 - 1:48pm

yes

Submitted by marocom on May 25, 2012 - 1:48pm

todo va muy bien, costo pero funciona genial

Submitted by Trousers on May 25, 2012 - 1:48pm

I also had this on install the aTV flash. 

I quit the installer and then either just ran it again, or power cycled the aTV and then ran the installer again ... can't remember which, but it went through after that.  

 

Note...i DIDNT re-jailbreak the device ... 

Submitted by scottra on May 25, 2012 - 1:56pm

COULD NOT get XBMC to show up, I installed using SSH, but it wouldn't show up. Installed aTV Flash, still nothing... I went into Maintenance and removed XBMC, rebooted and then installed it fresh through the Maintenance menu, and everything is working great now, actually seems like it has a way faster response time when moving through the menus.

Submitted by jeffa.1207 on May 25, 2012 - 2:10pm

Thanks, tried rerunning the installer earlier, same thing. Will try power cycling. If all else fails will try re-breaking.

**update: working now--rerunning the installer and power cycling wasn't helping, but finally got it to work by killing a bunch of apple-related processes in task manager (including ituneshelper and bonjour) not sure which one if any did the trick. This time it loaded in seconds**

Thanks again!

Submitted by kyteflyer on May 25, 2012 - 2:15pm

Media Player not working here.  I wonder why it seems to randomly select success here and there?  The install just fails, it doesnt hang.  Message is that there are unmet dependencies, and I quote...

"The following packages have unmet dependencies:

com.firecore.media: Depends: com.firecore.libafpclient (>=1.3.50) but it is not going to be installed

Reading package lists...

Building dependency tree...

Reading state information...

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded"

I've submitted diag info. Do hope this issue can be resolved.

Submitted by Trousers on May 25, 2012 - 2:31pm

I had this. Power cycle (pull the power cord) and then retry the install. 

Although next you maybe waiting at the 'installing Media player' page ..... and watching and waiting and watching and waiting ..... 

Submitted by peregrines on May 25, 2012 - 2:34pm

i got it to work finally ... but there is one BIG problem left:
since I updated, the ATV2 refuses to connect to my Timecapsule (AFP).
Is there any known issues?
ATV is completely useless to me as long as it doesnt cooperate with my Timecapsule :O
 
p.s if you have troubles installing "media player": just restart your ATV and try again ... its going to work now (slow)

Submitted by longton48 on May 25, 2012 - 2:41pm

running  5.0.1 untethered  with atvflash 1.5 .just put the latest seasonpass on boot tethered everything fine for me.

thank you all very much

Submitted by Anon on May 25, 2012 - 2:51pm

delete old link and add it back again

Submitted by firstsxme on May 25, 2012 - 2:57pm

ATV flash kept hanging ... DISABLE BONJOUR service, enter IP address manually and it should work

Submitted by firstsxme on May 25, 2012 - 2:59pm

if you cant install atv flash, try shutting down bonjour and entering ip address manually

still cant install media player or last.fm

Submitted by peregrines on May 25, 2012 - 3:00pm

thanks for your help ... but thats what I tried first!

i also restarted both ... ATV2 & Timecapsule.

ATV2 keeps giving me the "connection error" message Frown

 

Submitted by Anon on May 25, 2012 - 3:02pm

You must have lost your internet connection....try connecting again

Submitted by peregrines on May 25, 2012 - 3:06pm

... now its working Smile

i needed to also specify "username" ... not only "password"

 

happy now ... thanks so much firecore!!!

you are truly making my life better Smile

Submitted by Anon on May 25, 2012 - 3:10pm

Need to connect it to the WiFi or Ethernet cable. Once it get access to the internet you should see all other applications.

Submitted by Anon on May 25, 2012 - 3:15pm

You need to download ATV Black Flash and use that to install your extra programs, that or SSH nitoTV to your ATV2

Submitted by Anon on May 25, 2012 - 3:21pm

I got the jailbreak to work but when I try to install aTV Flash black 1.5.1 it says

Sorry, the installer could not install Maintenance (Error 9.100). Help!

Submitted by sebastienl.4755 on May 25, 2012 - 3:25pm

how do you disable bonjour?

Submitted by dattas on May 25, 2012 - 3:29pm

I followed the directions on Win7 and everything went just perfect with my aTV2.  In case anyone else is wondering if they should take the plunge.  XBMC and aTV Flash installed without any problems.