Today we are happy to release a brand new version of Seas0nPass that provides an untethered jailbreak of the latest 5.0.1 (iOS 5.1.1) software for the 2nd gen Apple TV. Massive thanks goes to @pod2g and Co. for the countless hours that went into making this new release possible.

Update 6/6: Seas0nPass has been updated to support the new 5.0.2 Apple TV software.

What about the new 3rd gen Apple TV?

Unfortunately Seas0nPass is not yet compatible with the new ATV3. Work is still ongoing and we'll be sure to announce any and all news as soon as it becomes available. Be sure to follow us on Twitter, Facebook and Google+ for up to the minute info.

Which plugins are currently supported on 5.0.1?

  • Couch Surfer (works)
  • Last.fm (works)
  • Maintenance (works)
  • Media Player (works)
  • NitoTV (works)
  • Plex (works)
  • Remote HD (works)
  • Rowmote (works)
  • RSS Feeds (works)
  • Weather (works)
  • XBMC (works)
  • Overflow (not working)

Superb! Where can I get it?

As always, Seas0nPass is available as a free download from Seas0nPass.com.

Troubleshooting tips can be found here.

Enjoy. Smile

Comments

Submitted by Anon on May 25, 2012 - 3:36pm

Well after iPhone and iPad i now discovered the Apple TV and you and I' m really happy! The functionality and unlocked A-TV showed how the perfect media-player should look like if the industry would only listen. I'm so glad that you've taken over this position as my A-TV matches now fully to my expectations of a small universal media-box that is powersaving and upgradable. Thankyou such much that by now I can easily switch between living and sleeping-room without a tethered boot. Greetings from Germany and a glad customer! You made my weekend!

Eric

Submitted by markbajaj on May 25, 2012 - 3:43pm

xbmc will work if you install as described here:

http://www.appletvhacks.net/2012/04/02/xbmc-11-0-eden-for-apple-tv-2-5-0...

Took all night to find that!!!

JB works well otherwise - no issues on 2 x Apple TV2

Enjoy!

Submitted by staytunedcanada on May 25, 2012 - 4:04pm

if i have 4.44 already (jailbroken) and aptv 2 flash (firecore) do I have to start all over by restoring on itunes and then go from there? 

Submitted by Anon on May 25, 2012 - 4:08pm

Hi!

This all sounds great, but I'm a bit uncertain about the update procedure.

Is it necessary to restore the atv to an unjailbraked state, then update to the latest iOs version and then start the procedure with jailbraking and installing atv flash black?

Thanks!

Submitted by timd.4762 on May 25, 2012 - 4:14pm

Same query here - after only recently jail breaking via Seas0n Pass (and it taking several hours to get right); I'm a little wary about doing it again so soon.

 

So for this untethered jailbreak do I need to re-jailbreak, or restore via iTunes the Apple TV?

Submitted by Anon on May 25, 2012 - 4:33pm

Still waiting for media player to install.
It's stuck at the install screen for a few hours now.

Submitted by millefredl on May 25, 2012 - 4:44pm

Great work, well done! It´s the most important update since I use ATV Flash Black. Installation: no problem ! You have only to start the program and wait until you see your ATV with the right IP Adress. After installing the files ATV will reboot and all is done ! I did the update with my MacBook via WLAN and I don't use XBMC.:D

Submitted by Anon on May 25, 2012 - 5:06pm

I got it to work... i had to go into plea server and find my friendly name under general... then add server in plea on apple tv.. add my mac login and password and friendly name.... when successfully connected you have to make sure on list mode for movies and tv

Submitted by Anon on May 25, 2012 - 5:30pm

MY XBMC AND PLEX CRASH WHEN I OPEN THEM IS ANYBODY ELSE HAVING THIS ISSUE
AND WHO CAN CONFIRM XBMC AND PLEX WORKS ON THIS FIRMWARE AND IF NOT HOW DO I DOWNGRADE

Submitted by mediaboy on May 25, 2012 - 6:06pm

You need to get season pass to apply the jailbroken 5.0.1 iOS to your ATV2.  This means attaching the ATV to your computer and entering DFU mode like you did the originally. Then you can use atv flash to update. Right now you are still on the old iOS, doing an update doesn't accomplish much..

Submitted by Trousers on May 25, 2012 - 6:42pm

I was aswell, then I bit the bullet and went through the jailbreak again. 

1. Re-jailbreak aTV.

2. Restart it again after plugging it in first time after jailbreak. 

3. install aTV black Flash.

4. Restart it again after install. 

5. Dont restore settings (if you have those).

6. Install Media player ... this time took 10 seconds. 

7. Restored settings. 

 

The things I did different this time was restarting it before each install step, and didn't restore settings until after I installed media player. 

Hope that helps. 

Submitted by Anon on May 25, 2012 - 7:18pm

Finally managed to get it to work

1.DO NOT run atvflash from the dmg file..... copy it to your hdd & run it.
It completes very quickly

2.unplug your atv power cable & replug & then try to install media player.
Do the unplug after you have completed your basic setup & networking etc etc

Submitted by Anon on May 25, 2012 - 7:51pm

any relation to steve popovich?

google "installing plex atv ssh"

if your not comfortable using command line, then you may want to purchase their entire package, support the developers.

However, i'm pretty sure the real exploit makers don't get money from firecore (feel free to correct me if i'm wrong)

Submitted by Anon on May 25, 2012 - 8:04pm

Im also see the same issue - Have the FC logo but the SP menus are not there in the Settings

Submitted by nntong2007 on May 25, 2012 - 8:35pm

it stuck couple hours when try to install media player. please help

Submitted by philg.3575 on May 25, 2012 - 9:00pm

I had the same problem with Media Player.  I was originally getting the "failed to install" message.  I power cycled and tried again, this time it was hanging for a very LONG time.  I decided to let it be, changed inputs to watch regular tv.  Checked several hours later and it was installed.  I don't think it took hours, but other reports are saying they waited as long as 22 minutes.  If you are getting "Installing", let it be.  Good Luck!

Submitted by Anon on May 25, 2012 - 9:36pm

Hi all --

I'm on a macbook and can download and unzip Seas0npass but when I try to open it I get the spinning wheel and the program never opens. I've downloaded and deleted numerous times and it hangs up every time. I have to force quit.

Any ideas??

Thanks!

Submitted by gordonr.1446 on May 25, 2012 - 9:52pm

I had Media Player hang on me. I restarted Apple TV and it loaded right away.

Submitted by prj32 on May 25, 2012 - 9:53pm

Same here ... Preparing Apple TV for restore ... Zzzzzzzzz

Submitted by tbay2410 on May 25, 2012 - 10:08pm

Thanks!! This solved all my installation issues.... Frown

Submitted by Anon on May 25, 2012 - 10:13pm

Is anyone having problems with Plex?? I just updated everything, and I can't get the media server to populate from my PC to Apple TV 2.

Zeee1

Submitted by Anon on May 25, 2012 - 10:43pm

should of stayed on 4.4.4 .. this is a glitch fest.. and there is no way to downgrade. ah well.

Submitted by psychicpsquirrel on May 25, 2012 - 11:02pm

Whenever I've had problems like this, it's always been caused by having other iOS devices connected to iTunes at the time. It doesn't matter whether they are connected by usb or wifi. If other devices are showing up in iTunes, turn them off while you're running Seas0nPass. Since I started doing this, Seas0nPass has never failed. 

Submitted by fabiod.0165 on May 26, 2012 - 12:33am

Perfect! All ok!

Submitted by hjack on May 26, 2012 - 12:39am

I know my 4.4.4 works better then my 5.1...glad I kept one on 4.4.4

Submitted by prj32 on May 26, 2012 - 12:49am

Reset Apple TV to factory defaults.  Retried and worked (need to restart Seas0nPass.app). Wink

Submitted by prj32 on May 26, 2012 - 12:50am

Thanks Firecore!  Looking forward to ATV3

Submitted by Ian NE on May 26, 2012 - 1:03am

Wow this is good fun!

Went through process of jailbreaking and appeared to work but no Firecore logo showing on settings. nevertheless managed to shsh Nito tv so must be jailbroken. But XBMC not working. Armed with the excellent XCtechs video on installing XBMC tried again but now Putty tells me server unexpectedly closed network connection and I get same message with Win SCP. NITO tv still works but am I jailbroken or not?! Do I have to re-jailbreak?

 

Help please.

Submitted by steveloveday30 on May 26, 2012 - 1:17am

New jailbreak worked a treat and plex installed without a hitch BUT....... Upon the final stage of jail breaking iTunes came up with n unexpected error apparently failing to restore the firmware however upon unplugging and booting my ATV 2 normally it all works fine..

My advice is to look for the light on front of ATV2 and once it's staying on u can ignore the iTunes error and just boot up as norml....

Thank you so much fire core.

P.s . Love that plex has its icon back but am disappointed to find that the grid view for movies and tv shows force the Atv to reboot and fails to load the directory please fix this as I have thousands of files and I don't wanna scroll through like I do with ATV standard player....

Submitted by Anon on May 26, 2012 - 1:25am

Finally got Plex working by SSH-ing an update. I lost the icon, but I am okay with that. I do not like the list view, I prefer the grid, but that tends to reset the ATV2.

Zeee1

Submitted by jamest.8685 on May 26, 2012 - 1:54am

This worked for me but I would add that I needed to plug-in the aTV for iTunes to see it (1st, usb, run iTunes, then power) and that the restore went 99.9% through and then said it failed. The aTV's light was on steady so I assumed it just rebooted and was fine..and lo, it was!  

Great step-by-step...thanks!

Submitted by Anon on May 26, 2012 - 2:02am

Very Fine Job,
But now, xbmc, Last fm and Media Player dont work Frown
What is the Problem?

Submitted by dennisw.walta on May 26, 2012 - 2:19am

I'm having problems with Plex too. Plex does advise not to upgrade, I'm guessing they're still working on a new edition... So listview for now

Submitted by stefanw.1932 on May 26, 2012 - 2:32am

same problem as many others on here !! seas0npass worked fine, but now media player xbmc will not load !!!

Submitted by travism.9217 on May 26, 2012 - 3:03am

I followed this step by step i unplugged everything instead of just restarting it and IT WORKS!!!!

Installing media player did take ALOT longer than 10 seconds but it has worked!!

Now all i need to know is how to get rid of the icons i don't want!!!

Submitted by Anon on May 26, 2012 - 3:07am

xbmc wont load , & Plex very glitchy

Submitted by yoannr.5672 on May 26, 2012 - 3:09am

Great release. A bit of issues but it's all good at the end :

  • Error 9 when restoring from iTunes : Fixed by plugging the micro USB cable directly to the Mac (as opposed to a USB hub). There also another trick which consists in plugging the power cord as well (after plugin the USB) but removing quickly the power cord when iTunes is "updating the firmware". This error 9 happens when there is a lack of power available through the USB which causes it to briefly disconnect.
  • Slow installation from the installer. Keeps spinning for a while like it is stuck, but after 5 good minutes, it's all installed.
  • Slow installation of the Media Player (once again, keeps spinning for a long while, but it gets eventually installed)

Just arm yourselves with a bit of patience and all will go smoothly. Grin

Submitted by jasonp.0362 on May 26, 2012 - 5:11am

if anyone else is getting a 1601 error in iTunes and you have MacScan installed... uninstall MacScan! Took me about 4 hrs to work it out!

Submitted by twhiting9275 on May 26, 2012 - 5:12am

It is not necessary to restore the ATV to an unjailbroken state, however that's not a bad idea

 

Submitted by twhiting9275 on May 26, 2012 - 5:14am

Try re-breaking the device. That will probably help solve that

Submitted by milandukanovic on May 26, 2012 - 7:07am

Hey from Germany,

 

Jailbreak works... Cool

 

But XBMC, Media Player and so on... Don´t WORK...

 

WHY ???

Submitted by Anon on May 26, 2012 - 7:14am

Thank you very much, all works property folowing this steps.

Submitted by NCTokyo on May 26, 2012 - 7:14am

If I upgrade to this JB, how do I preserve my XBMC settings? Can I back up them up in maintenance and then restore or are they automatically preserved in the new install? Answer in layman's terms would be really appreciated

Submitted by shayan512 on May 26, 2012 - 7:54am

hi jailbreak worked fine but can't ssh !! any solution ??????

Submitted by Anon on May 26, 2012 - 7:57am

PLEASE HELP...I have jailbroken my appletv and it went fine, thank you so much for all your hard work!!!! nitotv was installed ok using putty and i have installed XBMC, it says it's installed but there is no XBMC icon at the home page just the words xbmc and when i click it it takes me to new screen that has xbmc, i click it and it takes me back to the homepage. I've tried uninstalling and reinstalling and i get the same thing, it's driving me mad. I'm not great on computers and could really do with some advice. Thanks guys!!!

Submitted by Anon on May 26, 2012 - 8:16am

Don't give up. If you get the spinning wheel of death, just unplug the power and plug it in again. It will work after that. All programs that I have tried are working fine. Some better than in 4.4.4.
Plex still not working that well, but XMBC is kicking ass.

Submitted by brian r.9178 on May 26, 2012 - 9:44am

Take out the electric lead and reboot ..then xbmc will install

Submitted by pierrev.1207 on May 26, 2012 - 10:39am

A big thank to you guys , Respect ! Keep up the good work.

Submitted by miguelamartinez1 on May 26, 2012 - 11:54am

Thanks for your post because I thought I was the only one. Installing media player is taking a long time. But be sure guys it took me like 8 minutes but it loaded have patience.

Submitted by Anon on May 26, 2012 - 1:37pm

I'm having trouble jailbreaking with the new software on windows 7, season pass goes through all the motions to prepare and install the software but when it goes to the "restoring in iTunes, please wait while script is running" screen it opens itunes but never initiallizes the restore, keeps saying "restoring in itunes please wait while running script'' but itunes is doing nothing, looked at some forums and did everything it said, as far as most current itunes, and season pass, as well as restarting my computer, checking my security settings and disconnected other usb devices with still no luck, it says right when i open season pass to close McAfee Total Protection but i dont have that, i have McAfee Internet Security which im sure is the same thing, and i disabled everything and even disabled them in the processes part of task mananger. Now i may be wrong but im starting to think thats theres something wrong with the script season pass is trying to run for the restore. Any help would be greatly appreciated.