Today we are happy to release a brand new version of Seas0nPass that provides an untethered jailbreak of the latest 5.0.1 (iOS 5.1.1) software for the 2nd gen Apple TV. Massive thanks goes to @pod2g and Co. for the countless hours that went into making this new release possible.

Update 6/6: Seas0nPass has been updated to support the new 5.0.2 Apple TV software.

What about the new 3rd gen Apple TV?

Unfortunately Seas0nPass is not yet compatible with the new ATV3. Work is still ongoing and we'll be sure to announce any and all news as soon as it becomes available. Be sure to follow us on Twitter, Facebook and Google+ for up to the minute info.

Which plugins are currently supported on 5.0.1?

  • Couch Surfer (works)
  • Last.fm (works)
  • Maintenance (works)
  • Media Player (works)
  • NitoTV (works)
  • Plex (works)
  • Remote HD (works)
  • Rowmote (works)
  • RSS Feeds (works)
  • Weather (works)
  • XBMC (works)
  • Overflow (not working)

Superb! Where can I get it?

As always, Seas0nPass is available as a free download from Seas0nPass.com.

Troubleshooting tips can be found here.

Enjoy. Smile

Comments

Submitted by Anon on May 30, 2012 - 8:55am

I extracted the file (SeasonPass.exe) but it will not run. I have jailbroken other devices before (iphone 2 and 3 and iPad 2) with mostly no trouble but I cannot get Seasonpass to run no matter what I try.

Submitted by spacegabs on May 30, 2012 - 11:39am

Worked like a charm! EverYthing is working! (xbmc, hulu, netflix, Media PlaYer, Couch Surfer).

What else can we ask for? Wink

Thank you guYs for all your work.

Greetings from Spain Grin

Submitted by Anon on May 30, 2012 - 1:05pm

I could not restore in itunes, i had to go in to terminal and put "#" infront of line "74.208.105.171 gs.apple.com". After that it worked perfectly. Thank you to the Seas0npass crew.

Submitted by Anon on May 30, 2012 - 4:41pm

The installation went very well!!! TAKES A LONG TIME TO CONNECT TO NAS.... WHY ???

. I tried XBMC and it's a matter of seconds..!

This started to happen after the 4.4...update...can you please fix this..I can't use media player it's too slow...so I'm using XBMC...it's faster...

Submitted by Jimi on May 30, 2012 - 5:03pm

Other than the FC SeasOnPass is there anything else I need to download because when I did the download all I got was the FC logo on the Settings icon and none of the other programs such as Media Player, XBMC, aTV Flash or Maintenance show up in the menu. I read in one of the other comments about installing aTV Flash. If so is aTV Flash a free download?

Submitted by Anon on May 31, 2012 - 11:04am

You pay for aTV flash, but it`s worth the money.

Submitted by kerrse on June 1, 2012 - 12:10pm

I was only going to jailbreak one of my atv's due to overflow & remote hd not being available yet but stupidly forgot today thats is why i had only done 1 :(& just jailbroke the 2nd, any news on sorting remote hd as i use that all the time Frown

Submitted by Anon on June 1, 2012 - 12:47pm

Try to right click the seasonpass.exe file and choose run as administrator!

Submitted by Anon on June 1, 2012 - 2:09pm

Can i keep my XBMC and other add ons if i rejailbreak with the new seasonpass?

Submitted by Anon on June 1, 2012 - 8:29pm

I second this question. What about all my add-ons and aTV flash?

Submitted by Anon on June 2, 2012 - 4:12am

I've tried this upgrade 3 times now and keep failing at the point where it needs to restore the IPSW in itunes. Then it says "iTunes restore failed., selecting IPSW in finder..." and it sits there for ages. The IPSW file was unzipped earlier (and every time) so what's happening please and how do I solve it?

Submitted by Anon on June 2, 2012 - 11:25am

Hi Dav,

I have the same problem. Men, it's a pain in the ass.
Have you already had some suggestions on how to solve this problem?
Hope to Hera from you.

GreatZZZzz, Polifinario

Submitted by ketank.6589 on June 2, 2012 - 11:42am

The current firmware on my 2nd generation Apple TV is 4.4.4  Do I first need to update the firmware from Apple and then do the 5.0.1 Seasonpass jailbreak?  Or will the jailbreak also load in the new firmware?  Thanks.

Submitted by Bata on June 2, 2012 - 2:35pm

I downloaded AppleTV2,1_5.0_9B206f_Restore.ipsw and Seas0nPass 0.8.5

I created IPSW and it's done, but in restore i get error 1604 in Mac and windows7

i deleted gs.apple.com in Hosts file in Mac and windows

but get Error 1604 Frown

 

Submitted by stein.tyldum on June 3, 2012 - 2:38am

I have exactely the same problem. FireCore team , please help us Smile

 

Submitted by stein.tyldum on June 3, 2012 - 2:39am

 

 

Submitted by stein.tyldum on June 3, 2012 - 3:01am

I finally got it to work. Installed itunes on a computer that I have never used with itunes before and did the jailbraiking using this computer.

 

Submitted by miguels.69948 on June 3, 2012 - 4:40am

I did it only today and it works under the OSX 10.6.

I have to warn you that if you are running under OSX 10.8, the new Lion Mountain, IT WILL FAIL. The Seas0nPass Script to run the iTunes update does not run properly and iTunes will restore the IPSW without Jailbreak.

Thanks guys, Jailbreak ROCKS ON

Submitted by miguels.69948 on June 3, 2012 - 4:42am

which OSX are you running? with Mountain Lion doesnt work

Submitted by miguels.69948 on June 3, 2012 - 4:46am

i had problems under my OSX 10.8, but after doing everything under 10.6 it just went fine at first try and it rocks on Smile

Submitted by getmilton on June 3, 2012 - 5:48am

Attempted to install using the new seas0npass. Everything worked normally until the script for iTunes to restore. Display said the script failed and now had to find the ipsw. The program wasn't doing anything I could see. Rather than restart the process, in iTunes (mac) I held down the Option + Restore allowing me to choose the ipsw to restore. I copied the file seas0npass created to the desktop and chose the copy to restore. Everything worked normally after that! Last version I spent several hours trying to get seas0npass to work. Now, it was a matter of 20 minutes. Thanks for the update.

Submitted by kterrio on June 3, 2012 - 9:47am

you know, in this day and age, $30 for a piece of software os a big chink pg change.  Last time  spent that much of software was the mac OS update let week.  I admit it though.  I got fucking doped, what can I say?  And the makers of this are scums of the earth bc they manage to pass themselves off as legit.  I have to see if I can get my CC company to stop mayment on them.  Let them chase me for it in court, this was a BS, misleading ad campaign...

Submitted by Bata on June 3, 2012 - 2:53pm

is there anybody here help us... :(:(:(:(:(

Submitted by Bata on June 3, 2012 - 2:55pm

if I change User (Profile) wil work...?

Submitted by ketank.6589 on June 3, 2012 - 7:30pm

Since the 1.6 maintenance update caused Media player to disappear, I re-jailbroke with SeasonPass 5.0.1 which automatically installed the latest firmware in Apple TV through the restore process in itunes (I was previously on 4.2.2).  Media player works flawlessly as well as XBMC.  The new ATV interface is nice as well as some of the new apps like WSJ Live. Thanks Firecore!!

Submitted by Anon on June 4, 2012 - 1:36am

Worked perfectly for me with 1st attempt. Everything was done under 10 minutes on Mac Lion 10.7.4 and iTunes 10.6.1.

I don't use ATV Flash. I just followed the instructions from XBMC forum and installed the latest XBMC.

Rock solid guys.

Submitted by danielsan on June 4, 2012 - 1:59pm

Worked perfectly. Thanks a lot.

Submitted by rupinders.9772 on June 4, 2012 - 7:44pm

I was unable to get ATV2 into DFU mode - but I then tried to put in power cable and usb cable, used Ireb to get into DFU mode - works fine, I just need to know the steps.

  1. run season pass
  2. when season pass prompts to enter into DFU mode - run ireb/plug in power cable and usb cable...once into dfu mode
  3. open itunes
  4. press shift key to select the file that season pass downloaded and I get error message I didnt make note of the errror messge, but i can try it again.

 

Submitted by tom.740410 on June 7, 2012 - 3:35am

Hi All,

worked fine with 5.0.2.

The only item to note, when it first tried to update the ATV2 in iTunes, the update failed. I had to restart Seas0npass, let it recreate the file, then I disconnected the ATV2, reconnected it and put it into DFU mode and it all worked fine. Using a mac.

Hope to see ATV3 'fix'!

Thanks.

 

Submitted by Bata on June 8, 2012 - 2:15pm

I did it but not work, got error 1604 :(

Submitted by johnh.0628 on June 8, 2012 - 8:42pm

Like some of the others, I tried a dozen times to get this working on OSX 10.7.4 without success.  Switched to a Windows 7 machine and it worked the first time.

Submitted by Anon on June 10, 2012 - 1:02am

Had some problems during restore, was getting unknown errors 12 or 14, apple website suggested could be a USB issue, after looking, I fund the cable connected to a USB hub first, bypassed the USB hub, and restore went perfect. Awesome job Fire Core!!

Submitted by Anon on June 12, 2012 - 10:31pm

Hi, i had the same problem, i deleted windows downloader of my machine, and downloaded seansonpass again, and worked 1st time.

Mark

Submitted by Anon on June 16, 2012 - 12:32am

Awesome program. One fatal flaw. SeasonPass downloads a new copy of the ATV software when there's already one on the PC in itunes. Can we somehow direct seasonpass to a copy of that software so don't have to blow another nearly 500mb downloading again?

Submitted by james on June 16, 2012 - 8:14am

Yes, you can Option + Click (Mac) or Shift + Click (PC) the Create IPSW button to choose a local IPSW file instead of downloading a new one.

Submitted by fabienb.4039 on June 24, 2012 - 11:13am

Excelllent Program 8 That's works very well with some few little bugs as sound stop playing with AC3 MKV ripped Films when you fast forward or reward.

Great Work ! 

 

Submitted by jamesm.8952 on June 25, 2012 - 9:10am

Worked Perfect...........Thanks Firecore.........B-)

Submitted by Anon on June 29, 2012 - 4:19pm

I ran the latest update and lost function of home sharing it would say the library has no videos in it.
you-tube would allow searches but would not play any files selected.
I went back to the default for today so the kids can watch Apple TV and will run the process again tonight.

Submitted by Anon on July 1, 2012 - 8:41am

any news on apple tv 3 jailbreak

Submitted by Anon on July 7, 2012 - 1:59am

all hope is gone... seems nobody is working on this...

Submitted by GeordieJim on July 7, 2012 - 10:54am

help!!....uploaded seasonpass...all ok ....at the point of waiting for dfu pluggin in the usb on my apple tv2 nothing Frown ...did various prompts in itunes holding menu and play button with power plugged in ..this seemd to dod a quick load instantly after seeing in dfu mode....tried to shift and restore to file season pass had indicated but erro message saying file incompatible...tried this loads of times without success....check my apple tv software its 5.0.2 (4250).....any ideas def does not go indfu mode with just usb as so many you tube videos indicate Frown

Submitted by Anon on July 8, 2012 - 9:09am

I think your right! I traded my ATV3 for the ATV2 yesterday and did everything the way it's supposed to be done and notta! This sucks!

Submitted by GeordieJim on July 8, 2012 - 1:08pm

its a pisser Pete im thinking ive got a duff ATV2 ...it just will not go into dfu mode....it does when i plug the power cable in but the "fix" is too quick and when i restore the file thru itunes just tells me its a firmware compatibility issue !! ...grrr

Submitted by Anon on July 10, 2012 - 6:49pm

Now after doing this on 5 appletvs you MUST KEEP IT PLUGED IN TO THE POWER SOURCE or IT WON'T WORK!

Submitted by Anon on July 11, 2012 - 8:27am

I had some of the same issues when upgrading to 5.0.2 and I just tried the jailbreak on my pc instead of my Mac and everything worked fine.

Submitted by Anon on July 12, 2012 - 1:38pm

THANKS !! it work for me with power cable still plugged, as you said.

Submitted by TapOut on July 26, 2012 - 10:46am

Yiipppii, the power plugged in did it for me. 

Without the power cord there was no way to enter DFU mode

Submitted by Anon on July 30, 2012 - 2:32pm

Not true. I never used the power source and i have done dozens. All with no issues. You might want to follow the steps a little more carefully.

Submitted by elwero on August 9, 2012 - 8:38pm

Hi, I have the atv 2, I have updated to version 5.0.1, I followed step by step to jailbreak, I have done many times, but does not work, I fc logo appears on the screen.

What's wrong?

Am I doing something wrong?

Please, I hope to help me, thanks!