Happy Friday! Today we are pleased to present you with another major update to Media Player for the 2nd gen (black) AppleTV. Version 0.7 adds a number of exciting new features (especially for our friends outside the US) and resolves a number of pesky bugs. All in all, a solid update that moves us one step closer to the final version!

What's new in Media Player 0.7?

  • Added new playback menu (hold select during playback)
  • Added support for .srt subtitles
  • Added support for multiple audio tracks
  • Added support for chapters
  • Added support for localized metadata
  • Added support for local cover art
  • Added option to refetch metadata for a specific file
  • Added option to clear all metadata
  • Added toggle setting for volume control
  • Improved metadata fetching (courtesy of themoviedb.org)
  • Improved progress bar controls
  • Improved DVD playback and ff/rw controls
  • Improved audio track selection logic
  • Resolved aspect ratios issues for certain video types
  • Resolved file browsing related crashes
  • Resolved metadata fetching related crashes
  • Resolved audio queue related errors
  • Resolved Top Shelf related playback issues
  • Resolved playback related memory leaks
  • Minor UI improvements
  • Many other miscellaneous fixes

What can I do with the playback menu?

The new playback menu provides quick access to chapters, audio tracks and subtitles. To access this menu simply press and hold the center (select) button during playback. Press the menu button to return to the movie.

Note: Chapter controls can also be accessed by pressing the down arrow on the remote during playback.

Spectacular! Now how do I get it?

With aTV Flash (black) installed, Media Player 0.7 can be downloaded on your ATV2 through the Maintenance --> Manage Extras menu. If you need to re-install aTV Flash (black) links for the latest version can be found under the Downloads tab in your account.

New users can pre-order aTV Flash (black) here.

Enjoy!

Comments

Submitted by james on August 29, 2011 - 4:33pm

Which tool was used to backup your DVDs?

Submitted by james on August 29, 2011 - 4:34pm

The setup guide can be found here.

http://support.firecore.com/entries/20322512-m...

Submitted by rihernandez on September 1, 2011 - 7:16pm

I installed the latest beta of atv2 flash black with latest media player. I added my time capsule to be accessed on the media menu. I can see my m4v files but I cannot play them. I always get Playback Error. File sizes range from 200MB to 5GB and they were created using hand brake with large-file option (64-bit). Only files under 1GB will be played by Media Player.

Is there any work-around?

Do you have a solution to this issue on its way?

Thanks.

Submitted by Anon on September 2, 2011 - 9:56am

Where do I put the .SRT file so the subtitles work?

Submitted by Anon on September 3, 2011 - 6:19am

I have the same problem.
The cause seems video audio format.
・MPEG-2 video doesn't shift.
・MPEG-2 video + AC-3 shifts gradually.

Submitted by andreass.2910 on September 4, 2011 - 4:56pm

Via Ethernet from a Synology NAS

Submitted by michaelpanayi on September 6, 2011 - 10:54pm

Hi James

A couple of questions:

  • Is there any plan for Media Player to clean up the Movie/TV file names like Plex & XBMC do... so I don't have to manually clean them.  At present you see the raw file name with/without the extension of course.
  • Can you also please confirm... if I have ripped a DVD I own with chapters... will the same time increments be used or is your software generating the increments based on a business rule & will it support the thumb nails of the chapters.
  • How do I watch the Apple TV Media on my iPad or iPhone without using a Media Server like Plex
  • Finally, do you support the EyeTV file formats?

Thanks...

 

Submitted by ANtrah on September 10, 2011 - 4:41pm

Thanks,
Richard

 

Smile

Submitted by Anon on September 11, 2011 - 10:47pm

The update works fine for me on most files, except DVD rips (Video TS folders) where I can't get past 4 minutes without "Buffering" happening.

For instance a rip of The Simpsons Season 7 DVD had 9 instances of "Buffering".

My thoughts: until this is resolved, it's back to watching DVD's on my computer Frown

Submitted by Anon on September 13, 2011 - 6:10pm

hi there,

actually I have tried plenty of them, but the problem is still there.

Would you recommend one ?

(just in case, I have already upgraded for the latest version launched last week, problem still there).

thank you

Submitted by Anon on September 17, 2011 - 7:00pm

Hi, james, is the folder.jpg for movie folder supported on this latest version of the Media Player? I can see it working for some folders but not all - can't find out why. Thanks and great work!

Submitted by Dozer on October 6, 2011 - 8:04am

Apologies for the delay... I've now upgraded to media player 0.9 and have the same problem.

The DVD's are ones that I've ripped with mac the ripper and/or used an older version of toast.  But, I have the same problem with home DVD's, some of which start straight into the main feature as there are no menus.

When I try to play these with media player, it says loading and the time bar says there is 00:01 to play (on DVD's with a menu this shows the length of time the menu plays before restarting) and then it says there is a playback error - couldnt establish a connection.

I'm playing my DVD's from the VIDEO_TS folders on my NAS.  All work ok played through my iMac.

Regards,

Dozer.

Submitted by Anon on November 4, 2011 - 11:12pm

Absolutly loving this update!!! Best thing is grid view!!! So far is seems more stable than previous versions as I have had no problems yet! Fingers crossed!!! Now just waiting for apple to release a device that can play 1080p and I'll be a very happy chappy!!!! I'll have one on every tv in the house!!

Submitted by Anon on December 5, 2011 - 4:13pm

installed as per guide, can connect but cannot find the folder, just says nothing to play. Mac is sharing the folder, can't understand it. Any tips please?

Submitted by daniloss on December 20, 2011 - 10:56pm

hey james, what encoding type would you recommend to brazilian portuguese subtitles (.srt files)?

Submitted by Demenster on December 27, 2011 - 3:07pm

Hi, have set up my share, but there is no files showing in the player? please help? Using 4.4.4

Submitted by alexanders.4434 on January 8, 2012 - 12:42pm

Any news on the subtitles preset? Our ATV is set to German, but we watch all movies with cyrillic subs Frown

Submitted by Anon on November 9, 2012 - 12:43am

Can someone help me? I'm new to jailbreaking and got everything working on my atv2. I downloaded Media player through Maint, however when I try the 'add share' function it just keeps getting stuck on Other...like it won't locate my external hard drive that I have connected to my Air Port Extreme Network.